Doc bug: euca_conf --deregister-sc must be used with a cluster name

Bug #551778 reported by Thierry Carrez on 2010-03-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Invalid
Undecided
graziano obertelli
2.0
Fix Released
Low
graziano obertelli
eucalyptus (Ubuntu)
Low
Dustin Kirkland 
Lucid
Low
Dustin Kirkland 

Bug Description

According to man page, --deregister-sc takes a "host" as a parameter.

Trying:
$ sudo euca_conf --deregister-sc <HOSTorIP>
SUCCESS: Storage controller for cluster '<HOSTorIP>' successfully deregistered.

However it appears to not change anything.

According to Dan (comment 1) this is a documentation bug (parameter should be the cluster name and not the host). I find the euca_conf SUCCESS message is kinda misleading, since it seems to imply SUCCESS in the deregistration operation, but I can live with that :)

Daniel Nurmi (nurmi) wrote :

Thierry,

It looks as if this may be a documentation bug: --deregister-cluster and --deregister-sc takes the 'name' of the cluster, instead of the 'host' of the component. I just tested with using the cluster name in both cases, and de-registration is working. However, there are a few issues:

1.) euca_conf --help shows this:

   --deregister-cluster <clustername> remove cluster from EUCALYPTUS
   --deregister-sc <host> remove storage controller from EUCALYPTUS

which is correct for 'cluster', but not for 'sc'. I'll make this fix and commit to 1.6.2 shortly. The second is what to do in the case where a user inputs an IP instead of a name. The reason you're seeing 'success' is that de-registration is idempotent (i.e. when you de-register a cluster named '192.168.1.1', the system will return 'success' if, after the operation is performed, there is no cluster named '192.168.1.1' registered with the CLC). It may be worth putting in a warning if the string that is passed to euca_conf looks like an IP address, telling the user that they probably didn't mean to put in an IP (though, one can use such a string as the name of a cluster).

Thoughts?

-Dan

Thierry Carrez (ttx) wrote :

Ah, my bad. I originally looked at --deregister-sc options and tried both host and IP with what appeared to be success (but really was doing nothing), filed the bug, and then tried --deregister-cluster <IP>, thinking it would obey the same option...

Fixing description to reflect that this is a doc bug.

summary: - CCs or SCs cannot be deregistered
+ Doc bug: euca_conf --deregister-sc must be used with a cluster name
description: updated
Changed in eucalyptus (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in eucalyptus (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Dustin Kirkland (kirkland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2-0ubuntu30

---------------
eucalyptus (1.6.2-0ubuntu30) lucid; urgency=low

  * Cherry-pick merge from upstream 1.6.2, now on revision 1222
    - LP: #552883 - r1222, fix volume statistics
    - LP: #552829 - r1221, fix volume state
    - LP: #552115 - r1220, fix node registration when nc+cc colocated
    - LP: #551778 - r1219, fix sc documentation
    - LP: #545000 - r1218, fix bad bucket name handling
  * debian/control: recommend qemu-kvm, rather than kvm
  * eucalyptus-cc.install, eucalyptus-cc.links, rules, 15-eucalyptus-url:
    - relocate the help text and url to just after the 10-help-text links,
      and before 50-landscape-sysinfo, which should come after; also,
      install the script as a conffile in /etc, rather than a symlink
      which allows the admin to modify it without upgrades automatically
      stomping local changes, LP: #559194
  * 15-eucalyptus-url, eucalyptus-cc.install, eucalyptus-common.install:
    install in the eucalyptus-common package, improve logic of determining
    if on CLC
 -- Dustin Kirkland <email address hidden> Wed, 14 Apr 2010 13:48:48 -0500

Changed in eucalyptus (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in eucalyptus:
assignee: nobody → Mitch Garnaat (mitch-garnaat)
Changed in eucalyptus:
assignee: Mitch Garnaat (mitch-garnaat) → graziano obertelli (graziano.obertelli)

Checking against 2.0.3 shows that euca_conf both reports an error when using a non-registered SC and the --help page returns correctly that it accepts a clustername not a host or IP. Closing it.

Changed in eucalyptus:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers