VNET_PRIVINTERFACE is not set correctly in a multi-network install

Bug #534412 reported by Thierry Carrez on 2010-03-08
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Medium
Thierry Carrez
Lucid
Medium
Thierry Carrez

Bug Description

Installed the following topology:
( CLC+Walrus )<---network1--->eth0( CC+SC )eth1<---network2--->( NC )

Everything installed and auto-registered correctly. I registered an image and started it with success.
However it's impossible to access that instance (from the CLC or from the CC), trying to ping the private address or the public address of the instance fails (unreachable).

I traced it back to VNET_PRIVINTERFACE on the CC+SC, which is set to "eth0" in eucalyptus.conf (should be "eth1").

eucalyptus-udeb.finish-install calls "set_conf_var" to set VNET_PRIVINTERFACE, however since it's not present in eucalyptus.local.conf, the sed call won't modify it:
sed -i "s/^\\($1\\)=.*/\\1=\"$2\"/"

Setting it to "eth1" and rebooting seems to solve the issue.

Thierry Carrez (ttx) on 2010-03-08
Changed in eucalyptus (Ubuntu):
importance: Undecided → High
tags: added: kernel-series-unknown
tags: removed: kernel-series-unknown
Thierry Carrez (ttx) on 2010-03-10
Changed in eucalyptus (Ubuntu Lucid):
status: New → Confirmed
Thierry Carrez (ttx) on 2010-03-11
Changed in eucalyptus (Ubuntu Lucid):
assignee: nobody → Dustin Kirkland (kirkland)
importance: High → Medium
milestone: none → ubuntu-10.04-beta-1
Thierry Carrez (ttx) on 2010-03-17
Changed in eucalyptus (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Thierry Carrez (ttx) on 2010-03-18
Changed in eucalyptus (Ubuntu Lucid):
assignee: Dustin Kirkland (kirkland) → Thierry Carrez (ttx)
status: Confirmed → In Progress
Thierry Carrez (ttx) on 2010-03-19
Changed in eucalyptus (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2-0ubuntu19

---------------
eucalyptus (1.6.2-0ubuntu19) lucid; urgency=low

  * debian/eucalyptus-udeb.finish-install: Set VNET*INTERFACE at install-time
    in eucalyptus.conf so that they actually get set and a CC with two NICs
    works correctly (LP: #534412)
 -- Thierry Carrez <email address hidden> Fri, 19 Mar 2010 11:19:03 +0100

Changed in eucalyptus (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers