Missing jar file when Walrus/S3 runs on different host than CLC

Bug #516083 reported by Boris Devouge on 2010-02-02
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Medium
Dustin Kirkland 
Karmic
Medium
Dustin Kirkland 
Lucid
Medium
Dustin Kirkland 

Bug Description

Please see initial issue reported here:

http://open.eucalyptus.com/forum/walrus-configuration-failed-contact-server

When running Walrus/S3 services of a different machine than the Cloud controller (CLC), we are missing some jar files. We seems to assume that the Walrus/S3 services are running out of the CLC by default.

From the earlier referenced page:
"There is an issue, however, with starting standalone Eucalyptus components due to a missing file in the Ubuntu Karmic packages (we, the upstream, do not produce those packages).

Try purging all eucalyptus packages, go through the steps again, then manually copy /usr/share/eucalyptus/eucalyptus-interface-1.6-devel.jar from the CLC host to /usr/share/eucalyptus on the Walrus host, run "stop eucalyptus" and then "start eucalyptus" on the Walrus host."

Copying the /usr/share/eucalyptus/eucalyptus-interface-1.6-devel.jar to the walrus host fixes the problem.

=================
SRU NOTES
 * Impact
  * This bug affects any users where the eucalyptus-cloud package is installed on a separate system from other Eucalyptus components.
 * How Addressed
  * The eucalyptus-interface jar should be installed by the eucalayptus-java-common package, rather than the eucalyptus-cloud package.
 * Minimal Patch

diff -u eucalyptus-1.6~bzr931/debian/eucalyptus-cloud.install eucalyptus-1.6~bzr931/debian/eucalyptus-cloud.install
--- eucalyptus-1.6~bzr931/debian/eucalyptus-cloud.install
+++ eucalyptus-1.6~bzr931/debian/eucalyptus-cloud.install
@@ -3 +2,0 @@
-/usr/share/eucalyptus/eucalyptus-interface-1.6-devel.jar
diff -u eucalyptus-1.6~bzr931/debian/eucalyptus-java-common.install eucalyptus-1.6~bzr931/debian/eucalyptus-java-common.install
--- eucalyptus-1.6~bzr931/debian/eucalyptus-java-common.install
+++ eucalyptus-1.6~bzr931/debian/eucalyptus-java-common.install
@@ -10,6 +10,7 @@
 /usr/share/eucalyptus/eucalyptus-clustermgr-1.6-devel.jar
 /usr/share/eucalyptus/eucalyptus-keymgr-1.6-devel.jar
 /usr/share/eucalyptus/eucalyptus-config-1.6-devel.jar
+/usr/share/eucalyptus/eucalyptus-interface-1.6-devel.jar
 /etc/eucalyptus/cloud.d
 /usr/lib/eucalyptus/liblvm2control.so
 /var/lib/eucalyptus/modules

 * Reproduce Instructions
  * Install the eucalyptus-cloud on one system, and any of (eucalyptus-walrus, eucalyptus-sc, eucalyptus-cc) on a different system. Note that the file /usr/share/eucalyptus/eucalyptus-interface-1.6-devel.jar is missing on any of the systems where eucalyptus-cloud is NOT installed.
  * Upgrade to the new packages. Note that /usr/share/eucalyptus/eucalyptus-interface-1.6-devel.jar is now installed by eucalyptus-java-common with:
   * dpkg -S /usr/share/eucalyptus/eucalyptus-interface-1.6-devel.jar
 * Regression Potential
  * Minimal, I believe.
   * NB: One question for the SRU team... Is any debian/control magic required since we've moved the installation of this file from one binary package to another? It appears to me that upgrades are handled cleanly without it (at least the testing that I did).
=================

Boris Devouge (bdevouge) wrote :

Sorry, this is fully updated Ubuntu 9.10 amd64 as of 01 Feb 2010.

Dustin Kirkland  (kirkland) wrote :

$ dpkg -c eucalyptus-java-common_1.6.2~bzr1176-0ubuntu4_amd64.deb | grep interface
-rw-r--r-- root/root 10058 2010-02-05 23:23 ./usr/share/eucalyptus/eucalyptus-interface-1.6.2.jar

So eucalyptus-interface is now provided by eucalyptus-java-common in Lucid at least. eucalyptus-walrus depends on eucalyptus-java-common, so this should be installed on a walrus system. I really think this is fix-released on Lucid.

Boris, can you reproduce this problem on Lucid? If so, please reopen this bug, and I'll get it fixed.

Changed in eucalyptus (Ubuntu):
importance: Undecided → High
importance: High → Medium
status: New → Triaged
assignee: nobody → Dustin Kirkland (kirkland)
status: Triaged → Fix Released
Changed in eucalyptus (Ubuntu Karmic):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Dustin Kirkland (kirkland)
Boris Devouge (bdevouge) wrote :

Thanks Dustin. I hope to be able to get hardware for a Lucid cloud soon, in the meantime i have not reproduced it yet, but i have verified as you have that eucalyptus-interface-1.6.2.jar is indeed packaged in eucalyptus-java-common_1.6.2.

As for Karmic, this is only about repackaging eucalyptus-java-common to include the eucalyptus-interface jar file, or is there more to it?

Thanks !

Boris-

That's it. Very simple 2-line patch, moving the installation from one
binary package to the other.

Dustin Kirkland  (kirkland) wrote :

Uploaded to karmic-proposed, awaiting acceptance into that archive.

Please test those packages and verify the fix ASAP.

Changed in eucalyptus (Ubuntu Karmic):
status: In Progress → Fix Committed
description: updated
John Dong (jdong) wrote :

ACK from ubuntu-sru

Martin Pitt (pitti) wrote :

I rejected the karmic-proposed upload:

 * You move a file without adding the required versioned "Conflicts:/Replaces:" to eucalyptus-java-common (where the file moved to).

 * It references bug 519877 which is private.

 * It references two other bugs which are called duplicates in the changelog. Please just make the other three bugs duplicates of this one, to have all affected people communicate here (in particular for testing feedback).

Changed in eucalyptus (Ubuntu Karmic):
status: Fix Committed → In Progress
Dustin Kirkland  (kirkland) wrote :

Thanks, Martin. I have re-uploaded a version that I think addresses
your concerns.

Accepted eucalyptus into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in eucalyptus (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Dustin Kirkland  (kirkland) wrote :

This upload has been in karmic-proposed for 6 weeks now...

Could someone please test that package, and note that the issue is fixed so that we can get this rolled out to karmic-updates?

Thanks.

Boris Devouge (bdevouge) wrote :

As far as the new package containing the eucalyptus-interface jar file, this is verified, and also fixes this escalation bug (package respin).

Martin Pitt (pitti) on 2010-04-13
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr931-0ubuntu7.6

---------------
eucalyptus (1.6~bzr931-0ubuntu7.6) karmic-proposed; urgency=low

  * debian/control, debian/eucalyptus-java-common.install,
    debian/eucalyptus-cloud.install: the common java package should
    install the eucalyptus-interface jar (otherwise walrus cannot run
    on a separate host from the clc), LP: #516083
 -- Dustin Kirkland <email address hidden> Thu, 04 Mar 2010 10:15:04 -0600

Changed in eucalyptus (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers