Publication jobs don't start after package install

Bug #504326 reported by Mathias Gug on 2010-01-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Low
Thierry Carrez
Lucid
Low
Thierry Carrez

Bug Description

When installing eucalyptus-* packages, *-publication jobs are not started. Thus autoregistration fails for package-based installation.

Mathias Gug (mathiaz) wrote :

One solution could be to drop the --noscripts option from dh_installinit in debian/rules so that relevant upstart jobs are actually started on package installation.

Thierry Carrez (ttx) wrote :

One issue is that even if publication was run, autoregistration would fail because the upstream credentials are missing from eucalyptus authorized_keys...

Changed in eucalyptus (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed

On Thu, Jan 07, 2010 at 07:42:31PM -0000, Thierry Carrez wrote:
> One issue is that even if publication was run, autoregistration would
> fail because the upstream credentials are missing from eucalyptus
> authorized_keys...
>

Right. Could the publication job be only started if the credentials are
available?

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

It could poll for key presence in a loop in pre-start.

Thierry Carrez (ttx) wrote :

Created bug 513722 to specifically track "Publication jobs should not start if authorized_keys is missing"
This bug is about triggering the publication upstart jobs on package install.

I see why --noscripts is used on the other upstart scripts (they handle their start themselves), but it doesn't seem warranted for the *publication.upstart ones (which don't have a postinst).

summary: - publication won't happen on package install
+ Publication jobs don't start after package install
Changed in eucalyptus (Ubuntu):
status: Confirmed → Triaged

Could be solved with a similar method to that proposed in Bug #503180, where we depend on an event, which a psuedo upstart job that loops until it can emit such a signal.

summary: - Publication jobs don't start after package install
+ Publication jobs don't start after package install (upstart issues)
Changed in eucalyptus (Ubuntu):
milestone: none → lucid-alpha-3
Thierry Carrez (ttx) wrote :

This is not a duplicate of upstart issues.
The issue here is that publication.upstart jobs are installed --noscripts, which prevents them from starting up right after package install.
I'd agree that bug 513722, which is about what the publication job should do, could be solved in a common way with bug 503180. But this one is just an installer failure, not an upstart issue.

summary: - Publication jobs don't start after package install (upstart issues)
+ Publication jobs don't start after package install
Thierry Carrez (ttx) on 2010-02-02
Changed in eucalyptus (Ubuntu Lucid):
assignee: nobody → Thierry Carrez (ttx)
importance: Medium → Low
status: Triaged → In Progress
Thierry Carrez (ttx) on 2010-02-11
Changed in eucalyptus (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2~bzr1189-0ubuntu1

---------------
eucalyptus (1.6.2~bzr1189-0ubuntu1) lucid; urgency=low

  [ Thierry Carrez ]
  * debian/rules: Start publication jobs on package install (LP: #504326)
  * debian/*publication.upstart: Do not advertise Walrus, SC, CC or NC if
    eucalyptus authorized_keys is missing, since autoregistration would then
    partially fail (LP: #513722)

  [ Dustin Kirkland ]
  * Merge from upstream bzr revision, should fix:
    - LP: #453416 - fix metadata subdirectory lists
    - LP: #513842 - fix metadata ephemeral verbage
 -- Dustin Kirkland <email address hidden> Thu, 11 Feb 2010 16:32:06 -0600

Changed in eucalyptus (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers