eucalyptus 1.6.2 should not depend on ietadm, iscsitarget

Bug #497196 reported by Dustin Kirkland  on 2009-12-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
High
Unassigned

Bug Description

ietadm is in /usr/sbin/ietadm, which is not in the eucalyptus user's default PATH.

This is causing the following errors in /var/log/eucalyptus/cloud-error.log:
com.eucalyptus.util.EucalyptusCloudException: ietadm not found: Is iscsitarget installed?
        at edu.ucsb.eucalyptus.storage.ISCSIManager.checkPreconditions(ISCSIManager.java:64)
        at edu.ucsb.eucalyptus.storage.LVM2Manager.checkPreconditions(LVM2Manager.java:145)
        at com.eucalyptus.bootstrap.BlockStorageBootstrapper.load(BlockStorageBootstrapper.java:99)
        at com.eucalyptus.bootstrap.SystemBootstrapper.load(SystemBootstrapper.java:180)
16:41:00 [SystemUtil:main] ERROR com.eucalyptus.util.ExecutionException: ///usr/lib/eucalyptus/euca_rootwrap ietadm --version

eucalyptus@aussie:~$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

This can be solved either by adding /usr/sbin to eucalyptus' PATH, or by fully qualifying the ietadm binary in the eucalyptus source code.

Either way, this should be solved programmatically for UEC.

Dustin Kirkland  (kirkland) wrote :

Hmm, actually, it doesn't look like there's any ~eucalyptus/.bashrc at all. This seems like a bad thing, no?

Changed in eucalyptus (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Dustin Kirkland  (kirkland) wrote :

Rather, since it's euca_rootwrapped, it need an entry in /etc/eucalyptus/euca_rootwrap.

summary: - ietadm not in the eucalyptus user's path
+ /usr/sbin/ietadm needs to be added to wrappers.conf
summary: - /usr/sbin/ietadm needs to be added to wrappers.conf
+ eucalyptus 1.6.2 should not depend on ietadm, iscsitarget
Changed in eucalyptus (Ubuntu):
importance: Medium → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2~bzr1103-0ubuntu1

---------------
eucalyptus (1.6.2~bzr1103-0ubuntu1) lucid; urgency=low

  [ Dustin Kirkland ]
  * Merge from Lucid's 1.6.1 tree, pull Colin's registration magic
  * Merge from upstream 1.6.2 tree
    - eucalyptus-cloud.install, eucalyptus-common.eucalyptus.upstart,
      eucalyptus-java-common.install, eucalyptus-sc.install,
      eucalyptus-walrus.install: jars are now named *-1.6.2.jar
    - debian/eucalyptus-java-common.install: db is packaged independently now,
      make sure this gets installed
    - debian/eucalyptus-java-common.links: install proxool.jar link
  * debian/eucalyptus-common.postinst: remove incorrect
    'dpkg-statoverride --add' calls, clean up existing ones, (LP: #437012)
  * Improve lintian cleanliness of this package
    - debian/control: bump standards version, no changes necessary
    - debian/README.source: add patch info
    - debian/eucalyptus-cc.templates, debian/eucalyptus-udeb.templates: drop
      useless imperative, fix too-long descriptions
    - debian/eucalyptus-cc.postinst, debian/eucalyptus-cloud.postinst,
      debian/eucalyptus-cloud.postrm, debian/eucalyptus-common.postinst,
      debian/eucalyptus-common.postrm, debian/eucalyptus-nc.config,
      debian/eucalyptus-nc.postinst: fix maintainer-script-ignores-errors
      lintian errors, this will need some testing and will probably
      involve some (needed) error handling in the maintainer scripts
    - debian/eucalyptus-common.install: fix lintian dir-or-file-in-var-run;
      create in the upstart script, rather than the install file
    - debian/control: fix lintian python-script-but-no-python-dep;
      depend on python
    - debian/eucalyptus-nc.postinst: fix postinst-does-not-load-confmodule,
      source it
    - debian/registration/common: fix script-not-executable, make executable
  * util/wrappers.conf: add /usr/sbin/ietadm, (LP: #497196)
  * clc/modules/bootstrap/eucalyptus-bootstrap.c: disable iscsi, (LP: #497196)
  * clc/modules/configuration/src/main/java/com/eucalyptus/config/Configuration.java:
    revert r582, as this is appropriately addressed now, no need to comment
    out this code
  * clc/modules/wsstack/src/main/java/com/eucalyptus/ws/handlers/WalrusRESTBinding.java:
    fix minor whitespace diff against upstream
  * debian/control, debian/eucalyptus-nc.eucalyptus-nc-publication.upstart,
    debian/eucalyptus-nc.install, debian/eucalyptus-nc.upstart, debian/rules:
    migrate the NC init to upstart, LP: #438631
  * debian/30-eucalyptus-nc.conf, debian/eucalyptus-nc.install,
    debian/eucalyptus-nc.upstart: use sysctl to load the eucalyptus-nc
    networking settings

  [ Thierry Carrez ]
  * Move eucalyptus-interface-1.6-devel.jar from eucalyptus-cloud to
    eucalyptus-java-common, since it is needed on Walrus and SC (LP: #494765)
  * Fix dependencies: Remove c3p0 dependencies, add proxool, woodstox and
    euca-commons-ext >=0.5.0

  [ Mathias Gug ]
  * debian/control: Add wget as an eucalyptus-cc dependency (required by
    eucalyptus-cc upstart job).
 -- Dustin Kirkland <email address hidden> Thu, 17 Dec 2009 18:22:02 -0600

Changed in eucalyptus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers