eucalyptus CLEAN=1 should also be supported in start

Bug #491254 reported by Thierry Carrez on 2009-12-02
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
High
Dustin Kirkland 
Karmic
High
Dustin Kirkland 
Lucid
High
Dustin Kirkland 

Bug Description

CLEAN=1 support has been implemented as part of bug 460089, to avoid cleaning up the CC network state at each restart. A CLEAN=1 option was added to the post-stop in eucalyptus-cc.conf. A similar option should be added to the pre-start so that CLEAN=1 is also supported at start. That will mimic what the eucalyptus init script provides (cleanstart and cleanstop).

===============
SRU Testing

MINIMAL PATCH:
http://bazaar.launchpad.net/~ubuntu-core-dev/eucalyptus/ubuntu-karmic/revision/727

IMPACT:
 When we converted the Eucalyptus init scripts to upstart jobs, we lost some functionality. The initscripts supported a few additional actions, namely: cleanstop, cleanstart, cleanrestart. These "clean" action would actually clear out the CC's state from /var/lib/eucalyptus/CC. We should *not* do this in the default case, but we *should* provide a convenient, documented mechanism for administrators to do the "clean" restart process. This update restores that functionality.

TEST CASE:
 After installing/upgrading the -proposed eucalyptus packages:
 1) Open a window on the CLC/CC, and watch the contents of /var/lib/eucalyptus/CC:
  $ watch -n1 sudo ls -alF /var/lib/eucalyptus/CC
 2) Perform each of the following actions, ensuring that the files in /var/lib/eucalyptus/CC are NOT removed:
  $ sudo restart eucalyptus
  $ sudo stop eucalyptus
  $ sudo start eucalyptus
  $ sudo restart eucalyptus-cc
  $ sudo stop eucalyptus-cc
  $ sudo start eucalytus-cc
 3) Now perform each of the following actions, ensure that the files in /var/lib/eucalyptus/CC ARE in fact removed at each operation:
  $ sudo restart eucalyptus CLEAN=1
  $ sudo stop eucalyptus CLEAN=1
  $ sudo start eucalyptus CLEAN=1
  $ sudo restart eucalyptus-cc CLEAN=1
  $ sudo stop eucalyptus-cc CLEAN=1
  $ sudo start eucalyptus-cc CLEAN=1

REGRESSION POTENTIAL:
Regression potential is rather low. The behavior is only changed when CLEAN=1 is passed to any of the eucalyptus scripts. We have only recently documented this behavior. It is intended to restore some functionality that was lost as of 9.10 GA when the eucalyptus init scripts were replaced by upstart jobs.
===============

Thierry Carrez (ttx) on 2009-12-02
Changed in eucalyptus (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Changed in eucalyptus (Ubuntu):
assignee: nobody → Dustin Kirkland (kirkland)
Changed in eucalyptus (Ubuntu Karmic):
status: New → In Progress
importance: Undecided → High
Changed in eucalyptus (Ubuntu Lucid):
status: Triaged → In Progress
importance: Wishlist → High
Changed in eucalyptus (Ubuntu Karmic):
assignee: nobody → Dustin Kirkland (kirkland)
milestone: none → karmic-updates
description: updated
Changed in eucalyptus (Ubuntu Karmic):
status: In Progress → Fix Committed
Changed in eucalyptus (Ubuntu Lucid):
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2009-12-03
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.1~bzr1083-0ubuntu2

---------------
eucalyptus (1.6.1~bzr1083-0ubuntu2) lucid; urgency=low

  * debian/patches/06-symlinked-jars.patch: drop patch from source; this
    patch hasn't been in the series file for a while now
  * debian/patches/axis2c_home_init.diff:
    - Dropping the httpd.conf part of this patch, since our upstart
      script handles this properly. +
    - Dropping the tools/eucalyptus-cc.in part of this patch, since
      we no longer use the eucalyptus-cc init script.
    - The tools/eucalyptus-nc.in patch should be dropped as soon as
      it's converted to an upstart script (which will need to handle
      AXIS2C_HOME correctly), see lp#438631
  * debian/patches/02-rely-on-libvirt-defaults.patch: add some documentation
    in this patches headers
  * debian/patches/var_lib_eucalyptus.diff: drop patch from source; this
    patch hasn't been in the series file for a while now
  * debian/patches/euca_conf-error-output.diff, debian/series,
    tools/euca_conf.in:
    - drop this patch from our series
    - apply directly to the branch, cleaning up wget error printing
    - upstream has agreed to take this, and fix this globally in their
      source
  * aclocal.m4, debian/patches/05-axis-alternative-repository.patch,
    debian/patches/series:
    - drop this patch from our series
    - apply directly to the branch, to support pkg-config
    - upstream cannot take this because not all distros will be able to
      depend on pkg-config
  * debian/patches/03-DESTDIR.patch: Eucalyptus will take this upstream;
    should be dropped from the Ubuntu branch as soon as they do
  * debian/eucalyptus-cc.upstart, debian/eucalyptus-common.eucalyptus.upstart:
    support CLEAN=1 on start/stop/restart of eucalyptus/euclayptus-cc; export
    the CLEAN env variable in eucalyptus.init, and handle it in both the
    pre-start and post-stop sections of eucalyptus-cc, (LP: #491254)
 -- Dustin Kirkland <email address hidden> Thu, 03 Dec 2009 07:29:32 -0600

Changed in eucalyptus (Ubuntu Lucid):
status: Fix Committed → Fix Released

Accepted eucalyptus into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Dustin Kirkland  (kirkland) wrote :

Martin-

I have tested the packages in -proposed according to the instructions above.

They solve the problem as described in the bug, and do not cause regressions in my experience. I think you can mark this one verification-done.

Thanks.

Martin Pitt (pitti) on 2009-12-04
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr931-0ubuntu7.4

---------------
eucalyptus (1.6~bzr931-0ubuntu7.4) karmic-proposed; urgency=low

  [ Thierry Carrez ]
  * cluster/handlers.c: Cherrypick upstream r946: initialize axis2c in the CC
    for each NC client connection, to avoid rampart memory leak (LP: #460085)
  * clc/modules/wsstack/src/main/java/com/eucalyptus/ws/handlers/HmacV2Handler.java:
    Cherrypick upstream r1079: Fix authentication issue when using a euca2ools
    that doesn't double base64encode userdata (LP: #461156)

  [ Dustin Kirkland ]
  * debian/eucalyptus-cc.upstart, debian/eucalyptus-common.eucalyptus.upstart:
    support CLEAN=1 on start/stop/restart of eucalyptus/euclayptus-cc; export
    the CLEAN env variable in eucalyptus.init, and handle it in both the
    pre-start and post-stop sections of eucalyptus-cc, (LP: #491254)
 -- Dustin Kirkland <email address hidden> Wed, 02 Dec 2009 17:58:18 -0600

Changed in eucalyptus (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers