improve wsdl stubs generation

Bug #487270 reported by Dustin Kirkland  on 2009-11-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Undecided
Daniel Nurmi
eucalyptus (Ubuntu)
High
Dustin Kirkland 

Bug Description

For various reasons, the Ubuntu eucalyptus package is required to carry a giant, machine generated patch providing WSDL stubs:

debian/patches/01-wsdl-stubs.patch
-rw-r--r-- 1 kirkland kirkland 14M 2009-10-07 10:15 01-wsdl-stubs.patch
  324708 1021262 14314930 01-wsdl-stubs.patch
 351 files changed, 322953 insertions(+)

This is non-ideal for various reasons.

We discussed two possibilities at UDS-Dallas:
   * package a subset of axis2 to be able to generate the stub during the build process (proposal)
   * generate the stub as part of the upstream source release process

I believe that we loosely converged on the second of these two options, for the Lucid cycle.

I'm opening this bug for the sake of tracking this work, and any further discussions about the most appropriate approach.

Changed in eucalyptus (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Dustin Kirkland (kirkland)
Changed in eucalyptus:
status: New → Confirmed
assignee: nobody → Daniel Nurmi (nurmi)
Changed in eucalyptus (Ubuntu):
milestone: none → lucid-alpha-2
Dustin Kirkland  (kirkland) wrote :

Dan Nurmi indicated that the carried patch could be eliminated, and instead generated at build time if some axis2 (??) package were in main instead of universe, and eucalyptus could build-depend on it, rather than the eucalyptus package maintainer installing this universe package on his local system and generating the patch.

I'm still learning about this WSDL-stubs issue, but I'm trying to document my understanding here in this bug.

Looking through the archive for what package Dan is talking about --->

$ apt-cache search axis2 | awk '{print $1}' | xargs -i apt-cache show {} | grep Filename
Filename: pool/main/a/axis2c/libapache2-mod-axis2c_1.6.0-0ubuntu7_amd64.deb
Filename: pool/main/a/axis2c/libaxis2c-dev_1.6.0-0ubuntu7_amd64.deb
Filename: pool/main/a/axis2c/libaxis2c-doc_1.6.0-0ubuntu7_all.deb
Filename: pool/main/a/axis2c/libaxis2c0_1.6.0-0ubuntu7_amd64.deb
Filename: pool/main/r/rampart/librampart-doc_1.3.0-0ubuntu5_amd64.deb
Filename: pool/universe/a/axis2c/libaxis2c-bin_1.6.0-0ubuntu7_amd64.deb <------------
Filename: pool/main/r/rampart/librampart0_1.3.0-0ubuntu5_amd64.deb
Filename: pool/main/r/rampart/librampart-dev_1.3.0-0ubuntu5_amd64.deb

I only see one axis2c-related package that's in universe, libaxis2c-bin.

Is it not possible/practical to get this package promoted to Main for Lucid? Thierry, do you know?

Changed in eucalyptus (Ubuntu):
status: Triaged → Incomplete
Thierry Carrez (ttx) wrote :

The patch is generated using WSDL2C.sh, which uses a Java axis library. My understanding was that we would have to package a new Axis2/Java library to do this, which is a non-trivial amount of work.
If that's the only option, I'd consider generating the patch as part of the upstream source generation process, as already discussed.
If Dan means that the current libaxis-java is enough to use WSDL2C, then it's already in main.
Or something else ?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2~bzr1120-0ubuntu2

---------------
eucalyptus (1.6.2~bzr1120-0ubuntu2) lucid; urgency=low

  * Merge debian/patches into the branch, since we're using bzr for merging:
    - debian/patches/axis2c_home_init.diff, debian/patches/series,
      tools/httpd.conf: change the location of the Axis2 Apache module to
      match what is provided by the libapache2-mod-axis2c package, from
      Thierry Carrez <email address hidden> -- 7 Dec 2009
    - debian/patches/series, tools/gen_kvm_libvirt_xml: Ubuntu prefers to
      rely on libvirt's default choosing of the appropriate hypervisor, from
      Dustin Kirkland <email address hidden> -- 2 Dec 2009
    - Makefile, clc/build.xml, clc/modules/bootstrap/Makefile,
      clc/modules/module-inc.xml,
      clc/modules/storage-controller/native/Makefile,
      clc/modules/www/build.xml, cluster/Makefile,
      debian/patches/03-DESTDIR.patch, debian/patches/series,
      gatherlog/Makefile, node/Makefile, tools/Makefile, util/Makefile:
      + this patch makes the eucalyptus installation work with a configurable
        destination directory, much better for packaging
      + this patch should be applied upstream (Dan Nurmi agreed to do so),
        in which case we should get back in sync
  * debian/rules, debian/wsdl.md5sums, debian/wsdl_generator: improve wsdl
    stubs (LP: #487270);
    - fail build if wsdl stubs need to be updated
    - create a script that verbosely automates wsdl stub generation for
      package maintainer(s)
  * debian/patches/01-wsdl-stubs.patch, debian/wsdl.md5sums: wsdl stubs updated
 -- Dustin Kirkland <email address hidden> Mon, 04 Jan 2010 11:24:00 -0600

Changed in eucalyptus (Ubuntu):
status: Incomplete → Fix Released
Changed in eucalyptus:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers