Eucalyptus avahi publication jobs failed to restart if avahi-daemon is restarted

Bug #480885 reported by Mathias Gug on 2009-11-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Low
Unassigned
Karmic
Low
Mathias Gug

Bug Description

If avahi-daemon is restarted (for example during an avahi-daemon package update) eucalyptus avahi publication jobs aren't restarted.

==========
Karmic SRU

Impact:
If avahi publication jobs are not running, the cluster controller cannot be located by the installer when additional node controllers are deployed.

How the bus has been addressed:
A respawn statement has been added to the upstart jobs.

TEST CASE:
1. Install eucalytpus-cc.
2. Check that 1 avahi-publish process is running and note its pids:

$ ps -ef | grep avahi-publish
root 1385 1 0 18:25 ? 00:00:00 avahi-publish -s 192.168.12.117 _eucalyptus._tcp 8774 txtvers=1 protovers=1.5.0 type=cluster

3. Restart avahi-daemon (to simulate an update):

$ sudo restart avahi-daemon

4. Before the update, avahi-publish processes are no longer there. After the upgrade, new avahi-publish processes have been started.

Potential of regression:
If avahi-daemon is manually stopped, upstart will try to restart the publication jobs until it stops respawning them:
init: eucalyptus-cc-publication main process (8593) terminated with status 1
init: eucalyptus-cc-publication respawning too fast, stopped
Restarting avahi-daemon manually will not start the publication jobs which need to be start manually as well. However this is not a regression from the current version in Karmic.

Mathias Gug (mathiaz) on 2009-11-11
Changed in eucalyptus (Ubuntu Karmic):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Mathias Gug (mathiaz)
Changed in eucalyptus (Ubuntu):
status: New → Triaged
importance: Undecided → Low

Accepted eucalyptus into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in eucalyptus (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Thierry Carrez (ttx) on 2009-11-13
Changed in eucalyptus (Ubuntu Karmic):
milestone: none → karmic-updates
Mathias Gug (mathiaz) on 2009-11-14
description: updated
Mathias Gug (mathiaz) wrote :

1.6~bzr931-0ubuntu7: Fail
1.6~bzr931-0ubuntu7.3: Pass.

However the publication jobs may be respawned too fast and upstart would stop them before avahi-daemon is running - this is a race condition between avahi-daemon being ready and avahi-publish jobs being respawned too fast.

However it's not a regression from the version in release since publication jobs would never be automatically restarted. With the update publication jobs may not be started.

Martin Pitt (pitti) on 2009-11-20
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr931-0ubuntu7.3

---------------
eucalyptus (1.6~bzr931-0ubuntu7.3) karmic-proposed; urgency=low

  * debian/eucalyptus-cc.postinst: restart avahi daemon so that it uses
    eucalyptus specific configuration file (LP: #458904).
  * debian/eucalyptus-cc.eucalyptus-cc-publication{,-ip}.upstart: Respawn
    avahi publication jobs if they die (LP: #480885).

eucalyptus (1.6~bzr931-0ubuntu7.2) karmic-proposed; urgency=low

  [ Dustin Kirkland ]
  * cluster/handlers.c: euca_rootwrap rework did not whitelist powerwake;
    however, powerwake does *not* need root privs, drop euca_rootwrap wrapper
    (LP: #458163)
  * debian/rules, debian/euclayptus-cc.install: install the avahi-daemon.conf
    in /etc/eucalyptus, (LP: #458904).

  [ Thierry Carrez ]
  * clc/modules/www/src/main/java/edu/ucsb/eucalyptus/admin/public/EucalyptusWebInterface.html:
    Fix HTML title in the web UI for more consistency in naming (LP: #455293)
  * debian/eucalyptus-common.eucalyptus.upstart: Add -l to eucalyptus-cloud
    options so that cloud-output.log is affected by LOGLEVEL (LP: #458001)

  [ Mathias Gug ]
  * cluster/handlers.c: Fix the networkIndex returned by describeInstances.
    (LP: #454405 - upstream revno 933).
  * debian/eucalyptus-cc.eucalyptus-cc-publication{,-ip}.upstart: add an
    upstart job to explicitly publish the IP/CC hostname mapping via avahi
    instead of publishing the CC IP address via the service name (LP: #458904).
  * debian/avahi-daemon.conf: ship a specific avahi-daemon configuration file
    that doesn't publish IP addresses by default. (LP: #458904).
  * debian/eucalyptus-cloud.postinst: Fix postfix configuration to accept
    confirmation emails sent by eucalyptus (LP: #459101)
  * debian/eucalyptus-cc.upstart: Don't clean the CC network state when the CC is
    stopped by default (LP: #460089).
 -- Mathias Gug <email address hidden> Wed, 11 Nov 2009 15:15:48 -0500

Changed in eucalyptus (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

I copied the karmic-proposed package to lucid. Ffor karmic-updates it is still missing two verifications.

Changed in eucalyptus (Ubuntu):
status: Triaged → Fix Released
Changed in eucalyptus (Ubuntu Karmic):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr931-0ubuntu7.3

---------------
eucalyptus (1.6~bzr931-0ubuntu7.3) karmic-proposed; urgency=low

  * debian/eucalyptus-cc.postinst: restart avahi daemon so that it uses
    eucalyptus specific configuration file (LP: #458904).
  * debian/eucalyptus-cc.eucalyptus-cc-publication{,-ip}.upstart: Respawn
    avahi publication jobs if they die (LP: #480885).

eucalyptus (1.6~bzr931-0ubuntu7.2) karmic-proposed; urgency=low

  [ Dustin Kirkland ]
  * cluster/handlers.c: euca_rootwrap rework did not whitelist powerwake;
    however, powerwake does *not* need root privs, drop euca_rootwrap wrapper
    (LP: #458163)
  * debian/rules, debian/euclayptus-cc.install: install the avahi-daemon.conf
    in /etc/eucalyptus, (LP: #458904).

  [ Thierry Carrez ]
  * clc/modules/www/src/main/java/edu/ucsb/eucalyptus/admin/public/EucalyptusWebInterface.html:
    Fix HTML title in the web UI for more consistency in naming (LP: #455293)
  * debian/eucalyptus-common.eucalyptus.upstart: Add -l to eucalyptus-cloud
    options so that cloud-output.log is affected by LOGLEVEL (LP: #458001)

  [ Mathias Gug ]
  * cluster/handlers.c: Fix the networkIndex returned by describeInstances.
    (LP: #454405 - upstream revno 933).
  * debian/eucalyptus-cc.eucalyptus-cc-publication{,-ip}.upstart: add an
    upstart job to explicitly publish the IP/CC hostname mapping via avahi
    instead of publishing the CC IP address via the service name (LP: #458904).
  * debian/avahi-daemon.conf: ship a specific avahi-daemon configuration file
    that doesn't publish IP addresses by default. (LP: #458904).
  * debian/eucalyptus-cloud.postinst: Fix postfix configuration to accept
    confirmation emails sent by eucalyptus (LP: #459101)
  * debian/eucalyptus-cc.upstart: Don't clean the CC network state when the CC is
    stopped by default (LP: #460089).
 -- Mathias Gug <email address hidden> Wed, 11 Nov 2009 15:15:48 -0500

Changed in eucalyptus (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers