euca-register fails with syntax error

Bug #480048 reported by Torsten Spindler on 2009-11-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Eucalyptus
New
Undecided
chris grzegorczyk
eucalyptus (Ubuntu)
Low
Unassigned

Bug Description

After creating a homemade Karmic image with vmbuilder, it fails to register with:

euca-register karmic-homemade/root.img.manifest.xml
Warning: failed to parse error message from AWS: <unknown>:1:49: syntax error
Traceback (most recent call last):
  File "/usr/bin/euca-register", line 95, in <module>
    main()
  File "/usr/bin/euca-register", line 87, in main
    euca.display_error_and_exit('%s' % ex)
  File "/usr/lib/python2.6/dist-packages/euca2ools/__init__.py", line 996, in display_error_and_exit
    dom = minidom.parseString(msg)
  File "/usr/lib/python2.6/xml/dom/minidom.py", line 1928, in parseString
    return expatbuilder.parseString(string)
  File "/usr/lib/python2.6/xml/dom/expatbuilder.py", line 940, in parseString
    return builder.parseString(string)
  File "/usr/lib/python2.6/xml/dom/expatbuilder.py", line 223, in parseString
    parser.Parse(string, True)
xml.parsers.expat.ExpatError: syntax error: line 1, column 49

Torsten Spindler (tspindler) wrote :

Here the relevant parts from history:

   64 export http_proxy=http://10.153.104.60:3128
   65 sudo vmbuilder xen ubuntu
   66 sudo vmbuilder xen ubuntu --part ./part --firstboot ./firstboot
   67 ls
   68 euca-bundle-image -i ubuntu-xen/root.img
   69 euca-upload-bundle -m /tmp/root.img.manifest.xml -n karmic-homemade
   70 euca-upload-bundle -m /tmp/root.img.manifest.xml -b karmic-homemade
   71 euca-register karmic-homemade/root.img.manifest.xml
   72 euca-upload-bundle -m /tmp/root.img.manifest.xml -b karmic-homemade
   73 euca-register karmic-homemade/root.img.manifest.xml
   74 history

Torsten Spindler (tspindler) wrote :

Here the image manifest.

Torsten Spindler (tspindler) wrote :

This might be unrelated to euca-register, I get the same error with euca-describe-availability-zones:

$ euca-describe-availability-zones
Warning: failed to parse error message from AWS: <unknown>:1:49: syntax error
Traceback (most recent call last):
  File "/usr/bin/euca-describe-availability-zones", line 106, in <module>
    main()
  File "/usr/bin/euca-describe-availability-zones", line 102, in main
    euca.display_error_and_exit('%s' % ex)
  File "/usr/lib/python2.6/dist-packages/euca2ools/__init__.py", line 996, in display_error_and_exit
    dom = minidom.parseString(msg)
  File "/usr/lib/python2.6/xml/dom/minidom.py", line 1928, in parseString
    return expatbuilder.parseString(string)
  File "/usr/lib/python2.6/xml/dom/expatbuilder.py", line 940, in parseString
    return builder.parseString(string)
  File "/usr/lib/python2.6/xml/dom/expatbuilder.py", line 223, in parseString
    parser.Parse(string, True)
xml.parsers.expat.ExpatError: syntax error: line 1, column 49

Torsten Spindler (tspindler) wrote :

After a reboot, 'euca-describe-availability-zones verbose' worked fine. 'euca-register' still fails, with a different error:

$ euca-register karmic-homemade/root.img.manifest.xmlWarning: failed to parse error message from AWS: <unknown>:1:0: syntax error
EC2ResponseError: 403 Forbidden
Failure: 403 Forbidden

Torsten Spindler (tspindler) wrote :

After a wait the last error went away and euca-register worked.

Thierry Carrez (ttx) wrote :

Looks like a duplicate of bug 444352
Could you check out your logs for DEADLOCK entries ?

Changed in eucalyptus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Torsten Spindler (tspindler) wrote :

grep -i deadlock /var/log/eucalyptus/* > /tmp/deadlock

Changed in eucalyptus:
assignee: nobody → chris grzegorczyk (chris-grze)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2~bzr1136-0ubuntu3

---------------
eucalyptus (1.6.2~bzr1136-0ubuntu3) lucid; urgency=low

  * eucalyptus-cc.eucalyptus-cc-publication.upstart,
    eucalyptus-common.eucalyptus.upstart, eucalyptus-network.upstart,
    eucalyptus-sc.eucalyptus-sc-publication.upstart,
    eucalyptus-walrus.eucalyptus-walrus-publication.upstart, rules: rework
    our eucalyptus starting condition to depend on a new upstart emitted
    signal, eucalyptus-network-is-ready, which is only fired once the
    network interface providing the default route is in fact up, and
    listening on a real ip address, LP: #503180
  * debian/eucalyptus-common.eucalyptus.upstart:
    - don't respawn eucalyptus-cloud
    - ensure that the iptables module gets loaded soon enough, otherwise
      much bad behavior happens in various nasty ways, most notably, a
      wedged database which renders the CLC non responsive on restart/reboot,
      LP: #503180 and dupes, LP: #444352, #444946, #467521, #478573, #480048
 -- Dustin Kirkland <email address hidden> Tue, 02 Feb 2010 17:13:52 -0800

Changed in eucalyptus (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers