eucalyptus services won't register

Bug #478573 reported by DarkJavi on 2009-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Medium
Unassigned

Bug Description

Got 2 karmic's boxes, one with VT extensions and I'm trying to test eucalyptus following this guide https://help.ubuntu.com/community/UEC/PackageInstall.
When it comes to "sudo start eucalyptus-cc-registration"
i got an
start: Job failed to start
logfiles says
ERROR: you need to be on the CLC host and the CLC needs to be running.

I've tried to set ip manually on /etc/eucalyptus/eucalyptus-ipaddr.conf
CC_IP_ADDR="10.0.10.150"
WALRUS_IP_ADDR="10.0.10.150"
SC_IP_ADDR="10.0.10.150"
CLOUD_IP_ADDR="10.0.10.150"
but no luck.

First tried to install the whole system on the VT machine, when failed, purged everything and moved fronted to another machine with the same result.

What could i do?

Attached a "cat /var/log/eucalyptus/*"

ProblemType: Bug
.etc.eucalyptus.eucalyptus.cc.conf: CC_NAME="eucalyptus"
Architecture: amd64
Date: Sun Nov 8 19:03:43 2009
DistroRelease: Ubuntu 9.10
EucalyptusAxis2cLog:
 [Sun Nov 8 18:22:34 2009] [error] http_transport_utils.c(2557) Service or operation not found
 [Sun Nov 8 18:27:43 2009] [error] http_transport_utils.c(2557) Service or operation not found
 [Sun Nov 8 18:36:28 2009] [error] http_transport_utils.c(2557) Service or operation not found
 [Sun Nov 8 18:38:53 2009] [error] http_transport_utils.c(2557) Service or operation not found
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: eucalyptus-cloud 1.6~bzr931-0ubuntu7
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: eucalyptus
Uname: Linux 2.6.31-14-generic x86_64

DarkJavi (darkjavi) wrote :
DarkJavi (darkjavi) on 2009-11-08
summary: - services won't register
+ eucalyptus services won't register
Chuck Short (zulcss) on 2009-11-10
Changed in eucalyptus (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Mathias Gug (mathiaz) wrote :

Could you try to run the following command on the front-end:

wget -T 10 -t 1 -O - --no-check-certificate https://127.0.0.1:8443/register

Changed in eucalyptus (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2~bzr1136-0ubuntu3

---------------
eucalyptus (1.6.2~bzr1136-0ubuntu3) lucid; urgency=low

  * eucalyptus-cc.eucalyptus-cc-publication.upstart,
    eucalyptus-common.eucalyptus.upstart, eucalyptus-network.upstart,
    eucalyptus-sc.eucalyptus-sc-publication.upstart,
    eucalyptus-walrus.eucalyptus-walrus-publication.upstart, rules: rework
    our eucalyptus starting condition to depend on a new upstart emitted
    signal, eucalyptus-network-is-ready, which is only fired once the
    network interface providing the default route is in fact up, and
    listening on a real ip address, LP: #503180
  * debian/eucalyptus-common.eucalyptus.upstart:
    - don't respawn eucalyptus-cloud
    - ensure that the iptables module gets loaded soon enough, otherwise
      much bad behavior happens in various nasty ways, most notably, a
      wedged database which renders the CLC non responsive on restart/reboot,
      LP: #503180 and dupes, LP: #444352, #444946, #467521, #478573, #480048
 -- Dustin Kirkland <email address hidden> Tue, 02 Feb 2010 17:13:52 -0800

Changed in eucalyptus (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers