How to decrease cloud-debug / cloud-error log verbosity (or disable them)

Bug #463449 reported by Thierry Carrez on 2009-10-29

This bug report was converted into a question: question #90205: How to decrease cloud-debug / cloud-error log verbosity (or disable them).

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Undecided
chris grzegorczyk
eucalyptus (Ubuntu)
Wishlist
Unassigned

Bug Description

Eucalyptus produces very noisy cloud-error.log and cloud-debug.log.
LOGLEVEL doesn't affect their verbosity.
There seem to be no easy way of disabling those logs. They are hardcoded in clc/modules/core/src/main/resources/log4j.xml which is shipped inside eucalyptus JARs ?

Thierry Carrez (ttx) on 2009-10-29
Changed in eucalyptus (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
tags: added: eucalyptus
chris grzegorczyk (chris-grze) wrote :

Actually, a user can supply their own logging configuration by putting a log4j.xml configuration in /etc/eucalyptus/cloud.d/

Note that this will override all logging configuration.

thanks
c

Changed in eucalyptus:
status: New → Invalid
assignee: nobody → chris grzegorczyk (chris-grze)
Thierry Carrez (ttx) wrote :

So it's not a bug, but definitely a good question :)

Changed in eucalyptus (Ubuntu):
status: Confirmed → Invalid
summary: - No possibility to decrease cloud-debug / cloud-error log verbosity (or
- disable them)
+ How to decrease cloud-debug / cloud-error log verbosity (or disable
+ them)

Ahh. Good point. Thanks ;)

On Sat, Nov 14, 2009 at 1:18 PM, Thierry Carrez
<email address hidden> wrote:
> So it's not a bug, but definitely a good question :)
>
> ** Changed in: eucalyptus (Ubuntu)
>       Status: Confirmed => Invalid
>
> ** Converted to question:
>   https://answers.launchpad.net/ubuntu/+source/eucalyptus/+question/90205
>
> ** Summary changed:
>
> - No possibility to decrease cloud-debug / cloud-error log verbosity (or disable them)
> + How to decrease cloud-debug / cloud-error log verbosity (or disable them)
>
> --
> How to decrease cloud-debug / cloud-error log verbosity (or disable them)
> https://bugs.launchpad.net/bugs/463449
> You received this bug notification because you are a bug assignee.
>
> Status in Eucalyptus: Invalid
> Status in “eucalyptus” package in Ubuntu: Invalid
>
> Bug description:
> Eucalyptus produces very noisy cloud-error.log and cloud-debug.log.
> LOGLEVEL doesn't affect their verbosity.
> There seem to be no easy way of disabling those logs. They are hardcoded in clc/modules/core/src/main/resources/log4j.xml which is shipped inside eucalyptus JARs ?
>

--
Chris Grzegorczyk
Co-Founder and Engineer
Eucalyptus Systems, Inc.

130 Castilian St. | Goleta, CA | 93117
Office: 805-968-1400 x e^1 | Cell: 805-807-8237
Email: <email address hidden>
www.eucalyptus.com
________________________________________

H.M. (cybrocop) wrote :

Why does the user have to provide anything custom in order to get more value out of a product?

Having an easy way to reduce log verbosity (if the system is stable and functioning) will help the user manage the system better by reducing the noise. Why would a DEBUG log entry need to ever be written to a log file (consuming disk space and CPU resources) on a normally functioning system?

Forcing the user to learn log4j is not very user-friendly.

H.M., fully agreed on all points. This topic have been brought up in the past two UDS; not sure what the roadmap for resolution is.

chris grzegorczyk (chris-grze) wrote :

This bug has long been irrelevant and should be closed.

That is all addressed by adding the --log-level={TRACE,DEBUG,INFO,WARN,ERROR,FATAL} flag in:
- 1.6.2 you need to add it to OPTS in the eucalyptus-cloud init script
- devel add it to CLOUD_OPTS in eucalyptus.conf

cheers.

Changed in eucalyptus:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers