When installing a UEC cluster, the prompt for the private interface is displayed after the "Installation complete" dialog

Bug #455816 reported by Etienne Goyer on 2009-10-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Medium
Colin Watson
Karmic
Medium
Mathias Gug

Bug Description

Binary package hint: debian-installer

Using karmic server daily ISO of 19-10-2009, when installing an Eucalyptus cluster controller on a machine that have multiple network interfaces, the dialog that prompt for which interface to use to communicate with nodes ("Network interface for communication with nodes:") is shown *after* the "Installation complete" dialog where the CD is ejected.

The installation is otherwise fine, but this is very confusing to say the least! :)

Related branches

Colin Watson (cjwatson) wrote :

Actually slightly fiddly to fix because part of this code also needs to go after another script that's after that question - it'll probably need to be split into two files.

affects: debian-installer (Ubuntu) → eucalyptus (Ubuntu)
Changed in eucalyptus (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Mathias Gug (mathiaz) wrote :

To test the fix:

18:23 < cjwatson> I think what you can do is build the package, put the udeb
                  somewhere wgettable, write a preseed file that says 'd-i
                  preseed/early_command string wget
                  http://url/to/eucalyptus-udeb_1.6~bzr931-0ubuntu7_i386.udeb
                  && udpkg -i eucalyptus-udeb_1.6~bzr931-0ubuntu7_i386.udeb'
18:23 < cjwatson> but then the tricky bit
18:24 < cjwatson> you have to start the installer in expert mode, run through
                  it until right before the "Select cloud installation mode"
                  menu item, *but then* scroll down the menu and select
                  "Download debconf preconfiguration file"
18:24 < cjwatson> after that, you can select "Change debconf priority", set it
                  back to high, and continue as normal
18:24 < cjwatson> (obviously I meant 0ubuntu8 not 0ubuntu7, you get the idea)

Thierry Carrez (ttx) on 2009-10-22
Changed in eucalyptus (Ubuntu Karmic):
assignee: nobody → Mathias Gug (mathiaz)
Mathias Gug (mathiaz) wrote :

I haven't been able to confirm the fix. Going through the instructions above, I got stuck at:

   *but then* scroll down the menu and select "Download debconf preconfiguration file"

AFAICT there isn't any "Download debconf preconfiguration file" item in the menu.

I think this is just a cosmetic bug and is not a blocker for the Karmic release.

Changed in eucalyptus (Ubuntu Karmic):
status: Confirmed → Triaged
Thierry Carrez (ttx) on 2009-10-23
Changed in eucalyptus (Ubuntu Karmic):
status: Triaged → Won't Fix
Thierry Carrez (ttx) on 2009-10-29
tags: removed: eucalyptus
Colin Watson (cjwatson) on 2009-11-26
Changed in eucalyptus (Ubuntu):
status: Triaged → Fix Committed
assignee: Mathias Gug (mathiaz) → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :
Download full text (3.7 KiB)

eucalyptus (1.6.1~bzr1083-0ubuntu1) lucid; urgency=low

  [ Dustin Kirkland ]
  * Merge upstream bzr revision 1082; the following bugs have been fixed
    upstream since the last merge:
    - LP: #378969 - private bug
    - LP: #404842 - init script fix
    - LP: #434283 - existing keys should be overwritten unconditionally
    - LP: #445990 - run instance will fail if no kernel or ramdisk specified
    - LP: #447457 - euca_conf --register-sc ... check the number of parameters
    - LP: #449874 - fix incorrect help text (--delete-nodes doesn't exist)
    - LP: #451795 - show registered images in elastic fox
    - LP: #454405 - return correct networkIndex values on describeInstances
    - LP: #456877 - init script fix
    - LP: #456878 - fix for libvirt xen driver
    - LP: #460085 - fix rampart memory leak
    - LP: #461156 - fix authentication problem w/ userdata
    - LP: #461394 - fix multiple concurrent snapshots on the same volume
    - LP: #461444 - fix memory leaks in NC getConsoleOutput and startup_thread
    - LP: #469984 - fix iptables rules issue
    - LP: #477776 - fix query string authentication
    - LP: #480783 - allow api connection over https
    - LP: #482249 - fix "Describe Regions"
    - LP: #484217 - create keypair should return an error if key exists
    - LP: #490623 - parse RFC 1123 formatted datetime
  * debian/control:
    - make all package lists one-per-line (makes changes henceforth more
      readable), sort lists
    - depend on rampart >= 1.3.0-0ubuntu6, which fixes some shared library
      installation issues
  * debian/patches/04-axis2c-1.6.0-rampart-1.3.0.patch: drop this patch,
    since Eucalyptus 1.6.1 natively supports axis2c 1.6.0 now
  * debian/eucalyptus-cloud.install,
    debian/eucalyptus-common.eucalyptus.upstart,
    debian/eucalyptus-java-common.install, debian/eucalyptus-sc.install,
    debian/eucalyptus-walrus.install: update static version number strings
    from "1.6-devel" to "1.6.1"; (we should really find a better way to do
    this)
  * debian/patches/03-DESTDIR.patch: ported forward for merge

 -- Dustin Kirkland <email address hidden> Tue, 01 Dec 2009 21:09:28 -0600

eucalyptus (1.6~bzr931-0ubuntu9) UNRELEASED; urgency=low

  [ Dustin Kirkland ]
  * cluster/handlers.c: euca_rootwrap rework did not whitelist powerwake;
    however, powerwake does *not* need root privs, drop euca_rootwrap wrapper
    (LP: #458163)
  *

  [ Thierry Carrez ]
  * clc/modules/www/src/main/java/edu/ucsb/eucalyptus/admin/public/EucalyptusWebInterface.html:
    Fix HTML title in the web UI for more consistency in naming (LP: #455293)
  * debian/eucalyptus-common.eucalyptus.upstart: Add -l to eucalyptus-cloud
    options so that cloud-output.log is affected by LOGLEVEL (LP: #458001)

  [ Colin Watson ]
  * Move cluster private interface selection forward to just after network
    configuration (LP: #455816).
  * Add the CC's IP address as an explicit TXT record in the Avahi
    advertisement, and make use of it in euca_find_cluster (LP: #458904).
  * Advertise the CLC and Walrus using Avahi.
  * Rename euca_find_cluster to euca_find_component and make...

Read more...

Changed in eucalyptus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers