The CC sometimes advertises the wrong IP address via avahi

Bug #451607 reported by Mathias Gug on 2009-10-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
High
Thierry Carrez
Karmic
High
Thierry Carrez

Bug Description

While trying to install a UEC system, the CC is using 169.254.169.254 as the advertise CC_IP_ADDR:

root 21254 1 0 14:43 ? 00:00:00 avahi-publish -s 169.254.169.254 _eucalyptus._tcp 8774 txtvers=1 protovers=1.5.0 type=cluster

This is probably due to the way the CC_IP_ADDR is computed in /etc/eucalyptus/eucalyptus-ipaddr.conf

addr_withprefix=$(ip addr show dev $default_interface | awk '$1 == "inet" { print $2 }')

The output of the command below is on the system:

ubuntu@karmic-uec-frontend:~$ ip addr show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1c:c4:6b:38:4a brd ff:ff:ff:ff:ff:ff
    inet 169.254.169.254/32 scope link eth0
    inet 10.153.108.210/24 brd 10.153.108.255 scope global eth0
    inet 172.19.1.1/27 brd 172.19.1.31 scope global eth0
    inet6 fe80::21c:c4ff:fe6b:384a/64 scope link
       valid_lft forever preferred_lft forever

The assumption here is that the correct ip address will be the first one in the listing.

Mathias Gug (mathiaz) wrote :

This result in a non-working UEC since the NC can't connect to the CC and its different components.

Changed in eucalyptus (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-9.10
status: New → Triaged
Dustin Kirkland  (kirkland) wrote :

I've seen this too. It's nasty.

Even ifconfig will report eth0 is 169.254.169.254. That breaks things.

:-Dustin

Mathias Gug (mathiaz) wrote :

ubuntu@karmic-uec-frontend:/var/log/eucalyptus$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:1c:c4:6b:38:4a
          inet addr:169.254.169.254 Bcast:0.0.0.0 Mask:255.255.255.255
          inet6 addr: fe80::21c:c4ff:fe6b:384a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:171691 errors:0 dropped:0 overruns:0 frame:0
          TX packets:97810 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:224916845 (224.9 MB) TX bytes:15611321 (15.6 MB)
          Interrupt:16 Memory:f8000000-f8012800

eth1 Link encap:Ethernet HWaddr 00:1c:c4:6b:38:48
          BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          Interrupt:17 Memory:fa000000-fa012800

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:471027 errors:0 dropped:0 overruns:0 frame:0
          TX packets:471027 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:724541810 (724.5 MB) TX bytes:724541810 (724.5 MB)

Changed in eucalyptus (Ubuntu Karmic):
assignee: nobody → Thierry Carrez (ttx)
Thierry Carrez (ttx) wrote :

For reference: Might be a side-effect of resolution of bug 449143, which changes 169.254.169.254 to be assigned link local.

Thierry Carrez (ttx) wrote :

The fix for bug 449143 introduces two problems.
The first one is 169.243.169.243 appears as the first address in the /etc/eucalyptus/eucalyptus-ipaddr.conf logic, so it is used as the cloud address if its already up, causing despair and desolation (this bug)
The second one is that "ifconfig eth0" will show up the link-local address only, as Dustin says in comment 2. I'm not sure exactly how nasty this is and what exact things is breaks, though. 169.254.0.0/16 is a link-local range, so assinging it link-local seems to be the right way of doing it.

I 'll commit a fix for /etc/eucalyptus/eucalyptus-ipaddr.conf so that it discards 169.243.169.243 as a valid cloud IP.

For the second part, its a direct consequence of the fix in bug 449143. So if its a real issue I'd suggest reopening that bug, revert that change, and discuss a better way to fix the issue there.

Changed in eucalyptus (Ubuntu Karmic):
status: Triaged → In Progress
Thierry Carrez (ttx) wrote :

Fixed by only considering "scope global" addresses when picking up the "external" IP address.

Changed in eucalyptus (Ubuntu Karmic):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr931-0ubuntu3

---------------
eucalyptus (1.6~bzr931-0ubuntu3) karmic; urgency=low

  * debian/eucalyptus-ipaddr.conf: Only consider scope global addresses when
    determining cloud IP addresses (LP: #451607)
  * Cherrypick upstream r932 to fix regression in ElasticFox query handling
    that would prevent registered images to show up (LP: #451795)
  * Web UI changes: add Services tab and fix look of ImageStore (LP: #436447)

 -- Thierry Carrez <email address hidden> Thu, 15 Oct 2009 13:51:28 +0200

Changed in eucalyptus (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers