eucalyptus does not survive a reboot

Bug #444946 reported by Dustin Kirkland  on 2009-10-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
High
Dustin Kirkland 

Bug Description

I installed UEC from today's iso. One cluster/storage/walrus controller, and two nodes. Autoregistration for all components seemed to work flawlessly. And I was able to run instances.

And then I rebooted all 3 components.

I am no longer able to see any availability in my cloud:

ubuntu@cluster:~$ euca-describe-availability-zones verbose
-------------------------
         4 0 8
path=/services/Eucalyptus/?AWSAccessKeyId=WKy3rMzOWPouVOxK1p3Ar1C2uRBwa2FBXnCw&Action=DescribeAvailabilityZones&SignatureMethod=HmacSHA256&SignatureVersion=2&Timestamp=2009-10-06T21%3A49%3A27&Version=2009-04-04&ZoneName.1=verbose&Signature=gDxkbjQff1%2BpLMD7G8A/e38EIA3SjQOqH4qWb4cwjIQ%3D
Failure: 408 Request Timeout

-------------------------
-------------------------
         4 0 8
path=/services/Eucalyptus/?AWSAccessKeyId=WKy3rMzOWPouVOxK1p3Ar1C2uRBwa2FBXnCw&Action=DescribeAvailabilityZones&SignatureMethod=HmacSHA256&SignatureVersion=2&Timestamp=2009-10-06T21%3A49%3A27&Version=2009-04-04&ZoneName.1=verbose&Signature=gDxkbjQff1%2BVLdD7G8A/e38EIAmSjQOqH4qlb4cwjIQ%3D
Failure: 408 Request Timeout

-------------------------

Dustin Kirkland  (kirkland) wrote :

Hmm, after 18 minutes of uptime, it seems to be back up now.

ubuntu@cluster:~$ euca-describe-availability-zones verbose
AVAILABILITYZONE canyonedge 10.1.1.131
AVAILABILITYZONE |- vm types free / max cpu ram disk
AVAILABILITYZONE |- m1.small 0004 / 0004 1 128 2
AVAILABILITYZONE |- c1.medium 0004 / 0004 1 256 5
AVAILABILITYZONE |- m1.large 0002 / 0002 2 512 10
AVAILABILITYZONE |- m1.xlarge 0002 / 0002 2 1024 20
AVAILABILITYZONE |- c1.xlarge 0000 / 0000 4 2048 20

There still seems to be something wrong. A reboot should not result in ~20 minutes of downtime.

:-Dustin

Changed in eucalyptus (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Thierry Carrez (ttx) wrote :

Could you check if it's a duplicate of bug 444352 ? In particular if you get "APPARENT DEADLOCK!!!" messages in cloud-output.log ?

Thierry Carrez (ttx) on 2009-10-07
Changed in eucalyptus (Ubuntu):
assignee: nobody → Dustin Kirkland (kirkland)
Thierry Carrez (ttx) on 2009-10-08
Changed in eucalyptus (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2~bzr1136-0ubuntu3

---------------
eucalyptus (1.6.2~bzr1136-0ubuntu3) lucid; urgency=low

  * eucalyptus-cc.eucalyptus-cc-publication.upstart,
    eucalyptus-common.eucalyptus.upstart, eucalyptus-network.upstart,
    eucalyptus-sc.eucalyptus-sc-publication.upstart,
    eucalyptus-walrus.eucalyptus-walrus-publication.upstart, rules: rework
    our eucalyptus starting condition to depend on a new upstart emitted
    signal, eucalyptus-network-is-ready, which is only fired once the
    network interface providing the default route is in fact up, and
    listening on a real ip address, LP: #503180
  * debian/eucalyptus-common.eucalyptus.upstart:
    - don't respawn eucalyptus-cloud
    - ensure that the iptables module gets loaded soon enough, otherwise
      much bad behavior happens in various nasty ways, most notably, a
      wedged database which renders the CLC non responsive on restart/reboot,
      LP: #503180 and dupes, LP: #444352, #444946, #467521, #478573, #480048
 -- Dustin Kirkland <email address hidden> Tue, 02 Feb 2010 17:13:52 -0800

Changed in eucalyptus (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers