Eucalyptus restart is needed after autoregistration of components

Bug #439251 reported by Thierry Carrez on 2009-09-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Undecided
Unassigned
eucalyptus (Ubuntu)
High
Dustin Kirkland 
Karmic
High
Dustin Kirkland 

Bug Description

Eucalyptus as of 1.6~bzr854-0ubuntu13 autoregisters components. However those registered components are not put in use by the cloud webservice until it is restarted.

So after installation you need to run:
$ sudo stop eucalyptus
$ sudo start eucalyptus
before making use of the cloud.

Related branches

Thierry Carrez (ttx) on 2009-09-30
Changed in eucalyptus (Ubuntu):
importance: Undecided → High
status: New → Triaged
Thierry Carrez (ttx) wrote :

Confirmed as well on a ISO-with-ubuntu12 install, upgraded to -0ubuntu13. NC won't get polled until you restart eucalyptus.

Thierry Carrez (ttx) on 2009-10-01
tags: added: eucalyptus
Thierry Carrez (ttx) on 2009-10-01
Changed in eucalyptus (Ubuntu):
milestone: none → ubuntu-9.10
Thierry Carrez (ttx) wrote :

Seems like if you wait 16 minutes, it finally listens to your requests again. There is a 16 minutes hole in the cloud-output.log:

14:37:38 INFO ClusterUtil | -> [ vcloud ] Node certificate valid=
14:37:38 INFO ClusterUtil | -------------------------------------
--------------------------
14:53:13 WARN JDBCExceptionReporter | SQL Error: -3, SQLState: 08003
14:53:13 ERROR JDBCExceptionReporter | Connection is broken: java.net.Socket
Exception: Connection timed out

Daniel Nurmi (nurmi) on 2009-10-05
Changed in eucalyptus (Ubuntu Karmic):
assignee: nobody → Dustin Kirkland (kirkland)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr912-0ubuntu1

---------------
eucalyptus (1.6~bzr912-0ubuntu1) karmic; urgency=low

  * Merge upstream revision 912
  * tools/eucalyptus-cc.in: resolve conflict, ensuring that we maintain
    the 'ThreadsPerChild 1' sed
  * clc/modules/www/src/main/java/edu/ucsb/eucalyptus/admin/server/ServletUtils.java:
    resolve conflict, drop our diff, as upstream has solved the smtp
    hostname issue
  * debian/patches/boot-order.patch: dropped, applies to a file we don't
    use anymore so it can be removed
  * debian/eucalyptus-walrus.eucalyptus-walrus-registration.upstart: source
    conf file and use $WALRUS_IP_ADDR variable, like the other scripts
  * This snapshot is expected to fix the following bugs:
    - LP: #388934 - apply authorization checks
    - LP: #430226 - fix display of image permissions
    - LP: #430957 - fix running of instances in SYSTEM mode
    - LP: #436276 - sc should run as eucalyptus, instead of root
    - LP: #436313 - fix sc registration through web ui
    - LP: #436407 - fix cc segfaults with apache-mpm-worker, rampart
    - LP: #436885 - fix database corruption, c3p0 deadlock on CLC
    - LP: #437014 - handle execessive CLC sockets
    - LP: #439251 - fix restart-required after autoregistration issue
    - LP: #440744 - handle external command
    - LP: #440817 - fail gracefully with volume deletion on sc
    - LP: #443125 - fix loss of admin credentials

 -- Dustin Kirkland <email address hidden> Mon, 05 Oct 2009 15:02:11 -0500

Changed in eucalyptus (Ubuntu Karmic):
status: In Progress → Fix Released

Closing bug since the fix was commited long time ago.

Changed in eucalyptus:
status: New → Fix Committed
tags: added: iso-testing
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers