add cloud's own ssh host key to /etc/ssh/known_hosts

Bug #436211 reported by Colin Watson on 2009-09-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Medium
Dustin Kirkland 

Bug Description

Registering components with the cloud currently requires --local-sync, or else you get some ssh host key prompts. We already arrange for the cloud's ssh key to be allowed to authenticate to itself; we should also put its own host key in /etc/ssh/known_hosts, to make component registration simpler.

Dustin Kirkland  (kirkland) wrote :

Agreed. I'll knock this out as well.

:-Dustin

Changed in eucalyptus (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

Note that according to ssh(1), the file is /etc/ssh/ssh_known_hosts.

:-Dustin

Changed in eucalyptus (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr854-0ubuntu5

---------------
eucalyptus (1.6~bzr854-0ubuntu5) karmic; urgency=low

  [ Dustin Kirkland ]
  * debian/control: drop dhcp from -nc's recommends, add it to -cc's
    recommends, LP: #364925
  * tools/euca_conf.in: use "-oStrictHostKeyChecking=no" if we're doing
    --discover-nodes, LP: #436210
  * debian/eucalyptus-udeb.finish-install: add own ssh host key to
    /etc/ssh/ssh_known_hosts, LP: #436211

  [ Colin Watson ]
  * euca_find_cluster: Use the proper bracketed format for IPv6 host/port
    combinations.
  * euca_find_cluster: For now, only ask for an IPv4 address for the
    cluster, as IPv6 addresses often show up by accident but don't work, and
    we don't have time to deal with this right now (LP: #436200).
  * tools/eucalyptus-java-ws.in: Increase timeout here too, to go with
    Matt's previous change.

eucalyptus (1.6~bzr854-0ubuntu4) karmic; urgency=low

  * Temporarily disable rejection of loopback addresses in registerComponent.
    This seems perfectly valid when the cloud and cluster controllers are
    running on the same system.

    This works around LP: #434593 (which is a blocker for 9.10 beta) and
    reopens LP: #431934 (which is not)
  * tools/eucalyptus-cc.in:register_local_cloud: Increase the timeout
    waiting for the service to start before registering it. Increasing from 10
    seconds to 60 seems to be sufficient to work around LP: #434590

 -- Colin Watson <email address hidden> Fri, 25 Sep 2009 15:30:36 +0100

Changed in eucalyptus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers