euca_find_cluster should probably prefer IPv4 addresses

Bug #436200 reported by Colin Watson on 2009-09-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Medium
Colin Watson
Karmic
Medium
Colin Watson

Bug Description

The first time I tried the UEC node installation (in this testing pass), it failed to download the preseed file from the cluster because it had got the IPv6 address and I don't have IPv6 routing set up between my VMs. I think it would be best if we fixed euca_find_cluster to actively prefer IPv4 addresses.

Dustin Kirkland  (kirkland) wrote :

Confirming. I see this periodically too. Usually, if I re-run the step, it will pick it up on the 2nd or 3rd try.

:-Dustin

Changed in eucalyptus (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Colin Watson (cjwatson) on 2009-09-25
Changed in eucalyptus (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Thierry Carrez (ttx) wrote :

Targeting for beta. It's easily solved but still doesn't look good as a first user experience.

Changed in eucalyptus (Ubuntu):
milestone: none → ubuntu-9.10-beta
Colin Watson (cjwatson) on 2009-09-25
Changed in eucalyptus (Ubuntu Karmic):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr854-0ubuntu5

---------------
eucalyptus (1.6~bzr854-0ubuntu5) karmic; urgency=low

  [ Dustin Kirkland ]
  * debian/control: drop dhcp from -nc's recommends, add it to -cc's
    recommends, LP: #364925
  * tools/euca_conf.in: use "-oStrictHostKeyChecking=no" if we're doing
    --discover-nodes, LP: #436210
  * debian/eucalyptus-udeb.finish-install: add own ssh host key to
    /etc/ssh/ssh_known_hosts, LP: #436211

  [ Colin Watson ]
  * euca_find_cluster: Use the proper bracketed format for IPv6 host/port
    combinations.
  * euca_find_cluster: For now, only ask for an IPv4 address for the
    cluster, as IPv6 addresses often show up by accident but don't work, and
    we don't have time to deal with this right now (LP: #436200).
  * tools/eucalyptus-java-ws.in: Increase timeout here too, to go with
    Matt's previous change.

eucalyptus (1.6~bzr854-0ubuntu4) karmic; urgency=low

  * Temporarily disable rejection of loopback addresses in registerComponent.
    This seems perfectly valid when the cloud and cluster controllers are
    running on the same system.

    This works around LP: #434593 (which is a blocker for 9.10 beta) and
    reopens LP: #431934 (which is not)
  * tools/eucalyptus-cc.in:register_local_cloud: Increase the timeout
    waiting for the service to start before registering it. Increasing from 10
    seconds to 60 seems to be sufficient to work around LP: #434590

 -- Colin Watson <email address hidden> Fri, 25 Sep 2009 15:30:36 +0100

Changed in eucalyptus (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers