Cloud installer / Cluster install fails to autoregister cluster, walrus, sc

Bug #434590 reported by Thierry Carrez on 2009-09-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Medium
Matt Zimmerman

Bug Description

Running Alpha6 cloud installer, cluster mode.
After install, looking at the Configuration tab on the web UI, walrus, sc and cluster aren't registered.

The initscripts run register_local_cloud but there is a 10-second wait loop waiting for the web services port to show up in netstat. The issue is it takes 28 seconds on my machine for the port to come up, then another 5 seconds before the service is actually able to answer anything.

Related branches

Thierry Carrez (ttx) wrote :

Quick workaround is to replace i=10 by i=45 and add a sleep 5 just after the while loop.
Better workaround is to try euca_conf every 5 seconds for 1 minute, and add proper messages while doing that.
Best workaround is to rewrite the initscripts completely to get rid of redundancy and race conditions.

Note that the workaround isn't sufficient to make it work with bzr808 because of bug 434593.

Changed in eucalyptus (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: eucalyptus
Thierry Carrez (ttx) on 2009-09-24
Changed in eucalyptus (Ubuntu):
assignee: nobody → Thierry Carrez (ttx)
Thierry Carrez (ttx) wrote :

Workaround (to execute on the cluster setup itself):
sudo euca_conf --local-sync --register-cluster CLUSTERNAME EXTERNALIP
sudo euca_conf --local-sync --register-walrus EXTERNALIP
sudo euca_conf --local-sync --register-sc CLUSTERNAME EXTERNALIP

Matt Zimmerman (mdz) on 2009-09-24
Changed in eucalyptus (Ubuntu):
assignee: Thierry Carrez (ttx) → Matt Zimmerman (mdz)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr854-0ubuntu5

---------------
eucalyptus (1.6~bzr854-0ubuntu5) karmic; urgency=low

  [ Dustin Kirkland ]
  * debian/control: drop dhcp from -nc's recommends, add it to -cc's
    recommends, LP: #364925
  * tools/euca_conf.in: use "-oStrictHostKeyChecking=no" if we're doing
    --discover-nodes, LP: #436210
  * debian/eucalyptus-udeb.finish-install: add own ssh host key to
    /etc/ssh/ssh_known_hosts, LP: #436211

  [ Colin Watson ]
  * euca_find_cluster: Use the proper bracketed format for IPv6 host/port
    combinations.
  * euca_find_cluster: For now, only ask for an IPv4 address for the
    cluster, as IPv6 addresses often show up by accident but don't work, and
    we don't have time to deal with this right now (LP: #436200).
  * tools/eucalyptus-java-ws.in: Increase timeout here too, to go with
    Matt's previous change.

eucalyptus (1.6~bzr854-0ubuntu4) karmic; urgency=low

  * Temporarily disable rejection of loopback addresses in registerComponent.
    This seems perfectly valid when the cloud and cluster controllers are
    running on the same system.

    This works around LP: #434593 (which is a blocker for 9.10 beta) and
    reopens LP: #431934 (which is not)
  * tools/eucalyptus-cc.in:register_local_cloud: Increase the timeout
    waiting for the service to start before registering it. Increasing from 10
    seconds to 60 seems to be sufficient to work around LP: #434590

 -- Colin Watson <email address hidden> Fri, 25 Sep 2009 15:30:36 +0100

Changed in eucalyptus (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers