Cluster controller initscripts do not output messages at boot

Bug #431274 reported by Thierry Carrez on 2009-09-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Low
Thierry Carrez

Bug Description

Testing Alpha6 candidate, UEC install / Cluster mode.
eucalyptus 1.6~bzr746-0ubuntu3

Symptom:
The initscripts for eucalyptus-* (while successful) do not output any boot message:
-----------------
 * Starting web server apache2
apache2: Could not reliably determine the server's fully qualified domain name,
using 127.0.1.1 for ServerName
                                                                                [ OK ]
 * Restarting OpenBSD Secure Shell server sshd

Enabling IP forwarding
Ubuntu karmic (development branch) ubuntu tty1

ubuntu login:
-----------------

Expected result:
-----------------
 * Starting web server apache2 [ OK ]
 * Starting Eucalyptus Cluster Controller eucalyptus-cc [ OK ]
 * Starting Eucalyptus Cloud Controller eucalyptus-cloud [ OK ]
 * Starting Eucalyptus Storage Controller eucalyptus-sc [ OK ]
 * Starting Eucalyptus Walrus eucalyptus-walrus [ OK ]

Ubuntu karmic (development branch) ubuntu tty1

ubuntu login:
-----------------

Adding VERBOSE=yes at the top of the /etc/init.d/eucalyptus-* files works around the issue.

Thierry Carrez (ttx) wrote :

The issue is that even the very basic messages are guarded by if [ "$VERBOSE" != no ]...

Changed in eucalyptus (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Thierry Carrez (ttx) on 2009-09-17
Changed in eucalyptus (Ubuntu):
assignee: nobody → Thierry Carrez (ttx)
status: Triaged → In Progress
Thierry Carrez (ttx) wrote :
Changed in eucalyptus (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr808-0ubuntu1

---------------
eucalyptus (1.6~bzr808-0ubuntu1) karmic; urgency=low

  [ Dustin Kirkland ]
  * debian/eucalyptus-udeb.finish-install: eth0 should be set to
    'manual', when configured with br0 on dhcp, LP: #430820
  * tools/euca_conf.in: ensure that /var/run/eucalyptus and
    /var/run/eucalyptus/net are created at boot and have correct
    ownerships, LP: #431114, #365349

  [ Thierry Carrez ]
  * cluster/Makefile, node/Makefile: Do not patch generated stubs if you
    didn't regenerate them, to avoid spurious build interruptions.
  * tools/eucalyptus-*.in: Do not guard initscripts basic output
    messages with VERBOSE != no (LP: #431274)
  * debian/control: Have eucalyptus-cc suggest vtun for full multi-cluster
    networking capabilities (LP: #425928)

  [ Colin Watson ]
  * Align ports used for cloud startup detection in init scripts with the
    corresponding code in euca_conf (LP: #430758).

  [ Soren Hansen ]
  * New snapshot.
  * Add a build-dependency on libc3p0-java.

 -- Soren Hansen <email address hidden> Mon, 21 Sep 2009 12:14:12 +0200

Changed in eucalyptus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers