eucalyptus-nc fail to upgrade to 1.6~bzr746-0ubuntu1

Bug #430075 reported by Etienne Goyer on 2009-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
High
Dustin Kirkland 

Bug Description

On karmic, when upgrading Eucalyptus from 1.6~bzr672-0ubuntu4 to 1.6~bzr746-0ubuntu1, package upgrade will fail following. It seems like the problem is really with insserv and unrelated to Eucalyptus specifically, but I am not entirely sure.

Setting up eucalyptus-nc (1.6~bzr746-0ubuntu1) ...
insserv: warning: script 'S12udev-finish' missing LSB tags and overrides
insserv: warning: script 'S02udev' missing LSB tags and overrides
insserv: warning: script 'udev-finish' missing LSB tags and overrides
insserv: warning: script 'udev' missing LSB tags and overrides
insserv: There is a loop between service udev and mountnfs-bootclean if started
insserv: loop involving service mountnfs-bootclean at depth 7
insserv: loop involving service mountnfs at depth 6
insserv: There is a loop between service udev and mountoverflowtmp if started
insserv: loop involving service mountoverflowtmp at depth 7
insserv: loop involving service mountall-bootclean at depth 6
insserv: There is a loop between service udev and mountall if started
insserv: loop involving service mountall at depth 5
insserv: loop involving service checkfs at depth 4
insserv: exiting without changing boot order!
EUCALYPTUS not configured!
invoke-rc.d: initscript eucalyptus-nc, action "start" failed.
dpkg: error processing eucalyptus-nc (--configure):
 subprocess installed post-installation script returned error exit status 1

The actual error:

EUCALYPTUS not configured!
invoke-rc.d: initscript eucalyptus-nc, action "start" failed.

This comes from the eucalyptus-nc init script

affects: ubuntu → eucalyptus (Ubuntu)

The problem is indeed with eucalyptus. There is now a check in the init script that will make it fail if the EUCALYPTUS value of the configuration file is "not_configured". The config that shipped in the last version indeed was. Somehow, the config file did not got upgraded to the new version, despite that I did accept the package maintainer's version. Manually fixing the config file makes the eucalyptus-nc start, and I can fix the package installation with "apt-get install -f".

Got the same problem upgrading a Eucalyptus frontend (running -cloud, -cc, -walrus and -sc). However, we cannot accept the package maintainer's version, as it will overwrite the NODES value in the configuration file, which would make the frontend consider there is no node controller. People running earlier version of Eucalyptus will have to reject the package maintainer's version when upgrading. It is worth nothing that the other eucalyptus- start just fine with EUCALYPTUS="not_configured", unlike eucalyptus-nc.

Dustin Kirkland  (kirkland) wrote :

Confirming, marking High.

This is an area that we will need to test heavily (though we haven't done so yet) ... users upgrading from Jaunty UEC to Karmic UEC. Alternatively, we could document the gotchas, which might be sufficient of the Jaunty UEC install base is small enough.

:-Dustin

Changed in eucalyptus (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Dustin Kirkland  (kirkland) wrote :

I *think* the eucalyptus-nc init script needs to throw the error message, and exit, but exit 0, to prevent this sort of upgrade problem.

  * tools/eucalyptus-nc.in: eucalyptus not being configured is a fatal
    condition for the init script, but exit 0 such that package installation
    can proceed, LP: #430075

:-Dustin

Changed in eucalyptus (Ubuntu):
status: Confirmed → Triaged
status: Triaged → In Progress
assignee: nobody → Dustin Kirkland (kirkland)
Changed in eucalyptus (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr854-0ubuntu6

---------------
eucalyptus (1.6~bzr854-0ubuntu6) karmic; urgency=low

  [ Thierry Carrez ]
  * Apply upstream rev867 and rev876 diffs to fix SC registration through
    Web UI, LP: #436313
  * tools/eucalyptus-java-ws.in: Reapply fix on boot messages that was lost
    on a merge, LP: #435766

  [ Dustin Kirkland ]
  * debian/80-eucalyptus-url: add an update-motd script that
    displays the administration URL in the MOTD at position 80, LP: #436199
  * debian/eucalyptus-nc.preinst: echo a warning message if a system
    installing the -nc does not have VT, LP: #426830
  * debian/rules: don't fail package installation due to init script
    failures, LP: #430075, #418473
  * tools/euca_conf.in: vastly improve the output of
    'euca_conf --register-nodes', which was missing some pertinent
    information, LP: #424457
  * clc/modules/www/src/main/java/edu/ucsb/eucalyptus/admin/server/ServletUtils.java:
    if we're going to use the local host to send email, use 'localhost' as
    the hostname, rather than the externally resolvable hostname which
    breaks in the default ubuntu postfix configuration, LP: #412676
  * debian/control:
    - have eucalyptus-common depend on openssh-server and openssh-client,
      as these should really be installed on most any Eucalyptus system,
      LP: #411656
    - have eucalyptus-common recommend unzip, since Eucalyptus uses zip
      files for credentials, which may be needed on various systems,
      LP: #436876
    - recommend libpam that provides pam_motd, LP: #436199
    - conflict with apache2-mpm-itk, LP: #338344
  * debian/eucalyptus-common.postinst: configure VNET_DHCPDAEMON and
    VNET_DHCPUSER appropriately for default Ubuntu on initial install,
    LP: #364938

  [ Colin Watson ]
  * debian/control:
    - Make eucalyptus-nc explicitly depend on apache2-mpm-worker |
      apache2-mpm-prefork, since the NC requires that Apache be configured
      to only start a single child (LP: #338344).

 -- Dustin Kirkland <email address hidden> Fri, 25 Sep 2009 18:01:29 -0700

Changed in eucalyptus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers