Add a check in eucalyptus-nc to verify that the target can run KVM

Bug #426830 reported by Etienne Goyer on 2009-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
Wishlist
Dustin Kirkland 
Karmic
Wishlist
Dustin Kirkland 

Bug Description

Binary package hint: eucalyptus-nc

This is a wishlist item.

As it can be hard to track problems running instances on a node controller caused by the node controller not supporting HVM, it would be good if the package installer would warn of the situation. For example, we could just run kvm-ok in the preinst, and report status in a dialog box. This would improve the out-of-the-box experience significantly, reduce the number of people who request help following installation and simplify documentation.

Dustin Kirkland  (kirkland) wrote :

Etienne-

Hmm, this is a bit easier said than done.

We can't run kvm-ok directly, because the package that provides kvm-ok may be being installed at that time. Note that there's another bug where we're trying to get kvm-ok into the base system files and out of qemu-kvm, Bug #429443.

However, kvm-ok's real meat is a very simple grep of /proc/cpuinfo. That's certainly something that we can do.

I disagree with the concept of a "dialog box", or anything interactive that would hamper unattended installations.

But I can throw a warning message echo'd in the nc postinst, such that the message is at least logged *somewhere*.

:-Dustin

Changed in eucalyptus (Ubuntu Karmic):
importance: Undecided → Wishlist
assignee: nobody → Dustin Kirkland (kirkland)
status: New → Triaged
Changed in eucalyptus (Ubuntu Karmic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr854-0ubuntu6

---------------
eucalyptus (1.6~bzr854-0ubuntu6) karmic; urgency=low

  [ Thierry Carrez ]
  * Apply upstream rev867 and rev876 diffs to fix SC registration through
    Web UI, LP: #436313
  * tools/eucalyptus-java-ws.in: Reapply fix on boot messages that was lost
    on a merge, LP: #435766

  [ Dustin Kirkland ]
  * debian/80-eucalyptus-url: add an update-motd script that
    displays the administration URL in the MOTD at position 80, LP: #436199
  * debian/eucalyptus-nc.preinst: echo a warning message if a system
    installing the -nc does not have VT, LP: #426830
  * debian/rules: don't fail package installation due to init script
    failures, LP: #430075, #418473
  * tools/euca_conf.in: vastly improve the output of
    'euca_conf --register-nodes', which was missing some pertinent
    information, LP: #424457
  * clc/modules/www/src/main/java/edu/ucsb/eucalyptus/admin/server/ServletUtils.java:
    if we're going to use the local host to send email, use 'localhost' as
    the hostname, rather than the externally resolvable hostname which
    breaks in the default ubuntu postfix configuration, LP: #412676
  * debian/control:
    - have eucalyptus-common depend on openssh-server and openssh-client,
      as these should really be installed on most any Eucalyptus system,
      LP: #411656
    - have eucalyptus-common recommend unzip, since Eucalyptus uses zip
      files for credentials, which may be needed on various systems,
      LP: #436876
    - recommend libpam that provides pam_motd, LP: #436199
    - conflict with apache2-mpm-itk, LP: #338344
  * debian/eucalyptus-common.postinst: configure VNET_DHCPDAEMON and
    VNET_DHCPUSER appropriately for default Ubuntu on initial install,
    LP: #364938

  [ Colin Watson ]
  * debian/control:
    - Make eucalyptus-nc explicitly depend on apache2-mpm-worker |
      apache2-mpm-prefork, since the NC requires that Apache be configured
      to only start a single child (LP: #338344).

 -- Dustin Kirkland <email address hidden> Fri, 25 Sep 2009 18:01:29 -0700

Changed in eucalyptus (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers