package eucalyptus-cloud eucalyptus-cloud_1.6~bzr452-0ubuntu3 fail to upgrade

Bug #418473 reported by marcobra (Marco Braida) on 2009-08-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
High
Unassigned

Bug Description

Description: Ubuntu karmic (development branch)
Release: 9.10

Package:

apt-cache policy eucalyptus-cloud
eucalyptus-cloud:
  Installato: 1.5~bzr266-0ubuntu2
  Candidato: 1.6~bzr452-0ubuntu3
  Tabella versione:
     1.6~bzr452-0ubuntu3 0
        500 http://archive.ubuntu.com karmic/universe Packages
 *** 1.5~bzr266-0ubuntu2 0
        100 /var/lib/dpkg/status

Give me this error on update... i cannot send error report because i cannot traverse corporate proxy

sudo apt-get dist-upgrade
...
Recuperati 3940kB in 1min 25s (45,8kB/s)
(Lettura del database... 260162 file e directory attualmente installati.)
Preparativi per sostituire eucalyptus-cloud v.1.5~bzr266-0ubuntu2 (utilizzando .../eucalyptus-cloud_1.6~bzr452-0ubuntu3_i386.deb)...
EUCALYPTUS not configured!
invoke-rc.d: initscript eucalyptus-cloud, action "stop" failed.
dpkg: attenzione: vecchio script di pre-removal ha restituito lo stato di errore 1
dpkg - viene provato lo script dal nuovo pacchetto...
EUCALYPTUS not configured!
invoke-rc.d: initscript eucalyptus-cloud, action "stop" failed.
dpkg: errore nell'elaborare /var/cache/apt/archives/eucalyptus-cloud_1.6~bzr452-0ubuntu3_i386.deb (--unpack):
 il sottoprocesso nuovo script pre-removal ha restituito lo stato di errore 1
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/eucalyptus-cloud_1.6~bzr452-0ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Related branches

Antono Vasiljev (antono) wrote :

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu karmic (development branch)"

The following packages will be REMOVED:
  eucalyptus-cloud{a} eucalyptus-nc
0 packages upgraded, 0 newly installed, 2 to remove and 3 not upgraded.
Need to get 0B of archives. After unpacking 5792kB will be freed.
Do you want to continue? [Y/n/?] Y
Writing extended state information... Done
(Reading database ... 531566 files and directories currently installed.)
Removing eucalyptus-cloud ...
-cc, -nc and -cloud are not used anymore
EUCALYPTUS not configured!
invoke-rc.d: initscript eucalyptus-cloud, action "stop" failed.
dpkg: error processing eucalyptus-cloud (--remove):
 subprocess installed pre-removal script returned error exit status 1
Removing eucalyptus-nc ...
-cc, -nc and -cloud are not used anymore
EUCALYPTUS not configured!
invoke-rc.d: initscript eucalyptus-nc, action "stop" failed.
dpkg: error processing eucalyptus-nc (--remove):
 subprocess installed pre-removal script returned error exit status 1
Errors were encountered while processing:
 eucalyptus-cloud
 eucalyptus-nc
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

Changed in eucalyptus (Ubuntu):
status: New → Confirmed
Antono Vasiljev (antono) wrote :

 apt-cache policy eucalyptus-cloud
eucalyptus-cloud:
  Installed: 1.6~bzr452-0ubuntu2
  Candidate: 1.6~bzr645-0ubuntu2
  Version table:
     1.6~bzr645-0ubuntu2 0
        500 http://by.archive.ubuntu.com karmic/main Packages
 *** 1.6~bzr452-0ubuntu2 0
        100 /var/lib/dpkg/status

Changed in eucalyptus (Ubuntu):
status: Confirmed → Fix Committed
Changed in eucalyptus (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr854-0ubuntu6

---------------
eucalyptus (1.6~bzr854-0ubuntu6) karmic; urgency=low

  [ Thierry Carrez ]
  * Apply upstream rev867 and rev876 diffs to fix SC registration through
    Web UI, LP: #436313
  * tools/eucalyptus-java-ws.in: Reapply fix on boot messages that was lost
    on a merge, LP: #435766

  [ Dustin Kirkland ]
  * debian/80-eucalyptus-url: add an update-motd script that
    displays the administration URL in the MOTD at position 80, LP: #436199
  * debian/eucalyptus-nc.preinst: echo a warning message if a system
    installing the -nc does not have VT, LP: #426830
  * debian/rules: don't fail package installation due to init script
    failures, LP: #430075, #418473
  * tools/euca_conf.in: vastly improve the output of
    'euca_conf --register-nodes', which was missing some pertinent
    information, LP: #424457
  * clc/modules/www/src/main/java/edu/ucsb/eucalyptus/admin/server/ServletUtils.java:
    if we're going to use the local host to send email, use 'localhost' as
    the hostname, rather than the externally resolvable hostname which
    breaks in the default ubuntu postfix configuration, LP: #412676
  * debian/control:
    - have eucalyptus-common depend on openssh-server and openssh-client,
      as these should really be installed on most any Eucalyptus system,
      LP: #411656
    - have eucalyptus-common recommend unzip, since Eucalyptus uses zip
      files for credentials, which may be needed on various systems,
      LP: #436876
    - recommend libpam that provides pam_motd, LP: #436199
    - conflict with apache2-mpm-itk, LP: #338344
  * debian/eucalyptus-common.postinst: configure VNET_DHCPDAEMON and
    VNET_DHCPUSER appropriately for default Ubuntu on initial install,
    LP: #364938

  [ Colin Watson ]
  * debian/control:
    - Make eucalyptus-nc explicitly depend on apache2-mpm-worker |
      apache2-mpm-prefork, since the NC requires that Apache be configured
      to only start a single child (LP: #338344).

 -- Dustin Kirkland <email address hidden> Fri, 25 Sep 2009 18:01:29 -0700

Changed in eucalyptus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers