RebootInstances does not seem to work

Bug #357397 reported by Neil Soman on 2009-04-07
4
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
High
Unassigned
1.5
Fix Released
High
Unassigned
eucalyptus (Ubuntu)
Undecided
Unassigned

Bug Description

This is with xen.

Here is the request:

AWSAccessKeyId=ISMvKXpXpadDiUoOSoAfww&Action=RebootInstances&InstanceId.1=i-4A120800&SignatureMethod=HmacSHA25
6&SignatureVersion=2&Timestamp=2009-04-07T23%3A41%3A19&Version=2008-12-01

16:40:40 [Admin:VmControl.10] ERROR java.lang.NullPointerException: Cannot invoke method getSimpleName() on n
ull object
java.lang.NullPointerException: Cannot invoke method getSimpleName() on null object
        at org.codehaus.groovy.runtime.NullObject.invokeMethod(NullObject.java:77)
        at org.codehaus.groovy.runtime.InvokerHelper.invokePogoMethod(InvokerHelper.java:784)
        at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:758)
        at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:170)
        at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethod0(ScriptBytecodeAdapter.java:198)
        at edu.ucsb.eucalyptus.msgs.EucalyptusMessage.toString(Messages.groovy:89)
        at java.lang.String.valueOf(String.java:2827)
        at java.lang.StringBuilder.append(StringBuilder.java:115)
        at java.util.AbstractCollection.toString(AbstractCollection.java:422)
        at java.lang.String.valueOf(String.java:2827)
        at java.lang.StringBuilder.append(StringBuilder.java:115)
        at edu.ucsb.eucalyptus.util.Admin.makeMsg(Admin.java:46)
        at edu.ucsb.eucalyptus.cloud.ws.SystemState.dispatchReboot(SystemState.java:292)
        at edu.ucsb.eucalyptus.cloud.ws.SystemState.handle(SystemState.java:325)
        at edu.ucsb.eucalyptus.cloud.ws.VmControl.RebootInstances(VmControl.java:77)

Related branches

Neil Soman (neilsoman) on 2009-04-07
Changed in eucalyptus:
assignee: nobody → chris-grze
importance: Undecided → Medium
description: updated
Neil Soman (neilsoman) wrote :

This is with REST as well as SOAP.

Neil Soman (neilsoman) on 2009-04-23
summary: - RebootInstances with REST does not seem to work
+ RebootInstances does not seem to work
chris grzegorczyk (chris-grze) wrote :

------------------------------------------------------------
revno: 293
committer: root <root@personal-army>
branch nick: 1.5
timestamp: Fri 2009-04-24 15:18:06 -0700
message:
  fix problem with forming downstream message for reboot instaces
------------------------------------------------------------

Neil Soman (neilsoman) wrote :

The front end now conveys the operation correctly. However, the operation itself fails (this is Debian lenny + xen).

cc.log:

[Fri Apr 24 15:39:04 2009][028969][EUCADEBUG ] refresh_resources(): called
[Fri Apr 24 15:39:05 2009][032315][EUCAERROR ] ERROR: RebootInstanceInstance() could not be invoked (check NC
host, port, and credentials)
[Fri Apr 24 15:39:05 2009][032257][EUCAINFO ] call complete (pid/rc): 32315/1
[Fri Apr 24 15:39:05 2009][032257][EUCADEBUG ] RebootInstances(): done.

nc.log:

[Fri Apr 24 15:39:06 2009][009440][EUCAERROR ] ERROR: doRebootInstance() failed error=1
[Fri Apr 24 15:39:06 2009][009440][EUCAINFO ] doDescribeInstances() invoked

axis2c.log on the NC:

[Fri Apr 24 15:39:06 2009] [error] adb_ncRebootInstanceResponseType.c(1059) Nil value found in non-nillable property status

So there seem to be two issues.

-The CLC returns the instance id indicating that everything is okay.
-The operation itself fails.

chris grzegorczyk (chris-grze) wrote :

The CLC returns true if the instance ID exists, the user executing the command is the owner of the instance, and the cluster which is hosting the instance is valid (i.e., still exists). So this is the expected behaviour.

It looks like the underlying problem has to do with permissions (from httpd-nc_error_log):

Error: Most commands need root access. Please try again as root.

chris grzegorczyk (chris-grze) wrote :

Error: Most commands need root access. Please try again as root.

Neil Soman (neilsoman) wrote :

Nope, that log entry is unrelated (much earlier timestamp). The log entries that I've pointed out earlier seem to capture the problem.

Dmitrii Zagorodnov (dmitrii) wrote :

Replacing 'xm reboot' invocation with virDomainReboot() allows non-root operation with Xen.

------------------------------------------------------------
revno: 297
committer: Dmitrii Zagorodnov <email address hidden>
branch nick: 1.5
timestamp: Mon 2009-04-27 17:05:54 -0700
message:
  couple of detachVolume bug fixes, as well as reboot without 'xm'
    ------------------------------------------------------------

Soren Hansen (soren) on 2009-09-24
Changed in eucalyptus (Ubuntu):
status: New → Fix Released
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers