euca-modify-image-attribute usage raises error

Bug #826022 reported by Dave Walker
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
euca2ools (Ubuntu)
High
Scott Moser

Bug Description

$ euca-modify-image-attribute xxx-xxxxxx -l -r all
Traceback (most recent call last):
  File "bin/euca-modify-image-attribute", line 41, in <module>
    cmd.main_cli()
  File "/usr/lib/python2.7/dist-packages/euca2ools/commands/euca/modifyimageattribute.py", line 120, in main_cli
    self.main()
  File "/usr/lib/python2.7/dist-packages/euca2ools/commands/euca/modifyimageattribute.py", line 95, in main
    if self.adds and self.removes:
AttributeError: 'ModifyImageAttribute' object has no attribute 'adds'

This issue is resolved in upstream commit r454. Oneiric package is a current snapshot @r451, diff between 451 and current trunk is bug fixes only, suggesting new upstream snapshot rather than cherry picking.

Thanks.

Related branches

Revision history for this message
Dave Walker (davewalker) wrote :

Scott, are you able to drive this? Thanks.

Changed in euca2ools (Ubuntu):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Scott Moser (smoser)
tags: added: server-o-rs
Changed in euca2ools (Ubuntu):
milestone: none → ubuntu-11.10-beta-1
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package euca2ools - 2.0.0~bzr464-0ubuntu1

---------------
euca2ools (2.0.0~bzr464-0ubuntu1) oneiric; urgency=low

  * new upstream snapshot of bzr revno 464. (LP: #826022)
  * Note, previous upload was incorrectly named 'bzr451'. It should have
    been named bzr461 as it was a snapshot of revision 461.
 -- Scott Moser <email address hidden> Mon, 15 Aug 2011 11:16:29 -0500

Changed in euca2ools (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Elliot Murphy (statik) wrote :

This seems to not be fixed:

root@node1:~/nimbus# apt-cache policy euca2ools
euca2ools:
  Installed: 2.0.0~bzr464-0ubuntu1
  Candidate: 2.0.0~bzr464-0ubuntu1
  Version table:
 *** 2.0.0~bzr464-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status
root@node1:~/nimbus# euca-modify-image-attribute aki-01 -l -r all
'ModifyImageAttribute' object has no attribute 'adds'
root@node1:~/nimbus#

Revision history for this message
Dave Walker (davewalker) wrote :

Confirmed:

$ euca-modify-image-attribute aki-00000045 -l -r all
'ModifyImageAttribute' object has no attribute 'adds'

Changed in euca2ools (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Dave Walker (davewalker) wrote :

euca2ools (2.0.0~bzr464-0ubuntu2) oneiric; urgency=low

  * fix a bad upload that had a debian-changes patch which reverted
    the intended changes. euca-modify-image-attribute works now.
 -- Scott Moser <email address hidden> Tue, 23 Aug 2011 16:26:01 -0400

Changed in euca2ools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers