euca-bundle-vol/ec2-bundle-vol should copy filesystem uuid

Bug #672986 reported by Scott Moser on 2010-11-09
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
euca2ools
Fix Released
Undecided
Mitch Garnaat
ec2-ami-tools (Ubuntu)
Medium
Unassigned
Lucid
High
Unassigned
Maverick
High
Unassigned
euca2ools (Ubuntu)
Low
Unassigned
Lucid
High
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: euca2ools

This bug is similar to bug 667793 and related to bug 671427 and bug 665235.

But, unrelated to any of those things, it seems from a purely objective perspective that euca-bundle-vol maybe should copy the UUID from the source filesystem to the destination. This would simply be a more complete copy of the "vol".

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: euca2ools 1.2-0ubuntu11
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
Date: Tue Nov 9 05:52:53 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: euca2ools

Scott Moser (smoser) wrote :
Changed in euca2ools (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Scott Moser (smoser) on 2011-01-06
summary: - euca-bundle-vol should copy filesystem uuid
+ euca-bundle-vol/ec2-bundle-vol should copy filesystem uuid
Changed in ec2-ami-tools (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in euca2ools:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package euca2ools - 1.3.1-0ubuntu2

---------------
euca2ools (1.3.1-0ubuntu2) natty; urgency=low

  * update patch delta upstream information (all delta now upstream)
  * cherry pick upstream commits
    * r318 : fix euca-bundle-img to correctly create checksum (LP: #600783)
    * r319 : correctly catch man page build errors
  * copy filesystem uuid, label, fstype from source filesytem to
    bundled volume (LP: #667793, #672986)
 -- Scott Moser <email address hidden> Wed, 12 Jan 2011 17:29:32 -0500

Changed in euca2ools (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ec2-ami-tools - 1.3.49953-0ubuntu2

---------------
ec2-ami-tools (1.3.49953-0ubuntu2) natty; urgency=low

  * copy filesystem uuid, label, fstype from source filesytem to
    bundled volume (LP: #667793, #672986)
 -- Scott Moser <email address hidden> Thu, 13 Jan 2011 13:42:01 -0500

Changed in ec2-ami-tools (Ubuntu):
status: Confirmed → Fix Released
Scott Moser (smoser) wrote :

I've uploaded maverick and lucid packages for both ec2-ami-tools and euca2ools with the proposed fixes to my ppa at https://launchpad.net/~smoser/+archive/ppa/+packages .

Scott Moser (smoser) wrote :

To test packages, please:
   sudo add-apt-repository ppa:smoser/bundle-fix-sru-test
   sudo apt-get update
   sudo apt-get upgrade

Changed in ec2-ami-tools (Ubuntu Lucid):
status: New → In Progress
importance: Undecided → High
Changed in ec2-ami-tools (Ubuntu Maverick):
status: New → In Progress
importance: Undecided → High
Changed in euca2ools (Ubuntu Lucid):
status: New → In Progress
importance: Undecided → High
Changed in euca2ools (Ubuntu Maverick):
importance: Undecided → High
status: New → In Progress

Accepted ec2-ami-tools into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ec2-ami-tools (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in ec2-ami-tools (Ubuntu Maverick):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted ec2-ami-tools into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Scott Moser (smoser) wrote :

- I tested maverick with the following:
  us-east-1 ami-a6f504cf canonical ubuntu-maverick-10.10-i386-server-20101225
- sudo mkdir /mnt/creds && sudo chown ubuntu:ubuntu /mnt/creds
  . /mnt/creds # creds file set up to have necessary environment vars
- add proposed and install/upgrade package
  $ mirror=$(awk '$0 ~ /^deb / { print $2 ; exit(0); }' /etc/apt/sources.list)
  $ echo "deb ${mirror} $(lsb_release -sc)-proposed main universe multiverse" | sudo tee -a /etc/apt/sources.list
  $ echo "deb ${mirror} $(lsb_release -sc) multiverse" | sudo tee -a /etc/apt/sources.list
  $ sudo apt-get update
  $ apt-cache policy ec2-ami-tools
    ec2-ami-tools:
      Installed: (none)
      Candidate: 1.3.49953-0ubuntu1.1
      Version table:
         1.3.49953-0ubuntu1.1 0
            500 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ maverick-proposed/multiverse i386 Packages
  $ sudo apt-get install ec2-ami-tools ec2-api-tools
- dest=/mnt/dest
- sudo rm -Rf "${dest}" && sudo mkdir -p "${dest}" && cd "${dest}"
- name=ec2-ami-rebundle-$(lsb_release -sc).img
- arch=$(uname -m) ; [ "${arch}" = "i686" ] && arch=i386
- sudo ec2-bundle-vol \
   --cert "${EC2_CERT}" --privatekey "${EC2_PRIVATE_KEY}" \
   --user "${EC2_USER_ID}" \
   --arch ${arch} \ --destination /mnt/dest \
   --arch "${arch}" \
   --prefix "${name}" \
   --size 2048
- verify that / and target have the same fs info:
 $ sudo blkid ${name} /dev/sda1
 ec2-ami-rebundle-maverick.img: LABEL="uec-rootfs" UUID="7742f6ee-e492-4019-a70f-877c43562a7b" TYPE="ext4"
 /dev/sda1: LABEL="uec-rootfs" UUID="7742f6ee-e492-4019-a70f-877c43562a7b" TYPE="ext4"
- upload/register
  bucket=smoser-test
  $ ec2-upload-bundle \
   --access-key ${EC2_ACCESS_KEY} --secret-key ${EC2_SECRET_KEY} \
   --bucket ${bucket} \
   --manifest ${name}.manifest.xml
  $ ec2-register --name ${name%.img} ${bucket}/${name}.manifest.xml
- run the new instance, and verify you can connect
  ec2-run-instances <new_ami>
  ssh ubuntu@....

This all worked fine. Prior to this bug being fixed, the filesystem would have always been ext3, and have had no label and a different uuid than this.

Scott Moser (smoser) wrote :

- I did same as above on lucid AMI:
  us-east-1 ami-88f504e1 canonical ubuntu-lucid-10.04-i386-server-20101228
- package tested was:
  $ apt-cache policy ec2-ami-tools
ec2-ami-tools:
  Installed: (none)
  Candidate: 1.3-45758-0ubuntu1.1
  Version table:
     1.3-45758-0ubuntu1.1 0
        500 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ lucid-proposed/multiverse Packages
     1.3-45758-0ubuntu1 0
        500 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ lucid/multiverse Packages
- $ sudo blkid ${name} /dev/sda1
  ec2-ami-rebundle-lucid.img: LABEL="uec-rootfs" UUID="844b1f46-656d-4a2f-b1b6-5c0d9d110731" SEC_TYPE="ext2" TYPE="ext3"
  /dev/sda1: LABEL="uec-rootfs" UUID="844b1f46-656d-4a2f-b1b6-5c0d9d110731" TYPE="ext3"

tags: added: verification-done
removed: verification-needed
Scott Moser (smoser) wrote :

Verification is done for lucid and maverick on ec2-ami-tools.

I've just uploaded the euca2ools packages that fix this also. The 2 packages are completely stand alone, once euca2ools gets into -proposed I will test with almost identical test and record that response here.

Martin Pitt (pitti) wrote :

Accepted euca2ools into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in euca2ools (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted euca2ools into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in euca2ools (Ubuntu Maverick):
status: In Progress → Fix Committed
Scott Moser (smoser) wrote :
Download full text (3.3 KiB)

I've verified maverick and lucid euca2ools for this bug, by doing the following:

==== Maverick Euca2ools ====
- launch ami-a6f504cf, ssh
  us-east-1 ami-a6f504cf canonical ubuntu-maverick-10.10-i386-server-20101225
- sudo mkdir /mnt/creds && sudo chown ubuntu:ubuntu /mnt/creds
  . /mnt/creds # creds file set up to have necessary environment vars
- add proposed and install/upgrade package
  $ mirror=$(awk '$0 ~ /^deb / { print $2 ; exit(0); }' /etc/apt/sources.list)
  $ echo "deb ${mirror} $(lsb_release -sc)-proposed main universe multiverse" | sudo tee -a /etc/apt/sources.list
  $ sudo apt-get update
  $ apt-cache policy euca2ools
  euca2ools:
    Installed: 1.2-0ubuntu11
    Candidate: 1.2-0ubuntu11.1
    Version table:
       1.2-0ubuntu11.1 0
          500 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ maverick-proposed/main i386 Packages
   *** 1.2-0ubuntu11 0
          500 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
          100 /var/lib/dpkg/status
  $ sudo apt-get install euca2ools
- dest=/mnt/dest
- sudo rm -Rf "${dest}" && sudo mkdir -p "${dest}" && cd "${dest}"
- name=euca-ami-rebundle-$(lsb_release -sc)
- arch=$(uname -m) ; [ "${arch}" = "i686" ] && arch=i386
- sudo euca-bundle-vol \
   --cert "${EC2_CERT}" --privatekey "${EC2_PRIVATE_KEY}" \
   --user "${EC2_USER_ID}" \
   --destination /mnt/dest \
   --arch ${arch} \
   --prefix "${name}" \
   --size 2048
- verify that / and target have the same fs info:
 $ sudo blkid ${name}.img /dev/sda1
 euca-ami-rebundle-maverick.img: LABEL="uec-rootfs" UUID="7742f6ee-e492-4019-a70f-877c43562a7b" TYPE="ext4"
 /dev/sda1: LABEL="uec-rootfs" UUID="7742f6ee-e492-4019-a70f-877c43562a7b" TYPE="ext4"
- bundle/upload/register
  #due to bug 665667, we have to bundle the .img file with the ec2-ami-tools
  ## begin bug 665667 work around ##
  sudo apt-get install ec2-ami-tools
  sudo rm *.part.* *manifest.xml
  aki=$(wget -q http://169.254.169.254/latest/meta-data/kernel-id -O -)
  sudo ec2-bundle-image \
     --cert ${EC2_CERT} --privatekey ${EC2_PRIVATE_KEY} --user ${EC2_USER_ID} \
     --destination ${dest} \
     --image ${dest}/${name}.img \
     --kernel ${aki} --arch ${arch}
  ## end bug 665667 work around ##

  bucket=smoser-test
  $ euca-upload-bundle \
   --access-key ${EC2_ACCESS_KEY} --secret-key ${EC2_SECRET_KEY} \
   --bucket ${bucket} \
   --manifest ${name}.img.manifest.xml
  $ euca-register ${bucket}/${name}.img.manifest.xml
- run the new instance, and verify you can connect
  ec2-run-instances <new_ami>
  ssh ubuntu@....

==== Lucid Euca2ools ====
I followed the same process as with maverick above, with the following differences:
- launch ami-88f504e1, ssh connect
  us-east-1 ami-88f504e1 ubuntu-lucid-10.04-i386-server-20101228
- $ apt-cache policy euca2ools
  euca2ools:
    Installed: 1.2-0ubuntu10
    Candidate: 1.2-0ubuntu10.1
    Version table:
       1.2-0ubuntu10.1 0
          500 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ lucid-proposed/main Packages
   *** 1.2-0ubuntu10 0
          500 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ lucid/main Packages
          100 /var/lib/dpkg/status
- $ sudo blkid ${name}.img /dev/sda1
  euca-ami-reb...

Read more...

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package euca2ools - 1.2-0ubuntu10.1

---------------
euca2ools (1.2-0ubuntu10.1) lucid-proposed; urgency=low

  * copy filesystem uuid, label, fstype from source filesytem to
    bundled volume (LP: #667793, #672986)
 -- Scott Moser <email address hidden> Fri, 14 Jan 2011 01:31:27 -0500

Changed in euca2ools (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ec2-ami-tools - 1.3-45758-0ubuntu1.1

---------------
ec2-ami-tools (1.3-45758-0ubuntu1.1) lucid-proposed; urgency=low

  * copy filesystem uuid, label, fstype from source filesytem to
    bundled volume (LP: #667793, #672986)
 -- Scott Moser <email address hidden> Fri, 14 Jan 2011 01:28:39 -0500

Changed in ec2-ami-tools (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ec2-ami-tools - 1.3.49953-0ubuntu1.1

---------------
ec2-ami-tools (1.3.49953-0ubuntu1.1) maverick-proposed; urgency=low

  * copy filesystem uuid, label, fstype from source filesytem to
    bundled volume (LP: #667793, #672986)
 -- Scott Moser <email address hidden> Fri, 14 Jan 2011 00:56:22 -0500

Changed in ec2-ami-tools (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package euca2ools - 1.2-0ubuntu11.1

---------------
euca2ools (1.2-0ubuntu11.1) maverick-proposed; urgency=low

  * copy filesystem uuid, label, fstype from source filesytem to
    bundled volume (LP: #667793, #672986)
 -- Scott Moser <email address hidden> Fri, 14 Jan 2011 01:12:33 -0500

Changed in euca2ools (Ubuntu Maverick):
status: Fix Committed → Fix Released
Scott Moser (smoser) wrote :

Just a note, this patch was sent to amazon (upstream) at https://forums.aws.amazon.com/thread.jspa?messageID=215902&

Changed in euca2ools:
assignee: nobody → Mitch Garnaat (mitch-garnaat)
Changed in euca2ools:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers