euca-describe-images <img> lists all images when querying against ec2

Bug #541468 reported by Scott Moser on 2010-03-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
euca2ools
Fix Released
Undecided
Unassigned
euca2ools (Ubuntu)
Low
Scott Moser

Bug Description

Binary package hint: euca2ools

This is possibly a regression caused by changes for bug 531076 or bug 530296 .

To show the problem,
$ cat ~/.eucarc.ec2-us-east-1
EC2_ACCESS_KEY=XXXX
EC2_SECRET_KEY=YYYY
EC2_USER_ID=0123-4567-8910
EUCALYPTUS_CERT=/usr/share/euca2ools/cert-ec2.pem
EC2_URL=https://ec2.amazonaws.com

$ euca-describe-images --config ~/.eucarc.ec2-us-east-1 ami-5154b838
<long list of everything here>

conversely, with ec2-describe-images:
$ xc2 describe-images ami-5154b838
IMAGE ami-5154b838 ubuntu-images-milestone-us/ubuntu-lucid-alpha3-i386-server-20100224.manifest.xml 099720109477 available public i386 machine aki-7b54b812 instance-store

ProblemType: Bug
Architecture: amd64
Date: Thu Mar 18 14:57:31 2010
DistroRelease: Ubuntu 10.04
Package: euca2ools 1.2-0ubuntu6
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-server
SourcePackage: euca2ools
Uname: Linux 2.6.32-16-server x86_64

Scott Moser (smoser) wrote :
Neil Soman (neilsoman) wrote :

Definitely a regression due to 530296 and not 531076

Neil Soman (neilsoman) wrote :

Reintroducing the workaround fixes this problem. The list from EC2 includes all images even if an image id is specified.

Neil Soman (neilsoman) wrote :

Fixed in revno 268.

Describe images asks for a list of images as before (instead of asking for all images). It will then double check the list against the list specified by the user and display only the intersection, just in case the service sends back all images.

Changed in eucalyptus:
status: New → Fix Committed
Changed in euca2ools:
status: New → Fix Committed

On Thu, 18 Mar 2010, Neil Soman wrote:

> Reintroducing the workaround fixes this problem. The list from EC2
> includes all images even if an image id is specified.

This is simply not true.
You can convince yourself of it by using 'get_image' from boto.
   euca_conn.get_image(image_ids[0])
or
   images = euca_conn.get_all_images(image_ids=image_ids, None, None)

The former will return 1 image, the latter, given a valid list, will
return that number.

I'll play with this some more tomorrow. The work around of locally
filtering everything can obviously be made to work, but its terribly
wasteful.

Neil Soman (neilsoman) wrote :

Yeah, looks like I can get boto to return the correct image is by setting owners and executable_by to None. If executable_by is set to ['self'], nothing is returned, which does not make a lot of sense.

Good luck getting to the bottom of this. Frankly, this is beyond the scope of euca2ools functionality, since it clearly works as expected with Eucalyptus and I can't devote any more time to this.

Mathias Gug (mathiaz) on 2010-03-23
Changed in euca2ools (Ubuntu):
importance: Undecided → Low
Scott Moser (smoser) wrote :

I've run a fair set of tests, and the attached patch results in identical image lists between euca-describe-images and ec2-describe-images with my user id pointed at ec2.

tags: added: patch
Scott Moser (smoser) wrote :

I ran the attached file as ec2 my account. As shown here, I got identical results for the modified euca-describe-images and ec2-describe-images
all-image: euca: 0 ec2: 0
all: euca: 5124 ec2: 5124
canonical-or-amazon: euca: 718 ec2: 718
canonical-or-amazon-x-self: euca: 44 ec2: 44
none: euca: 49 ec2: 49
o-self-image: euca: 1 ec2: 1
x-eric: euca: 0 ec2: 0
x-scott: euca: 47 ec2: 47
x-self-eric: euca: 386 ec2: 386
x-self-image: euca: 1 ec2: 1
x-self: euca: 47 ec2: 47

Scott Moser (smoser) wrote :
Changed in euca2ools (Ubuntu):
assignee: nobody → Scott Moser (smoser)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package euca2ools - 1.2-0ubuntu7

---------------
euca2ools (1.2-0ubuntu7) lucid; urgency=low

  [ Dustin Kirkland ]
  * Try to get the Debian and Ubuntu packaging in better sync
    - debian/watch: pulled from Debian
    - debian/rules, debian/manpages: fix manpage building, cleanup,
      and install
    - debian/compat, debian/control:
      + bump to debhelper 7
      + update homepage
      + bump standards version
      + bump python-boto dep (doesn't affect us, but gets us closer to
        Debian's packaging)

  [ Scott Moser ]
  * euca-describe-images returns same result sets as ec2-describe-images
    LP: #541468
 -- Dustin Kirkland <email address hidden> Wed, 24 Mar 2010 16:14:44 -0700

Changed in euca2ools (Ubuntu):
status: In Progress → Fix Released
Changed in euca2ools:
status: Fix Committed → Fix Released
no longer affects: eucalyptus
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers