Make more of Etoile available as binaries

Bug #269224 reported by Warbo on 2008-09-12
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
etoile (Ubuntu)
Undecided
Unassigned

Bug Description

The Etoile source in Ubuntu/Debian currently builds 2 packages (camaelon.app and dictionaryreader.app) and a dummy package (wildmenus.app), but there is a lot more stuff in Etoile which could be made available in the repos. This includes the various Etoile libraries like RSSKit, XMPPKit, EtoileUI, etc. as well as end user applications like FontManager and the Azalea window manager. Etoile applications ("Services") can even run a complete desktop.

Despite this source package being available, the only way to get these things is to compile SVN. Please make it easier to install by packaging it.

Brian (neon-lights) on 2008-09-12
Changed in etoile:
status: New → Confirmed
Thomas Perl (thp) wrote :

+1 from me. That would be really helpful for getting users to try out Etoile.

Hubert Chathi (uhoreg) wrote :

Yes, the Etoile package in Debian/Ubuntu is in a bad (and outdated) state. If you want to help with the package, feel free to contact the Debian GNUstep packaging team (<email address hidden>). We would like to see the Etoile package improved, but we don't have the manpower to do it.

Ben M. (bmhm) wrote :

I wonder this "bug" is still set to confirmed. Has anyone contacted the dev team of Étoilé?

Thomas Perl (thp) wrote :

By the way, there is a mailing list specially targeted towards packagers:

https://mail.gna.org/listinfo/etoile-packaging/

ShanaVar (shanavar) wrote :

Etoile 0.4.1 will be released this week (according to their mailing list) so this would be a good oportunity to build all of etoile stable (including all the apps). It does build fine, though it doesnt start n jaunty

Greetings

Warbo (warbo) wrote :

I'd help to package it, but whilst I can get it to build (mostly, had some problems with their Smalltalk system) I can't get it to run :( Gave up after about 5 complete rebuilds of GNUStep and Etoile.

This is why packages would be nice :D

Hubert Chathi (uhoreg) wrote :

Unfortunately, if it doesn't run, then having packages for it won't help, as the package won't work either. :/ Can you give more details about how it won't run? Etoile has a lot of components; do none of them work? Have you tried using the latest GNUstep? Packages for the latest released GNUstep (not SVN) can be found at <http://debian.uhoreg.ca/experimental/gnustep/> (built for Debian, but should work in Ubuntu).

ShanaVar (shanavar) wrote :

i just got to build & start "without" a problem today. I simply followed the instructions in the install and install.Ubuntu (for Jaunty) files to install the dependencies. I did build it on Jaunty. The "only" problem i encountered was the version of gnustep. There was a bug in it, preventing etoile to finish building. I found on google that there should be a patch, but i didnt know how to handle that error so I simply took gnustep packages from karmic and all went well (the performance is a bit sluggish though, dont know if i use the wrong gnustep backend or something else - have no clue there).

PS: just noticed in the quite-write correction that Ubuntu is marked as wrong and if you try Microsoft it isnt :)

Greetings

ShanaVar (shanavar) wrote :

sorry, forgot to add: i only tried the core components of etoile from trunk, no extras tested

ShanaVar (shanavar) wrote :

Ok I finally managed to build etoile and GNUstep so that everything works! I did make an archive and put it up on rapidshare with the source files from GNUstep/Etoile I used to build. I did it on a clean jaunty install (I didn't even apply updates) and copied together instructions that are included in the build-2 directory of the steps i did. the instructions, esp. those for installing build dependencies are for jaunty only and i'm afraid they wont work on another version. Etoile didn't find the libs as they are usually stored in /lib on a debian system, so i just copied them over to /lib. Also note, that I made the experience that if you modify the installpath of GNUstep, that the setup.sh from Etoile won't find it and it will lead to problems. I'm sorry, I dont know how to make packages and a ppa, so somebody else has to do that if interested.

I had some problems using tar through gui, as it followed one symbolic link and made a file the size of 1GB. I used tar on command line and hope that everything went well. If it didn't just drop me a post or email and I will try to correct it.

Greetings!

http://rapidshare.com/files/232602425/etoile-gnustep.tar.gz.html

ShanaVar (shanavar) wrote :

I am really sorry about the 4th post in a row. An edit function would be really nice...

But I wanted to say forget the comment on copy you libs, as i forgot to source GNUstep.sh.

Greeting.

Ben M. (bmhm) wrote :

Thanks for your testing. I will try them soon and hopefully someone else, too.

If we can find out what's the perfomance issue about, Étoilé would be a nice think to have in Ubuntu as its goal perfectly hits Ubuntus goal: Easy to use interface, everything is a file &c.

Regards

ShanaVar (shanavar) wrote :

The performance is fine with those gnustep svn now(I build it with cairo backend!).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers