Packaging: Provide etcd package to provide distributed key value store on POWER

Bug #1673443 reported by bugproxy on 2017-03-16
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
High
Unassigned
etcd (Ubuntu)
High
Tim Van Steenburgh

Bug Description

As package is now available in Debian SID at level 3.1.2+dfsg-1
https://packages.debian.org/search?searchon=sourcenames&keywords=etcd
can we expect an upgrade on Ubuntu ?

bugproxy (bugproxy) on 2017-03-16
tags: added: architecture-ppc64le bugnameltc-146641 severity-high targetmilestone-inin1710
Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)
affects: ubuntu → linux (Ubuntu)
Tim Gardner (timg-tpi) on 2017-03-16
affects: linux (Ubuntu) → etcd (Ubuntu)
tags: added: upgrade-software-version
Manoj Iyer (manjo) wrote :

The zesty version of etc is currently 3.1.0-1 (universe package). This will likely be upgraded in 17.10 to 3.1.2. there might be enough time between now and then for the debian package to make it into debian stable.

Steve Langasek (vorlon) on 2017-05-17
Changed in etcd (Ubuntu):
assignee: Taco Screen team (taco-screen-team) → Tim Van Steenburgh (tvansteenburgh)
Steve Langasek (vorlon) wrote :

There is currently an etcd 3.1.4+dfsg-1 in artful-proposed, which is not building because of failing tests.

In terms of providing an up-to-date etcd to Ubuntu users on the releases they will likely be using to deploy production services (i.e., LTS releases), instead of SRUing the etcd package in universe, our preferred strategy is to use the snap package. Tim (assigned)'s team will look at updating this snap to provide ppc64el support.

Frank Heimes (frank-heimes) wrote :

Would that package also be made available for other architectures?
(having especially s390x in mind)

Here's what we have in the snap store today:

Track Arch Channel Version Revision
2.3 amd64 stable 2.3.8 55
                  candidate ^ ^
                  beta ^ ^
                  edge ^ ^
3.0 amd64 stable 3.0.17 57
                  candidate ^ ^
                  beta ^ ^
                  edge ^ ^
3.1 amd64 stable 3.1.8 62
                  candidate ^ ^
                  beta ^ ^
                  edge 3.1+master 53
3.2 amd64 stable - -
                  candidate 3.2.0-rc.1 61
                  beta 3.2.0-rc.1 61
                  edge 3.2.0-rc.1-29-gb003734 60
         ppc64el stable - -
                  candidate 3.2.0-rc.1 63
                  beta 3.2.0-rc.1 63
                  edge ^ ^

I intend to add arm64 snaps soon, as arm64 bins are already provided by upstream. I'll also add s390x once upstream begins to provide those. There's an issue open for that here: https://github.com/coreos/etcd/issues/7978

LP obliterated the formatting, see here instead: http://pastebin.ubuntu.com/24667709/

Manoj Iyer (manjo) on 2017-06-01
tags: added: ubuntu-17.10
Manoj Iyer (manjo) on 2017-07-19
Changed in etcd (Ubuntu):
importance: Undecided → High
Changed in ubuntu-power-systems:
importance: Undecided → High
Changed in etcd (Ubuntu):
status: New → In Progress
Changed in ubuntu-power-systems:
status: New → In Progress
Manoj Iyer (manjo) on 2017-07-31
tags: added: triage-g
Manoj Iyer (manjo) on 2017-09-18
tags: added: triage-r
removed: triage-g

Snap store has ppc64el builds for 2.3.8, 3.0.17, 3.1.10, and 3.2.8.

`snapcraft status --arch ppc64el etcd | pastebinit`
http://paste.ubuntu.com/25664865/

Changed in etcd (Ubuntu):
status: In Progress → Fix Released
bugproxy (bugproxy) on 2017-10-13
tags: added: targetmilestone-inin1804
removed: targetmilestone-inin1710
Changed in ubuntu-power-systems:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.