grub is not installed

Bug #34205 reported by Martin Pitt on 2006-03-09
8
Affects Status Importance Assigned to Milestone
espresso (Ubuntu)
Medium
Unassigned

Bug Description

I just tried espresso with today's (March 09) amd64 live CD. Grub was not installed, when I rebooted, I just saw my old grub again with no possibility to boot the new espresso installation.

In case it helps: /dev/hda2 has my old installation; I installed the new one into /dev/hdc2 (root) and /dev/hda1 (swap, shared amongst all installations).

Bug 32047 already complained about a missing grub, but that one was fixed two weeks ago, so maybe mine has a different reason.

/var/log/installer/espresso

Colin Watson (cjwatson) wrote :

Any chance you could try an installation with ESPRESSO_DEBUG=1 set at some point? I wonder if it's perhaps installing grub onto the wrong device.

Ernst Sjöstrand (ernstp) wrote :

I had this problem too with my Ubuntu i386 livecd from last week when installing using espresso.
The install-cd worked fine.

Colin Watson (cjwatson) wrote :

Incidentally, at the moment ESPRESSO_DEBUG=1 logs may contain passwords. Be careful to use a throwaway password, or go through the log blanking out passwords, before submitting full debug logs to bug reports.

I'll try to fix this at some point.

Eric Spierings (ericspierings) wrote :

same problem here

Matt Zimmerman (mdz) on 2006-04-05
Changed in espresso:
status: Unconfirmed → Needs Info
Alexandre Otto Strube (surak) wrote :

it happened with 0.99.36 on amd64. However, it got fixed with 0.99.42.

Changed in espresso:
status: Needs Info → Fix Released
Colin Watson (cjwatson) wrote :

Martin, can you please confirm that this is fixed for you? I don't like bugs being closed by non-submitters on the basis that it now works for them, since they may misunderstand the cause.

Martin Pitt (pitti) wrote :

I tried today's live CDs, but they already stopped at bug 39116, so I can't test right now. I will reopen this if it still happens.

Hi Colin,

Colin Watson [2006-04-10 23:03 -0000]:
> Martin, can you please confirm that this is fixed for you?

Confirmed, works fine now.

Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments