Ubuntu

[needs-packaging] esddsp LD_PRELOAD broken

Reported by Jordan Callicoat on 2008-04-09
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
esound (Ubuntu)
Wishlist
Daniel T Chen

Bug Description

Binary package hint: esound-clients

Ubuntu Version:
8.04 (hardy)

Packages effected:
esound-clients
libesd-alsa0

Versions effected:
>= 0.2.36-1

Problem:
Since 0.2.36-1, libesd-alsa0 places library and symlink in /usr/lib/esound, but esddsp script wasn't updated.

This causes esddsp to fail with the message:

ERROR: ld.so: object '/usr/lib/libesddsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.

Steps to reproduce:
Run an app that uses esddsp

Reproducible:
Always.

Related branches

Jordan Callicoat (monkeesage) wrote :
Jordan Callicoat (monkeesage) wrote :

Still broken....

Jordan Callicoat (monkeesage) wrote :

Still...

Jordan Callicoat (monkeesage) wrote :

*sigh*...still

Jordan Callicoat (monkeesage) wrote :

And many months later...guess what? STILL broken. :/ Why?

Jordan Callicoat (monkeesage) wrote :

$ esddsp audacity
ERROR: ld.so: object 'libesddsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
...

Jordan Callicoat (monkeesage) wrote :

Hmm...I thought somebody uploaded a patch like 8 moths ago or something? That's odd...

David Henningsson (diwic) wrote :

Confirmed on a daily-live Jaunty CD image. I guess this is low priority as most people will use pulseaudio/padsp instead...

Changed in esound:
status: New → Confirmed
David Henningsson (diwic) wrote :

Additional note: All I tried was that "esddsp sleep 1" gave the same error as Jordan suggested. I haven't tried that the patch fixes the problem.

Jordan Callicoat (monkeesage) wrote :

Yeah, it's minor, but it takes like 2 minutes to confirm and review / apply patch, which is what I find annoying about it taking 8 months. However, I apologize for being so sarcastic in my last comment.

The patch actually should be slightly different now, since @libdir@ is removed from the LD_PRELOAD variable in esddsp.in. The fix can be confirmed from a current install with the following command:

sudo sed -i -e 's:LD_PRELOAD="libesddsp.so.0 libesd.so.0 $LD_PRELOAD":LD_PRELOAD="/usr/lib/esound/libesddsp.so.0 libesd.so.0 $LD_PRELOAD":' /usr/bin/esddsp

Updated patch attached.

David Henningsson (diwic) wrote :

Jordan, I understand your frustration. As nobody but yourself seems to want to take the time to review this patch, what I would do if I was in your shoes, that would be to see from where this error originates. Is it Ubuntu specific? Is it introduced in Debian? Or does it come from the Gnome/esound project? When you've figured that out, send your patch to the appropriate person (or mailing list), and hopefully you're patch will be accepted.

Daniel T Chen (crimsun) on 2009-02-09
Changed in esound:
assignee: nobody → crimsun
status: Confirmed → In Progress
Daniel T Chen (crimsun) wrote :

libesd{,-alsa}0 both ship /usr/lib/esound/libesddsp.so.0* and /usr/lib/libesd.so.0*; I've adjusted for this difference in jaunty's debdiff.

Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in esound:
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package esound - 0.2.40-0ubuntu3

---------------
esound (0.2.40-0ubuntu3) jaunty; urgency=low

  * Make esddsp.in honour the correct libdir path for
    libesd*.so.0 (LP: #214465)

 -- Daniel T Chen <email address hidden> Mon, 09 Feb 2009 17:18:43 -0500

Changed in esound:
status: In Progress → Fix Released
Cerin (chrisspen) wrote :

I'm still getting this error in 10.04...

Cerin (chrisspen) wrote :

I'm getting the error when I run:

echo '(SayText "hello world")' | esddsp festival --pipe

ERROR: ld.so: object '/usr/lib/esound/libesddsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libesd.so.0' from LD_PRELOAD cannot be preloaded: ignored.

Changed in esound (Ubuntu):
status: Fix Released → Incomplete
Changed in esound (Ubuntu):
status: Incomplete → Confirmed
David Henningsson (diwic) wrote :

@Cerin, it works fine here under 10.04, can you try reinstalling the esound-clients package and see if that helps?

Changed in esound (Ubuntu):
status: Confirmed → Incomplete

confirmed in up to date ubuntu 10.10

matthias@purefruit:~/smb$ esddsp -v --mmap ./quake3.x86
server:
name: ./quake3.x86
command line: ./quake3.x86
ERROR: ld.so: object '/usr/lib/esound/libesddsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
Q3 1.31 linux-i386 Dec 17 2001

Cerin (chrisspen) wrote :

Yes, even after reinstalling esound-clients, I still get the error.

Cerin (chrisspen) wrote :

I should note I only get this error on 64-bit systems. It works fine on my 32-bit systems.

David Henningsson (diwic) wrote :

@Cerin, is this related to trying to run 32-bit executables on a 64-bit kernel?

Benoit (benghost1) wrote :

i have a 64 system and i have this bug... i have ubuntu 11.04

Cerin (chrisspen) wrote :

@David, I'm not sure if any executables are 32-bit. I've installed the stock Ubuntu packages for Festival/esdsp/etc that were available for the platform.

Thomas Hotz (thotz) wrote :

Marking back as confirmed.

Changed in esound (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers