[tribe 5] any time I open a document in gedit (from the shell) I get /usr/bin/esd: not found

Bug #134641 reported by Christer Edwards on 2007-08-25
12
Affects Status Importance Assigned to Milestone
esound (Ubuntu)
Low
Martin Pitt

Bug Description

Binary package hint: gedit

For any document I open with gedit from the shell I get the error:

/bin/sh: /usr/bin/esd: not found

gedit functions properly once launched from what I can tell, but that error is displayed on the shell from the time of launch.
GNOME gedit 2.19.90
2.6.22-10-generic

Tribe 5, downloaded and installed (including updates) 24-Aug-2007

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for your bug. That's not really an error, rather an indication of libgnome that esd is not used, why do you think that's an issue?

Changed in gedit:
importance: Undecided → Wishlist
status: New → Triaged
Martin Pool (mbp) wrote :

I get this too from all gnome programs.

If not using esd is the intended behaviour for gnome in gutsy, then why is it producing warnings?

Martin Pitt (pitti) on 2007-10-05
Changed in libgnome:
assignee: nobody → pitti
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

This actually comes from the esd client lib.

Changed in esound:
importance: Wishlist → Low
Martin Pitt (pitti) wrote :

esound (0.2.38-0ubuntu4) gutsy; urgency=low

  * esdlib.c: Check if the esd binary exists at all. If not, forego forking
    a shell and trying to execute it. This both improves startup time and also
    avoids the "/bin/sh: /usr/bin/esd: not found" warning. (LP: #134641)

 -- Martin Pitt <email address hidden> Fri, 05 Oct 2007 14:00:43 +0200

Changed in esound:
status: In Progress → Fix Released

> * esdlib.c: Check if the esd binary exists at all. If not, forego forking
> a shell and trying to execute it. This both improves startup time and also
> avoids the "/bin/sh: /usr/bin/esd: not found" warning. (LP: #134641)

I haven't looked at the source at all, but this makes me wonder if it
should ever be invoking through the shell, rather than executing it
directly. Just a random thought.

--
Martin

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers