erlang version 14.b.2-dfsg-3ubuntu2 failed to build with openjdk-7

Bug #888123 reported by James Page
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
erlang (Debian)
Fix Released
Unknown
erlang (Ubuntu)
High
James Page
Quantal
High
James Page
openjdk-7 (Ubuntu)
High
James Page
Quantal
High
James Page

Bug Description

During a rebuild test on precise with default-jdk switched to openjdk-7, a build failure was detected for erlang version 14.b.2-dfsg-3ubuntu2.

See attached log for full build failure details.

This log snippet might also be of interest:

 at org.apache.fop.layoutmgr.PageBreaker.getNextBlockList(PageBreaker.java:143)
 at org.apache.fop.layoutmgr.PageBreaker.getNextBlockList(PageBreaker.java:132)
 at org.apache.fop.layoutmgr.AbstractBreaker.doLayout(AbstractBreaker.java:337)
 at org.apache.fop.layoutmgr.PageBreaker.doLayout(PageBreaker.java:85)
 at org.apache.fop.layoutmgr.PageSequenceLayoutManager.activateLayout(PageSequenceLayoutManager.java:107)
 at org.apache.fop.area.AreaTreeHandler.endPageSequence(AreaTreeHandler.java:238)
 at org.apache.fop.fo.pagination.PageSequence.endOfNode(PageSequence.java:120)
 at org.apache.fop.fo.FOTreeBuilder$MainFOHandler.endElement(FOTreeBuilder.java:349)
 at org.apache.fop.fo.FOTreeBuilder.endElement(FOTreeBuilder.java:177)
 at org.apache.xalan.transformer.TransformerIdentityImpl.endElement(TransformerIdentityImpl.java:1102)
 at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
 at org.apache.xerces.xinclude.XIncludeHandler.endElement(Unknown Source)
 at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndElement(Unknown Source)
 at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
 at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
 at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
 at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
 at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
 at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
 at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
 at org.apache.xalan.transformer.TransformerIdentityImpl.transform(TransformerIdentityImpl.java:485)
 at org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:299)
 at org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:130)
 at org.apache.fop.cli.Main.startFOP(Main.java:174)
 at org.apache.fop.cli.Main.main(Main.java:205)
Caused by: java.lang.IllegalArgumentException: Can't load standard profile: sRGB.pf
 at java.awt.color.ICC_Profile$2.run(ICC_Profile.java:931)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.awt.color.ICC_Profile.getStandardProfile(ICC_Profile.java:924)
 at java.awt.color.ICC_Profile.getDeferredInstance(ICC_Profile.java:1071)
 at java.awt.color.ICC_Profile.getInstance(ICC_Profile.java:843)
 at java.awt.color.ColorSpace.getInstance(ColorSpace.java:298)
 at javax.imageio.ImageTypeSpecifier.<clinit>(ImageTypeSpecifier.java:73)
 ... 60 more
make[4]: *** [../pdf/stdlib-1.17.3.pdf] Error 1
make[4]: Leaving directory `/«PKGBUILDDIR»/lib/stdlib/doc/src'
make[3]: *** [docs] Error 2
make[3]: Leaving directory `/«PKGBUILDDIR»/lib/stdlib'
make[2]: *** [docs] Error 2
make[2]: Leaving directory `/«PKGBUILDDIR»/lib'
make[1]: *** [docs] Error 2
make[1]: Leaving directory `/«PKGBUILDDIR»'
make: *** [docs-stamp] Error 2
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
────────────────────────────────────────────────────────────────────────────────
Build finished at 20111109-1338

Finished
────────

E: Build failure (dpkg-buildpackage died)

Revision history for this message
James Page (james-page) wrote : Build log
tags: added: amd64 auto java7-ftbfs
Revision history for this message
Gábor Lipták (gliptak) wrote :
Revision history for this message
James Page (james-page) wrote :

Fixed in openjdk-6 - but would appear to still be in issue with openjdk-7 - http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=641530

James Page (james-page)
tags: added: fop
Changed in erlang (Debian):
status: Unknown → Fix Released
Revision history for this message
James Page (james-page) wrote :

openjdk-7 does not have the same ICC handling patch as openjdk-6 does - see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=641530

Raising task for openjdk-7.

Changed in erlang (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in erlang (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → High
Changed in openjdk-7 (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → High
no longer affects: openjdk-7 (Ubuntu Oneiric)
no longer affects: erlang (Ubuntu Oneiric)
Changed in openjdk-7 (Ubuntu Quantal):
status: New → Confirmed
importance: Undecided → High
Changed in erlang (Ubuntu Quantal):
assignee: nobody → James Page (james-page)
James Page (james-page)
Changed in openjdk-7 (Ubuntu Quantal):
status: Confirmed → In Progress
Changed in erlang (Ubuntu Quantal):
status: Confirmed → In Progress
Changed in openjdk-7 (Ubuntu Quantal):
assignee: nobody → James Page (james-page)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openjdk-7 - 7~u3-2.1.1~pre1-1ubuntu4

---------------
openjdk-7 (7~u3-2.1.1~pre1-1ubuntu4) quantal; urgency=low

  * Cherry picked patch from openjdk-6 to fix handling of
    ICC profiles (LP: #888123, #888129).
 -- James Page <email address hidden> Wed, 30 May 2012 16:55:20 +0100

Changed in openjdk-7 (Ubuntu Quantal):
status: In Progress → Fix Released
Revision history for this message
James Page (james-page) wrote :

Build fine with openjdk-7 - 7~u3-2.1.1~pre1-1ubuntu4

Marked 'Fix Released'

Changed in erlang (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.