Ubuntu

erlang-doc-html conflicts with other erlang packages

Reported by Hans Nilsson on 2006-11-07
86
This bug affects 12 people
Affects Status Importance Assigned to Milestone
erlang (Debian)
Fix Released
Unknown
erlang (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Luca Falavigna
Nominated for Lucid by H.-Dirk Schmitt
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
erlang-doc-html (Ubuntu)
Low
Unassigned
Declined for Gutsy by Luca Falavigna
Nominated for Lucid by H.-Dirk Schmitt
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: erlang-doc-html

In Ubuntu Edgy Eft (6.10) I installed the package erlang and all it's dependencies ( erlang-base, erlang-nox etc)

Erlang-doc-html was not among them, but when I tried to install it there was a conflict with erlang, erlang-base etc and Synaptic wanted to remove them!

The same happend with erlang-manpages.

Thomas Stenhaug (karvus) wrote :

I have this problem as well, with 6.10. What steps should be taken to help get this fixed?

Kai Kasurinen (kai-kasurinen) wrote :

(Note to self)

Edgy:

  erlang: Depends: erlang-base (>= 1:11.b.1-1) but it is not going to be installed or
                   erlang-base-hipe (>= 1:11.b.1-1) but it is not going to be installed
          Depends: erlang-base (< 1:11.b.1-1.0) but it is not going to be installed or
                   erlang-base-hipe (< 1:11.b.1-1.0) but it is not going to be installed
          Depends: erlang-nox (= 1:11.b.1-1) but it is not going to be installed
          Depends: erlang-x11 (= 1:11.b.1-1) but it is not going to be installed
          Depends: erlang-mode (= 1:11.b.1-1) but it is not going to be installed
          Depends: erlang-src (= 1:11.b.1-1) but it is not going to be installed
          Depends: erlang-dev (>= 1:11.b.1-1) but it is not going to be installed
          Depends: erlang-dev (< 1:11.b.1-1.0) but it is not going to be installed
          Depends: erlang-examples (= 1:11.b.1-1) but it is not going to be installed
          Conflicts: erlang-manpages (< 1:11.b.1) but 1:10.b.10-1 is to be installed
          Conflicts: erlang-doc-html (< 1:11.b.1) but 1:10.b.10-1 is to be installed

Martin Pool (mbp) wrote :

Still present in gutsy.

Changed in erlang-doc-html:
status: New → Confirmed

erlang-doc-html version trails behind the erlang version. erlang-doc-html should be synched from Debian.

Steve Salkin (steve-salkin) wrote :

In gutsy final, erlang-doc-html still makes synaptic want to uninstall the rest of the erlang packages. erlang-manpages installs all right though.

$ sudo apt-get install erlang-doc-html
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  ejabberd erlang erlang-base erlang-dev erlang-examples erlang-mode erlang-nox erlang-src erlang-x11 yaws yaws-wiki
The following NEW packages will be installed:
  erlang-doc-html

Vsevolod Krishchenko (mstu) wrote :

"Me too." I cannot understand why it works in my debian sid (same packages?) but does not work in my ubuntu gutsy.

Ok, I can live with wget -c -m http://www.erlang.org/doc

description: updated
Changed in erlang-doc-html:
importance: Undecided → Low
David Cordero (david.cordero) wrote :

erlang-doc-html was just updated to hardy. Sorry i didn't check it before create the new package.

http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=erlang-doc-html&searchon=names&subword=1&version=hardy&release=all

Must be this bug be marked as fixed?

Daniel Holbach (dholbach) wrote :

Looks like it:

root@lovegood:~# LC_ALL=C apt-get install -s erlang erlang-doc-html
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  erlang-base erlang-dev erlang-nox erlang-x11 libltdl3 libsctp1 odbcinst1debian1 unixodbc
Suggested packages:
  erlang-manpages libmyodbc odbc-postgresql libct1
Recommended packages:
  erlang-examples erlang-mode erlang-src tk8.4 wish linux-image-2.6-486 linux-image-2.6 lksctp-tools
The following NEW packages will be installed:
  erlang erlang-base erlang-dev erlang-doc-html erlang-nox erlang-x11 libltdl3 libsctp1 odbcinst1debian1 unixodbc
0 upgraded, 10 newly installed, 0 to remove and 161 not upgraded.
Inst libsctp1 (1.0.7.dfsg-2 Ubuntu:8.04/hardy)
Inst erlang-base (1:11.b.5dfsg-11 Ubuntu:8.04/hardy)
Inst erlang-dev (1:11.b.5dfsg-11 Ubuntu:8.04/hardy)
Inst libltdl3 (1.5.24-2ubuntu2 Ubuntu:8.04/hardy)
Inst odbcinst1debian1 (2.2.11-16 Ubuntu:8.04/hardy)
Inst unixodbc (2.2.11-16 Ubuntu:8.04/hardy)
Inst erlang-nox (1:11.b.5dfsg-11 Ubuntu:8.04/hardy)
Inst erlang-x11 (1:11.b.5dfsg-11 Ubuntu:8.04/hardy)
Inst erlang (1:11.b.5dfsg-11 Ubuntu:8.04/hardy)
Inst erlang-doc-html (1:11.b.5dfsg-1 Ubuntu:8.04/hardy)
Conf libsctp1 (1.0.7.dfsg-2 Ubuntu:8.04/hardy)
Conf erlang-base (1:11.b.5dfsg-11 Ubuntu:8.04/hardy)
Conf erlang-dev (1:11.b.5dfsg-11 Ubuntu:8.04/hardy)
Conf libltdl3 (1.5.24-2ubuntu2 Ubuntu:8.04/hardy)
Conf odbcinst1debian1 (2.2.11-16 Ubuntu:8.04/hardy)
Conf unixodbc (2.2.11-16 Ubuntu:8.04/hardy)
Conf erlang-nox (1:11.b.5dfsg-11 Ubuntu:8.04/hardy)
Conf erlang-x11 (1:11.b.5dfsg-11 Ubuntu:8.04/hardy)
Conf erlang (1:11.b.5dfsg-11 Ubuntu:8.04/hardy)
Conf erlang-doc-html (1:11.b.5dfsg-1 Ubuntu:8.04/hardy)
root@lovegood:~#

Changed in erlang-doc-html:
status: Confirmed → Fix Released
dweldon (dweldon-gmail) wrote :

this is broken again in 9.04

sudo apt-get install -s erlang-doc-html erlang-base
...
erlang-base: Conflicts: erlang-doc-html (< 1:12.b.5-dfsg) but 1:12.b.3-dfsg-1 is to be installed

Changed in erlang-doc-html (Ubuntu):
status: Fix Released → Incomplete
David Stansby (dstansby) wrote :

I can also confirm this problem is occurring on the latest version of 9.10.

David Stansby (dstansby) on 2009-07-21
Changed in erlang-doc-html (Ubuntu):
status: Incomplete → Confirmed
Iain Lane (laney) wrote :

I don't see what there is to sponsor here. Can someone explain? Also there seems to be a new upstream release in Debian. Do we want this?

Changed in erlang-doc-html (Ubuntu):
status: Confirmed → Incomplete
dweldon (dweldon-gmail) wrote :

The packages: erlang-doc-html and erlang-manpages are for a prior version of erlang. Furthermore, if you attempt to install erlang-doc-html, apt will actually see a package conflict. In order to get around this I had to install the docs outside of the package manager which is annoying.

I see debian sid has the latest version of erlang (R13B01). The answer is yes, I for one would very much like to see this released into 9.04 asap.

Erik Kronberg (eakron) wrote :

It seems to be a simple inconsistency in versions. I'm new at this packing and I can't seem to get it right, but the problem seems to be that erlang-doc-html is version 13.b-dfsg1 while erlang-base is 13.b.1-dfsg, causing a conflict. If someone could take a second of their busy time to answer some questions I think I could fix it.

Erik Kronberg (eakron) wrote :

Changed the upstream version from 13.b-dfsg1 to 13.b.1-dfsg, to remove conflict with erlang-base (that causes erlang-base to be removed if you install erlang-doc-html). However, the documentation version is probably incorrect. Tried building and it installs fine, no conflict.

Changed in erlang-doc-html (Ubuntu):
status: Incomplete → Fix Committed
assignee: nobody → Erik Kronberg (eakron)
Erik Kronberg (eakron) on 2009-11-10
Changed in erlang-doc-html (Ubuntu):
assignee: Erik Kronberg (eakron) → nobody
Erik Kronberg (eakron) on 2009-11-18
Changed in erlang-doc-html (Ubuntu):
status: Fix Committed → Confirmed
Evan Broder (broder) wrote :

The real problem here is the incredibly strong conflicts in the various erlang packages against erlang-doc-html. Since erlang-doc-html isn't part of the set of erlang packages, I really don't think that conflict is correct. I've filed a bug against the Debian package saying as much, and encouraging the maintainer to drop those conflicts, which will keep the problem from reoccurring going forward.

Evan Broder (broder) on 2009-11-29
affects: erlang-doc-html (Debian) → erlang (Debian)
Changed in erlang (Ubuntu):
status: New → Confirmed
Changed in erlang (Debian):
status: Unknown → New
Brian Candler (b-candler) wrote :

Same problem here with Xubuntu 9.10

$ sudo apt-get install erlang-doc-html
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libsctp1 tk unixodbc emacsen-common odbcinst1debian1 lksctp-tools
  erlang-mode
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED
  erlang erlang-appmon erlang-asn1 erlang-base erlang-common-test erlang-corba
  erlang-crypto erlang-debugger erlang-dev erlang-dialyzer erlang-docbuilder
  erlang-edoc erlang-et erlang-eunit erlang-examples erlang-gs erlang-ic
  erlang-inets erlang-inviso erlang-megaco erlang-mnesia erlang-nox
  erlang-observer erlang-odbc erlang-os-mon erlang-parsetools erlang-percept
  erlang-pman erlang-public-key erlang-reltool erlang-runtime-tools
  erlang-snmp erlang-src erlang-ssh erlang-ssl erlang-syntax-tools
  erlang-test-server erlang-toolbar erlang-tools erlang-tv erlang-typer
  erlang-webtool erlang-x11 erlang-xmerl
The following NEW packages will be installed
  erlang-doc-html
0 upgraded, 1 newly installed, 44 to remove and 0 not upgraded.
Need to get 6,182kB of archives.
After this operation, 47.5MB disk space will be freed.
Do you want to continue [Y/n]? n

Fabrice Coutadeur (fabricesp) wrote :

Hi,

The problem is solved in Lucid, as the html documentation and the erlang package have the same version.
Thus closing the bug report.
As it seems that the Debian maintainer won't fix it before having the source package in 3.0 format (the html documentation is creating links to the erlang lib directory *sic*), we will have to live with this recurrent problem...

Fabrice

Changed in erlang-doc-html (Ubuntu):
status: Confirmed → Fix Released
Evan Broder (broder) wrote :

I'm not a huge fan of closing this bug, because we've seen it repeatedly cause problems in releases, and we haven't come up with a mechanism to prevent it from becoming a problem again

Changed in erlang (Debian):
status: New → Fix Released

It is broken in lucid again:

erlang 1:13.b.3-dfsg-2ubuntu2 lucid de.archive.ubuntu.com
erlang-doc-html 1:13.b.2.1-dfsg-2 lucid de.archive.ubuntu.com

tags: added: lucid
Brian Candler (b-candler) wrote :

Still broken in Maverick, although instead of uninstalling the rest of erlang, it simply fails to install.

$ sudo apt-get install erlang-doc-html
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 erlang-crypto : Depends: erlang-base (= 1:13.b.3-dfsg-2ubuntu3) but it is not going to be installed or
                          erlang-base-hipe (= 1:13.b.3-dfsg-2ubuntu3) but it is not going to be installed
E: Broken packages

$ dpkg-query -l | grep -i erlang-base
ii erlang-base 1:13.b.3-dfsg-2ubuntu3 Erlang/OTP virtual machine and base applications
$ dpkg-query -l | grep -i erlang-crypto
ii erlang-crypto 1:13.b.3-dfsg-2ubuntu3 Erlang/OTP cryprographic modules

$ apt-cache show erlang-doc-html
Package: erlang-doc-html
Priority: optional
Section: universe/doc
Installed-Size: 37392
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Debian Erlang Packagers <email address hidden>
Architecture: all
Version: 1:13.b.2.1-dfsg-2build1
Replaces: erlang-doc
Suggests: erlang
Conflicts: erlang-doc
Filename: pool/universe/e/erlang-doc-html/erlang-doc-html_13.b.2.1-dfsg-2build1_all.deb
Size: 6241668
MD5sum: c6a1050430f472db7150fc82f34b345e
SHA1: 7c06ab234f2ecc38f7a70b71abf4950fcc14e5dc
SHA256: 54ed890e26c12b8f50765333cc8479d1d749fdf01eb2dc4a92ff2a92fbb0d4c2
Description: Erlang/OTP HTML documentation
 Documentation for the Erlang programming language and OTP
 library in HTML.
Homepage: http://www.erlang.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"

tags: added: maverick
Clint Byrum (clint-fewbar) wrote :

Closing Jaunty tasks as Won't Fix as it is well past its EOL now.

Changed in erlang (Ubuntu Jaunty):
status: New → Won't Fix
Changed in erlang-doc-html (Ubuntu Jaunty):
status: New → Won't Fix
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in erlang (Ubuntu Karmic):
status: New → Confirmed
Changed in erlang-doc-html (Ubuntu Karmic):
status: New → Confirmed
Changed in erlang-doc-html (Ubuntu Karmic):
status: Confirmed → Invalid
Changed in erlang (Ubuntu):
status: Confirmed → Fix Released
Changed in erlang (Ubuntu Karmic):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.