erlang-base conflicts with old erlang-doc-html

Bug #371581 reported by Evan Broder
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
erlang (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Evan Broder

Bug Description

Binary package hint: erlang-base

erlang-base conflicts with any version of erlang-docs-html older than itself. This is sort of a cute trick for making sure that your docs are up to date, but since erlang-doc-html is a separate source package, it creates the potential for the two packages to get out of sync, making erlang-doc-html uninstallable.

This happened in Jaunty - erlang was synced from Debian after the Debian Import Freeze (bug #331151), but erlang-doc-html wasn't pulled in as well.

I think that ideally I'd like to see erlang-doc-html synced into Jaunty as an SRU. If that's not possible, then the unsatisfiable conflict should be removed from erlang-base.

I'm happy to prepare the diffs for either, but I'd appreciate some input from motu-sru as to which approach they'd prefer.

Revision history for this message
Steve Beattie (sbeattie) wrote :

Confirming this bug, I just hit it as well.

Changed in erlang (Ubuntu):
status: New → Confirmed
Revision history for this message
Manuel Vazquez Acosta (mva-led) wrote :

erlang-base-hipe conflicts with erlang-doc-html but also suggest it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers