Eric segmentation fault

Bug #1161315 reported by Pablo_F
146
This bug affects 32 people
Affects Status Importance Assigned to Milestone
eric (Ubuntu)
High
Unassigned

Bug Description

$ export LANG=C
$ eric
Segmentation fault (core dumped)

strace attached

$ lsb_release -rd
Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04

$ apt-cache policy eric
eric:
  Installed: 4.5.8-1
  Candidate: 4.5.8-1
  Version table:
 *** 4.5.8-1 0
        500 http://ftp.free.org/mirrors/archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: eric 4.5.8-1
ProcVersionSignature: Ubuntu 3.5.0-25.39-generic 3.5.7.4
Uname: Linux 3.5.0-25-generic x86_64
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
Date: Thu Mar 28 11:15:17 2013
InstallationDate: Installed on 2013-02-13 (42 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: eric
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Pablo_F (pablo-fbus) wrote :
Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting this issue and help making Ubuntu better.

It segfaults when I attempt to run it on Ubuntu Raring here as well.

Changed in eric (Ubuntu):
status: New → Confirmed
Revision history for this message
Wegi (cw-wegi) wrote :

Same here on fresh install of 13.04 (/home from old install if this is relevant)

Revision history for this message
Dostulaş ÇAPARALİ (dostulas) wrote :

Beni de etkiliyor.

Revision history for this message
propan0 (propan0) wrote :

Also happening here also, 13.04

Revision history for this message
Funky Future (funky-future) wrote :

i recently installed eric5 manually on my system since i was affected by this bug.
so, i'm thinking about trying to privide a ppa for that. but i wouldn't take the effort if there was someone seriously working on that bug here.
so, is anyone doing so in the foreseeable (not the funky) future?

Revision history for this message
Michael Hug (mrhhug) wrote :

happening here 13.04

Revision history for this message
Mike C. Fletcher (mcfletch) wrote :

I've updated the ubuntu/eric bzr repo with eric 4.5.13 and proposed a merge back into lp:ubuntu/eric

Revision history for this message
Angelo Pantano (ghilteras) wrote :

Mike what do you mean you have updated the ubuntu/eric bzr? updated with what? I dont understand the merge sentence too to be honest.. does it have anything to do with a fix released or a ppa where it does not crashes? If so could you be more exhaustive and provide links on how to update it?

tags: added: saucy
Revision history for this message
Tomas Hlavacek (tmshlvck) wrote :

Angelo, it seems to me that Mike meant his branch lp:~mcfletch/eric/update-to-4.5.13 which is perhaps misplaced in the Eric project instead of Ubuntu package for Eric. I have tested it and it looks OK. Is there any possibility of pulling his work here, review it and merge if possible? (May I help in any way?)

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Since this bug prevents the application or any dependencies from functioning correctly at all, it has an importance of 'high'.

Changed in eric (Ubuntu):
importance: Undecided → High
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Since this bug is:

- Valid.
- Well described.
- Reported in the upstream bug tracker (Launchpad).
- Ready to be worked on by a developer.

it's also triaged.

Changed in eric (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Andrea Agnolin (agno94) wrote :

Happening also on Ubuntu 13.10 (saucy)

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 1161315] Re: Eric segmentation fault

Does it still happen after today's python-qscintilla2 update?

Revision history for this message
Esergion (esergion) wrote :

Yes, it still segfault on my Ubuntu 13.04

Revision history for this message
Jim Patterson (jimp-launchpad-rs9z) wrote :

I've hit this as well, and haven't found a way around it. Running Quantal on amd64. I'm attaching a trace from running python -v eric4.py" which shows it faults after importing Project.ProjectBrowserFlags . My 'strace' output looks pretty similar to what's there, so seems to be same bug.

Revision history for this message
Jim Patterson (jimp-launchpad-rs9z) wrote :

Sorry, I'm not running Quantal, but Saucy (13.10).

Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. I am no longer able to trigger this crash when starting eric 4.5.18-1 on Ubuntu 14.04, thus I believe this issue can be closed as fixed.

 If you need a fix for the bug in previous versions of Ubuntu, please follow the instructions for "Requesting a Backport" at https://wiki.ubuntu.com/UbuntuBackports#Requesting_a_Backport

Changed in eric (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers