bus error when starting adept

Bug #50700 reported by lcampagn on 2006-06-22
2
Affects Status Importance Assigned to Milestone
ept (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: adept

If I click "add/remove programs" from the KDE main menu, I am asked to enter my password and the package manager never starts. When I run adept_installer from the command line, I see "Bus Error" and the program exits. This happens if I run as root, too.

The backtrace looks pretty uninteresting to me:
#0 0x0808a594 in aptFront::exception::OperationCancelled::~OperationCancelled ()
#1 0x0807f6a5 in _init ()
#2 0x082075d7 in tut::test_object<tut::tagcoll_patches_shar>::test<2> ()
#3 0xb694fe51 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#4 0x08083611 in ?? ()

Here is the end of an strace:
open("/usr/lib/libXfixes.so.3", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\340\16"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0644, st_size=13776, ...}) = 0
old_mmap(NULL, 12672, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb68dd000
old_mmap(0xb68e0000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x3000) = 0xb68e0000
close(3) = 0
access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory)
open("/usr/lib/libexpat.so.1", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\260\"\0"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0644, st_size=125168, ...}) = 0
old_mmap(NULL, 124076, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb68be000
old_mmap(0xb68da000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1c000) = 0xb68da000
close(3) = 0
access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory)
open("/usr/lib/libXau.so.6", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\260\t\0"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0644, st_size=7052, ...}) = 0
old_mmap(NULL, 9996, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb68bb000
old_mmap(0xb68bd000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1000) = 0xb68bd000
close(3) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb68ba000
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb68b9000
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb68b8000
set_thread_area({entry_number:-1 -> 6, base_addr:0xb68b86c0, limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) = 0
munmap(0xb7f59000, 52677) = 0
set_tid_address(0xb68b8708) = 19641
rt_sigaction(SIGRTMIN, {0xb6b233b0, [], SA_SIGINFO}, NULL, 8) = 0
rt_sigaction(SIGRT_1, {0xb6b23430, [], SA_RESTART|SA_SIGINFO}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [RTMIN RT_1], NULL, 8) = 0
getrlimit(RLIMIT_STACK, {rlim_cur=8192*1024, rlim_max=RLIM_INFINITY}) = 0
_sysctl({{CTL_KERN, KERN_VERSION, 0, 20d91, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0}, 2, 0xbfd7c91c, 39, (nil), 0}) = 0
brk(0) = 0x82cc000
brk(0x82ed000) = 0x82ed000
futex(0xb6b0dc84, FUTEX_WAKE, 2147483647) = 0

--- SIGBUS (Bus error) @ 0 (0) ---
+++ killed by SIGBUS +++

lcampagn (luke-campagnola) wrote :

Using adept version 2.0ubuntu2

Thank you for your bug report. Do you still have this issue with the latest release of Ubuntu ?

Changed in ept:
importance: Undecided → Medium
status: Unconfirmed → Needs Info
lcampagn (luke-campagnola) wrote :

No, everything looks good now.

Ok thank you, I'm marking this as fixed.

Changed in ept:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers