Epiphany browser theme not respecting Ambiance

Bug #951871 reported by Newfie on 2012-03-10
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
light-themes
Fix Released
Undecided
Unassigned
epiphany-browser (Ubuntu)
Undecided
Unassigned
light-themes (Ubuntu)
Undecided
Unassigned

Bug Description

The icons in Epiphany look extremely wrong and out of place in Ambiance. It needs the Adwaita theme to properly integrate.

See screenshot attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: epiphany-browser 3.3.91-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Sat Mar 10 19:29:12 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120308)
ProcEnviron:
 LANGUAGE=en_CA:en
 TERM=xterm
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: epiphany-browser
UpgradeStatus: No upgrade log present (probably fresh install)

Newfie (mn-newfie) wrote :
Jeremy Bicha (jbicha) wrote :

Newfie, I can confirm this bug. I think this is actually a light-themes bug. For comparison, could you please submit a screenshot of how it looks with Adwaita?

The specific problems I see are that the back & forward buttons should be linked to appear like two halves of the same button. Also the reload/stop button should appear like it's part of the address bar.

Newfie (mn-newfie) wrote :

Yep, screenshot attached. Looks sleek, smooth, and awesome.

The icons and such *do* change and look different between the themes. The backgrounds for the buttons stay white on Ambiance.

Jeremy Bicha (jbicha) wrote :

Hmm, my Epiphany looks a bit better than yours does (the stop/refresh button). I don't know why yours is different.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in epiphany-browser (Ubuntu):
status: New → Confirmed
Changed in light-themes (Ubuntu):
status: New → Confirmed
Newfie (mn-newfie) wrote :

That's odd. Just to make sure it was not related to a weird setting I forgot about, I logged in as a guest. Same issue (screenshot).

I'm fully up to date and running the 64 bit version of Precise.

Andrea Cimitan (cimi) wrote :

Patches welcome :)

Changed in light-themes:
status: New → Confirmed
Changed in epiphany-browser (Ubuntu):
status: Confirmed → Invalid
James Ye (lolz836) wrote :

This is because light-themes is missing CSS stylings for Epiphany, and any GNOME applications since 3.4 that have undergone a redesign or are new, e.g. contacts, boxes, documents, nautilus (>=3.5.3), not just epiphany.
(and I don't know how to use patches)

James Ye (lolz836) wrote :

This has been fixed in Quantal.

Changed in light-themes (Ubuntu):
status: Confirmed → Fix Released
Changed in light-themes:
status: Confirmed → Fix Committed
James Ye (lolz836) wrote :

"Changed in light-themes (Ubuntu):
status: Confirmed → Fix Released"
That should be Fix Committed.

Adolfo Jayme (fitojb) on 2012-08-14
Changed in light-themes:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers