gsettings-data-convert crashed with signal 5 in g_settings_set_value()

Bug #945144 reported by Paul White on 2012-03-02
176
This bug affects 22 people
Affects Status Importance Assigned to Milestone
epiphany-browser (Ubuntu)
Medium
Unassigned

Bug Description

Crash notification after logging into Unity.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gconf2 3.2.3-1ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.94-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Fri Mar 2 21:11:29 2012
ExecutablePath: /usr/bin/gsettings-data-convert
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120223.1)
ProcCmdline: gsettings-data-convert
Signal: 5
SourcePackage: gconf
StacktraceTop:
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 g_settings_set_value () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 g_settings_set () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? ()
Title: gsettings-data-convert crashed with signal 5 in g_settings_set_value()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Paul White (paulw2u) wrote :

This crash has the same stack trace characteristics as bug #916441. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer

StacktraceTop:
 g_settings_schema_get_value (schema=0x860bf40, key=0x86142b8 "homepage-url") at /build/buildd/glib2.0-2.31.18/./gio/gsettingsschema.c:640
 g_settings_schema_key_init (key=0xbfbf3744, schema=0x860bf40, name=0x86142b8 "homepage-url") at /build/buildd/glib2.0-2.31.18/./gio/gsettingsschema.c:751
 g_settings_set_value (settings=0x85fe628, key=0x86142b8 "homepage-url", value=0x860cd78) at /build/buildd/glib2.0-2.31.18/./gio/gsettings.c:1330
 g_settings_set (settings=0x85fe628, key=0x86142b8 "homepage-url", format=0x804a980 "s") at /build/buildd/glib2.0-2.31.18/./gio/gsettings.c:1429
 handle_file (filename=<optimized out>) at gsettings-data-convert.c:199

Changed in gconf (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gconf (Ubuntu):
status: New → Confirmed
visibility: private → public
affects: gconf (Ubuntu) → epiphany-browser (Ubuntu)
Changed in epiphany-browser (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package epiphany-browser - 3.3.90-0ubuntu3

---------------
epiphany-browser (3.3.90-0ubuntu3) precise; urgency=low

  * debian/patches/update_schemas_convert.patch:
    - don't try to convert keys dropped from the schemas (lp: #945144)
 -- Sebastien Bacher <email address hidden> Wed, 07 Mar 2012 00:06:28 +0100

Changed in epiphany-browser (Ubuntu):
status: Fix Committed → Fix Released
tags: added: quantal running-unity
tags: added: apport-request-retrace

Package: gconf2 3.2.5-0ubuntu4
ProcCmdline: gsettings-data-convert --file=/usr/lib/compiz/migration/compiz-profile-active-unity.convert

tags: removed: apport-request-retrace
tags: added: bugpattern-needed
tags: added: raring
tags: added: saucy
tags: added: trusty
tags: added: apport-request-retrace

Package: gconf2 3.2.6-0ubuntu2
ProcCmdline: gsettings-data-convert --file=/usr/lib/compiz/migration/compiz-profile-active-unity.convert

tags: removed: apport-request-retrace
tags: added: utopic
tags: added: artful
tags: added: apport-request-retrace

Package: gconf2 3.2.6-4ubuntu1
ProcCmdline: gsettings-data-convert

tags: removed: apport-request-retrace
tags: added: bionic
To post a comment you must log in.