Ubuntu

Flash doesn't work in WebKitGTK3 browsers

Reported by Tylana on 2011-12-14
124
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Midori
Undecided
Unassigned
epiphany-browser (Fedora)
Unknown
Unknown
epiphany-browser (Ubuntu)
Undecided
Unassigned

Bug Description

Flash works in browsers such as Chrome and Firefox, but not in the WebKitGTK3 browsers such as Epiphany and the GTK3 builds of Midori.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in epiphany-browser (Ubuntu):
status: New → Confirmed
Goyo (goyodiaz) wrote :

Broken also in Ubuntu 12.04 Precise beta 2
epiphany-browser 3.4.0.1-2ubuntu1
flashplugin-installer 11.2.202.228ubuntu1

I tried nspluginwrapper as adviced here:
http://askubuntu.com/questions/64164/flash-player-in-epiphany
But did not work:
user@host:~$ sudo nspluginwrapper -v -i /usr/lib/flashplugin-installer/libflashplayer.so
*** NSPlugin Viewer *** ERROR: /usr/lib/flashplugin-installer/libflashplayer.so: wrong ELF class: ELFCLASS64
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so

Miha Marolt (tloramus) wrote :

I get the exact same error as Goyo. I'm surprised that only two of us reported this, so I wonder if maybe I am doing something wrong.

When I try to watch video on youtube, instead of a player I see a black square with a little blue cube with question marks in the middle.

epiphany-browser 3.4.0.1-2ubuntu1
nspluginwrapper 1.4.4-0ubuntu4
nspluginviewer 1.4.4-0ubuntu4
flashplugin-installer 11.2.202.228ubuntu3

I'm running Gnome-Shell in up to date Ubuntu 12.04.

userdce (userdce) wrote :

still not working in Quantal

Epiphany is GTK3, Flash is GTK2. Because it's not possible to mix GTK2 & GTK3 in the same process, this bug won't be fixed until Epiphany supports out-of-process plugins. That might happen for Epiphany 3.6 or 3.8 (Ubuntu 12.10 or 13.04).

summary: - flash doesn't work in epiphany-browser 3.20
+ Flash doesn't work in epiphany-browser
Changed in epiphany-browser (Ubuntu):
status: Confirmed → Triaged
frizzle21 (frederik-nnaji) wrote :

Jeremy: so is this definitely a wontfix then?
I think that the real problem is with GTK3.
The DECISION not to be flash-compatible is certainly more of a political nature, and i can't say i'm totally opposed to it.

still, it should be noted, incompatibility with flash is a major selling point missed, and bug #1 will have this additional stumbling stone to overcome on it's long path to being fixed.

Jeremy Bicha (jbicha) wrote :

Frederik, the fact that you can't mix GTK2 and GTK3 in the same process has nothing to do with politics or any attempt to discriminate against Flash. It is Adobe's fault alone that they have not bothered releasing a GTK3 version of Flash.

As I said in the previous comment, this bug is being actively worked on and has a decent chance of being fixed within the next year.

This has absolutely nothing to do with bug 1 as Epiphany is not shipped by default.

summary: - Flash doesn't work in epiphany-browser
+ Flash doesn't work in WebKitGTK3 browsers
description: updated
mculumov (mculumov) wrote :

I have the same problem!

Hadi Farnoud (hadi-farnoud) wrote :

what do you mean it wont fix?! do you know how many users affected by this bug?

it must be possible to temporarily fix it. a patch?

Doug McMahon (mc3man) on 2012-10-27
Changed in midori:
status: New → Confirmed
Linuxexperte (andrea-koeth) wrote :

hi together,

I can confirm the same thing here in LinuxMint 13 with web (epiphany-browser). In Firefox and Midori it works,
so: why does it not work in web??

Without a working flash in web, the Ubuntu Gnome-Remix is useless. So I would be glad, if this would be fixed.

Question: does anybody know the reason, why flas his not working in web??

Greetings
Linuxexperte

Anthony Boone (anthonyboone1) wrote :

Answered above, Linuxexperte. Please read the thread before posting questions.

Julian Alarcon (alarconj) wrote :

About this, seem taht GNOME Web (also know as Epiphany) 3.8 switched to WebKit2 and Flash is now working.

This is not a workaround, but a new kind of solution.
http://www.webupd8.org/2013/03/gnome-38-released-see-whats-new-video.html
https://wiki.archlinux.org/index.php/Epiphany

Daniel Fore (danrabbit) wrote :

Marking as Invalid for Midori. This is a problem in WebKitGTK+ and probably won't be solved since it doesn't effect WebKit2

Changed in midori:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.