[[edgy] epiphany freezes with dbus error message

Bug #80424 reported by bapoumba on 2007-01-18
2
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned
epiphany-browser (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

I tried to find duplicates, did not find any related to epiphany.
Please tell me if this is related to :
https://bugs.launchpad.net/ubuntu/+source/xine-ui/+bug/61873
and any debug process I can provide.

Running edgy, with official Ubuntu repositories. Here is the terminal output :
(epiphany:6396): libgnomevfs-WARNING **: Failed to create service browser: Bad state
Applications can not close shared connections. Please fix this in your app. Ignoring close request and continuing.

Epiphany freezes completely, making it useless, have to killall epiphany. Looks like Firefox is running ok.

uname-a :
Linux bapoumba 2.6.17-10-generic #2 SMP Tue Dec 5 22:28:26 UTC 2006 i686 GNU/Linux

Package: epiphany-browser
State: installed
Automatically installed: yes
Version: 2.16.1-0ubuntu2

Package: epiphany-extensions
State: installed
Automatically installed: no
Version: 2.16.1-0ubuntu1

Package: dbus
State: installed
Automatically installed: no
Version: 0.93-0ubuntu3.1

Thanks :)

Diogo Matsubara (matsubara) wrote :

not a malone bug

Changed in malone:
status: Unconfirmed → Rejected
Sebastien Bacher (seb128) wrote :

Thank you for your bug. What did you do to freeze epiphany (what page were you browsing, did you type text on it, what actions did you do, etc)? Could you get a backtrace (https://wiki.ubuntu.com/Backtrace) from that freeze?

Changed in epiphany-browser:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Needs Info
bapoumba (bapoumba) wrote :

Filling that from Firefox ;-)
Please see gdb-epiphany.txt from a terminal in same workspace, right after the freeze. All that worspace got frozen too, including the terminal window, so I am not sure the backtrace is complete. Started gdb from "Already running programs" instructions using epiphany PID.

Could neither run gdb from a tty (guess that was not smart to try) or from another workspace :
~ $ gdb 2>&1 | tee gdb-epiphany3.txt
[gdb blabla here]
(gdb) handle SIG33 pass nostop noprint
Signal Stop Print Pass to program Description
SIG33 No No Yes Real-time event 33
(gdb) set pagination 0
(gdb) attach pid 9963
Illegal process-id: pid 9963.
(gdb) q

killall epiphany did not work. Had to kill -9 9963 (current epiphany PID).

Hope that helps, thank you for your time.

bapoumba (bapoumba) wrote :

Edit : forgot to mention that I was browsing regular web pages (no video etc.), and that liferea and evolution were running too.

Sebastien Bacher (seb128) wrote :

the attachment has no backtrace. Could you reply to the question have what you were doing to get the freeze? Could you get a backtrace when starting epiphany with gdb?:
- gdb epiphany
(gdb) run
... get the hang
<ctrl-C>
(gdb) thread apply all bt

Sebastien Bacher (seb128) wrote :

No reply, bug closed. Feel free to reopen with the asked informations if you still get that problem

Changed in epiphany-browser:
status: Needs Info → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments