epiphany doesn't use gnome's copy & paste protocol

Bug #68093 reported by mon on 2006-10-24
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Epiphany Browser
Expired
Medium
epiphany-browser (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: epiphany-browser

Hi

Here's yet another app that doesn't use gnome's copy and paste protocol. If you open a epiphany window, copy something, close epiphany and try to paste it, voila! There's nothing to paste.

I find quite amusing the default web browser doesn't implement this feature correctly, I would expect it from firefox since it's not a gnome app, but epiphany... anyway, sorry for the rant.

Is there any plan on fixing this on ubuntu or will let gnome as it is and see if other apps are patched to work this way?

Thanks

For the record, here's upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=364845

I would like to know if this is a gnome thing or a gtk thing (and if can be fixed for all apps that use GTK, since I know it also happens in firefox and suspect it will also happen on apps like eclipse, amule, etc.)

just curious

Changed in epiphany-browser:
status: Unknown → Unconfirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug and the upstream pointer. As mentionned upstream that's an app issue, it should use the gtk functions to manage the clipboard

Changed in epiphany-browser:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Changed in epiphany-browser:
importance: Medium → Low
status: Confirmed → Triaged
Changed in epiphany-browser:
importance: Unknown → Medium
Changed in epiphany-browser:
status: New → Expired
Paul White (paulw2u) wrote :

Upstream report showing "RESOLVED OBSOLETE" on 2012-02-10
but with a comment that clipboard contents are available
after quitting Epiphany 3.2.

Checked ok with Epiphany 3.28.1 in Ubuntu 18.04 so closing.

Changed in epiphany-browser (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.