100% CPU usage after a download on AMD64

Bug #66814 reported by LGB [Gábor Lénárt]
2
Affects Status Importance Assigned to Milestone
epiphany-browser (Ubuntu)
Fix Released
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: epiphany-browser

After some time of Epiphany usage, CPU load caused by Epiphany goes to 100%, even if there is only one blank tab is open (ie, I open a new tab and close old ones). It seems the problem occures after at least one file download ("save as" after clicking eg on a tar.gz file). Doing a "strace -p <pid>" shows an endless ioctl(3, FIONREAD, [0]), poll (...) sequence. This is Edgy on AMD64.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for your bug. Could you get a backtrace when it eats CPU. Do you have some simple steps to get the issue?

Changed in epiphany-browser:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Revision history for this message
LGB [Gábor Lénárt] (lgb) wrote :

Unfortunately (this some kind of Murphy on bugs) now I can't find an easy was to reproduce the bug, however downloading various things (mostly eg from gmail.com when mail with attachment arrives and I want to download and save that) does that. I can't exactly know how can I produce backtrace when no fatal signal arrives which would interrupt the running program. So I'm attaching a backtrace now, the first one issues after attaching the running process, the second one after some time (after "continue") when I send a STOP signal to the epiphany process. Hope it helps, if no, please suggest some better method for me.

Revision history for this message
Sebastien Bacher (seb128) wrote :

the backtraces are not really useful, will not be easy to debug with those informations only. Might be a good idea to forward it upstream maybe they will have an idea on it

Revision history for this message
Sebastien Bacher (seb128) wrote :

might be a duplicate of gnome-vfs2 bug #54684 which is fixed to edgy-updates now, do you still have that problem?

Revision history for this message
LGB [Gábor Lénárt] (lgb) wrote :

I will try to trigger the bug again, but it's not easy to reproduce, however after a some hour of daily usage I usually hit this bug, so I'll try to catch it.

Revision history for this message
LGB [Gábor Lénárt] (lgb) wrote :

I haven't managed to trigger this bug again, since then, so maybe you're right about the nature of this bug ... Thanks!

Revision history for this message
Sebastien Bacher (seb128) wrote :

marking fixed then, feel free to reopen if you get the problem again

Changed in epiphany-browser:
importance: Undecided → Low
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments