epiphany-browser segmentation fault with proxy.pac

Bug #577553 reported by 2xyo on 2010-05-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
epiphany-browser (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: epiphany-browser

Hi,

epiphany-browser crashes with the url "*" :

$ gdb epiphany-browser
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/epiphany-browser...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/epiphany-browser
[Thread debugging using libthread_db enabled]
[New Thread 0xb3610b70 (LWP 31598)]
[New Thread 0xb2cefb70 (LWP 31599)]
[New Thread 0xb22ffb70 (LWP 31600)]
[Thread 0xb22ffb70 (LWP 31600) exited]
[New Thread 0xb22ffb70 (LWP 31601)]
[New Thread 0xb0fffb70 (LWP 31613)]
[New Thread 0xb07feb70 (LWP 31614)]
[New Thread 0xafffdb70 (LWP 31615)]
[New Thread 0xaf7fcb70 (LWP 31616)]
[New Thread 0xaeffbb70 (LWP 31617)]
[New Thread 0xae7fab70 (LWP 31618)]
[New Thread 0xadff9b70 (LWP 31619)]
[New Thread 0xad7f8b70 (LWP 31620)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb22ffb70 (LWP 31601)]
0xb657e20b in ?? () from /lib/tls/i686/cmov/libc.so.6
(gdb) backtrace
#0 0xb657e20b in ?? () from /lib/tls/i686/cmov/libc.so.6
#1 0xb2425252 in ?? () from /usr/lib/libproxy/0.3.1/modules/pacrunner_webkit.so
#2 0xb62b9b52 in px_proxy_factory_get_proxies () from /usr/lib/libproxy.so.0
#3 0xb7cc0b61 in ?? () from /usr/lib/libsoup-gnome-2.4.so.1
#4 0xb7cc0db2 in ?? () from /usr/lib/libsoup-gnome-2.4.so.1
#5 0xb7cc1049 in ?? () from /usr/lib/libsoup-gnome-2.4.so.1
#6 0xb6759cec in ?? () from /lib/libglib-2.0.so.0
#7 0xb6757dcf in ?? () from /lib/libglib-2.0.so.0
#8 0xb65c596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#9 0xb6533a0e in clone () from /lib/tls/i686/cmov/libc.so.6

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: epiphany-browser 2.30.2-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sat May 8 20:46:08 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: epiphany-browser

2xyo (2xyo) wrote :
2xyo (2xyo) wrote :

Please replace the title by "epiphany-browser segmentation fault with any url"

Indeed, the browser crashes for any address.
Methodology:
$ Epiphany-browser
-> Enter an address in the address bar
= The browser crashes

Victor Vargas (kamus) wrote :

I tried with "epiphany-browser www.google.com", epiphany-browser """, "epiphany-browser "*"" but all these commands works fine for me with same epiphany release, please could you install epiphany-browser-dbg package and give another examples that are crashing your browser? sorry for asking but I can't reproduce it.

Changed in epiphany-browser (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

I tested with the url ubuntu.com

gdb epiphany-browser
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/epiphany-browser...Reading symbols from
/usr/lib/debug/usr/bin/epiphany-browser...done.
done.
(gdb) run
Starting program: /usr/bin/epiphany-browser
[Thread debugging using libthread_db enabled]
[New Thread 0xb5dddb70 (LWP 3432)]
[New Thread 0xb54b4b70 (LWP 3433)]
[New Thread 0xb4affb70 (LWP 3434)]
[Thread 0xb4affb70 (LWP 3434) exited]
[New Thread 0xb4affb70 (LWP 3435)]
[New Thread 0xb3e3fb70 (LWP 3436)]
[Thread 0xb3e3fb70 (LWP 3436) exited]
[New Thread 0xb3e3fb70 (LWP 3439)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb4affb70 (LWP 3435)]
JSGarbageCollect (ctx=0x1) at ../JavaScriptCore/API/JSBase.cpp:96
96 ../JavaScriptCore/API/JSBase.cpp: Aucun fichier ou dossier de ce type.
 in ../JavaScriptCore/API/JSBase.cpp
(gdb) bt
#0 JSGarbageCollect (ctx=0x1) at ../JavaScriptCore/API/JSBase.cpp:96
#1 0x02b51e97 in ?? () from /usr/lib/libproxy/0.3.1/modules/pacrunner_webkit.so
#2 0x02b52377 in ?? () from /usr/lib/libproxy/0.3.1/modules/pacrunner_webkit.so
#3 0x01e35b52 in px_proxy_factory_get_proxies () from /usr/lib/libproxy.so.0
#4 0x00433b61 in ?? () from /usr/lib/libsoup-gnome-2.4.so.1
#5 0x00433db2 in ?? () from /usr/lib/libsoup-gnome-2.4.so.1
#6 0x00434049 in ?? () from /usr/lib/libsoup-gnome-2.4.so.1
#7 0x0199ed0c in ?? () from /lib/libglib-2.0.so.0
#8 0x0199cdef in ?? () from /lib/libglib-2.0.so.0
#9 0x01b1e96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0x01bffa4e in clone () from /lib/tls/i686/cmov/libc.so.6

But, it works without problems if i disable global proxy configuration
in ubuntu :
->System
-->Preferences
--->Proxy
---->Tick "direct connection to internet"
----> Apply to the system

--
Yohann L.
http://www.2xyo.info

Please rename this bug : "epiphany-browser segmentation fault with proxy.pac"

Launchpad Janitor (janitor) wrote :

[Expired for epiphany-browser (Ubuntu) because there has been no activity for 60 days.]

Changed in epiphany-browser (Ubuntu):
status: Incomplete → Expired

I have here the problem since migration from lucid to natty.
If i switch the gnome-network-preferences from "direct connection" to "automatic proxy configuration" epiphany crashes.
With "direct connection" no problem occurs.

summary: - epiphany-browser segmentation fault with url "*"
+ Please rename this bug : "epiphany-browser segmentation fault with
+ proxy.pac"
Changed in epiphany-browser (Ubuntu):
status: Expired → New
summary: - Please rename this bug : "epiphany-browser segmentation fault with
- proxy.pac"
+ epiphany-browser segmentation fault with proxy.pac
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers