Automatic search from address entry doesn't work anymore

Bug #56610 reported by Emmanuel Pacaud
104
Affects Status Importance Assigned to Milestone
Epiphany
Fix Released
Medium
Mozilla Firefox
Fix Released
Medium
epiphany-browser (Ubuntu)
Low
Ubuntu Desktop Bugs
Edgy
High
Sebastien Bacher
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I'm used to be able to perform a google search by entering keywords directly from the address entry. Since upgrade to firefox 2.0b, it doesn't work anymore. I've go the following error message: "The URL is not valid and cannot be loaded.".

My keyword settings are (about:config):

keyword.URL = http://www.google.fr/search?ie=UTF-8&oe=UTF-8&q=
keyword.enabled = true

With the same settings, it works fine in firefox.

Revision history for this message
In , Bugzilla-mcsmurf (bugzilla-mcsmurf) wrote :

*** Bug 333426 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Jag-mozilla (jag-mozilla) wrote :

*grmbl*

So, shall I just add that flag to all loadURIWithFlags calls, or do we too wanna disable keyword loads for certain cases?

Revision history for this message
In , Neil-httl (neil-httl) wrote :

It would be nice if we had a list of all callers, then we could see how easy it would be to selectively apply the flag.

Revision history for this message
In , Neil-httl (neil-httl) wrote :

*** Bug 340387 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Williamsca (williamsca) wrote :

Does anyone know if there is a workaround to this? This is something I *used* to do all of the time. It's hard to believe more people aren't complaining about this being gone.

Revision history for this message
In , Kairo-kairo (kairo-kairo) wrote :

What does this bug mean?
Without seeing what really is broken or not it's hard to decide if we should hold a release (or even an Alpha) for this...

Revision history for this message
In , Williamsca (williamsca) wrote :

This means that if you have "Enable Internet Keywords" checked in the preferences that it doesn't work anymore. In other words, if I wanted to search for something, I would simply type it into the location bar and hit return and it would automatically do the search based on what I have set for Internet Search in the preferences.

Revision history for this message
In , Kairo-kairo (kairo-kairo) wrote :

Keywords and Internet Search are two different beasts, from what I know, so I'm not sure if you are right.
And if I set a keyword "bug" for %s-based Bugzilla lookup, it works well in a branch build...

Revision history for this message
In , Abwillis1 (abwillis1) wrote :

I believe this is keyword.enabled set to true in about:config is what allowed me to search from the url bar with an enter click. It was a much smarter search system than IE has... IE decides to search for every blasted thing that it can't find which sucks when you just mistype a url. Seamonkey would only search with an enter if there was a space in the url bar (indicating it was not a url) or if the format was keyword:search where search was the word being searched for. As I rarely do a one word search it worked beautifully. I had thought I had just messed up my prefs.js as I had had to specify adding that ability expressly and didn't realize it had been regressed intentionally. I for one would really like to see this as a blocker I am constantly getting an error message that the input was not a valid URL (really even getting rid of the error would be better so I didn't have to acknowledge it before hitting the search button would be OK).

Revision history for this message
In , Kairo-kairo (kairo-kairo) wrote :

So, if I understand you correctly and this is just about the issue that calling up the default search engine by pressing enter in the URL bar for any string we can't handle with other methods, this is something that would really be great to have (I'd love it as well), but we won't block a release for it.

Revision history for this message
In , Williamsca (williamsca) wrote :

That's up to you guys, but from a general user perspective it's a previously released feature with a configuration option that now doesn't work - a regression.

Revision history for this message
In , Chris Thomas (CTho) (cst-yecc) wrote :

Re-request blocking for the beta.

Revision history for this message
In , Chris Thomas (CTho) (cst-yecc) wrote :

Reading the Firefox patch, I suspect we could make the last (new) argument optional, default to false, and that would make the patch a lot smaller.

Revision history for this message
Emmanuel Pacaud (emmanuel-pacaud-deactivatedaccount) wrote :

Hi,

I'm used to be able to perform a google search by entering keywords directly from the address entry. Since upgrade to firefox 2.0b, it doesn't work anymore. I've go the following error message: "The URL is not valid and cannot be loaded.".

My keyword settings are (about:config):

keyword.URL = http://www.google.fr/search?ie=UTF-8&oe=UTF-8&q=
keyword.enabled = true

With the same settings, it works fine in firefox.

Revision history for this message
Mateusz Drożdżyński (matid) wrote :

Thanks for you bug report. Can you reproduce your problem with any string you enter? If otherwise, please list at least one of the troublesome keywords.

Changed in epiphany-browser:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Revision history for this message
Emmanuel Pacaud (emmanuel-pacaud-deactivatedaccount) wrote :

It happens whatever I enter in address entry.

It used to work with one or more word separated with spaces.

Revision history for this message
In , Kairo-kairo (kairo-kairo) wrote :

I'm still not sure what this really is about and how important this is, so putting it on 1.1b radar.

Revision history for this message
In , Aha (aha) wrote :

KaiRo: Firefox has seperated searchbox. SeaMonkey has Location Bar with search capability. This search is now broken. (I'm using 1.0.x releases instead 1.1 nightly because this bug.)

Revision history for this message
In , Abwillis1 (abwillis1) wrote :

Just to keep things from being confused... The search does work if you click the search button. Previously you could type keyword:searchterm and hit enter (or if you were entering 2 or more terms separated by spaces you could drop the keyword: part... not sure what if anything else caused the keyword to be assumed but it wasn't brain dead like i.e. and try to search for mistyped urls). The search does still work but now it requires using the Search button rather than being able to use the enter key. Here is some information on it http://kb.mozillazine.org/Using_keyword_searches

Revision history for this message
In , Kairo-kairo (kairo-kairo) wrote :

That's what confuses me, because I can't remember having that working in 1.0.x - I thought this has been broken since before the SeaMoneky project had been founded.

Revision history for this message
In , Abwillis1 (abwillis1) wrote :

To be honest, I am not sure when it broke... I build from Trunk and don't know the corresponding release information. I had thought I had just borked my prefs.js and thought I was setting it back up wrong at first (the part I thought I was setting up wrong I didn't at first realize wouldn't affect the issue I was seeing... I just remembered I had to make a couple of changes to get it to work as I wanted it to originally).

Revision history for this message
In , Neil-httl (neil-httl) wrote :

Created attachment 234669
fix urlbar

open location dialog sucks, will fix later

Revision history for this message
In , Ajschult (ajschult) wrote :

Comment on attachment 234669
fix urlbar

Patch looks good. I hit bug 349419 with the patch applied, but so does firefox, so I don't think it's our misuse of the API.

Revision history for this message
In , Neil-httl (neil-httl) wrote :

Created attachment 234700
fix open location dialog

requires attachment 234669

Revision history for this message
In , Mnyromyr (mnyromyr) wrote :

While we probably may not want to halt an alpha for this, breaking the "enter search terms in urlbar and hit enter" feature is definitely a 1.1 blocker, imo.

Revision history for this message
In , Ajschult (ajschult) wrote :

Comment on attachment 234700
fix open location dialog

>@@ -63,7 +63,7 @@ function editDocument(aDocument)

as long as you're cleaning things up :) editDocument is never called.

>-function editPage(url, launchWindow, delay)
>+function editPage(url)

xpfe's (and toolkit's!) viewsource has a ViewSourceEditPage method that still passes 3 parameters.

OpenURLDialog in xpfe/components/xremote/src/XRemoteService.cpp also needs updating

Are you yanking the delayed open because it's icky or something directly related to this bug?

Revision history for this message
In , Neil-httl (neil-httl) wrote :

(In reply to comment #23)
>>-function editPage(url, launchWindow, delay)
>>+function editPage(url)
>xpfe's (and toolkit's!) viewsource has a ViewSourceEditPage method that still
>passes 3 parameters.
Fixed locally.

>OpenURLDialog in xpfe/components/xremote/src/XRemoteService.cpp also needs
>updating
That sucks. How much do you want to keep OpenURLDialog? It got overlooked when I implemented openurl for suiterunner.

>Are you yanking the delayed open because it's icky or something directly
>related to this bug?
Because it's icky, and I don't really want to have to touch all the functions that it uses to make them keyword-enabled.

Revision history for this message
In , Chris Thomas (CTho) (cst-yecc) wrote :

Comment on attachment 234669
fix urlbar

Diffing from xpfe/ has the wonderful result of making the Index: line look like a Firefox patch.

Revision history for this message
In , Neil-httl (neil-httl) wrote :

Created attachment 234992
addressed review comments

Revision history for this message
In , Ajschult (ajschult) wrote :

Comment on attachment 234992
addressed review comments

patch: **** malformed patch at line 146: Index: suite/common/openLocation.js

@@ -146,17 +129,12 @@ function editPage(url, launchWindow, del
should be
@@ -146,12 +129,7 @@ function editPage(url, launchWindow, del
?

>+++ xpfe/browser/resources/content/navigator.js 20 Aug 2006 20:35:33 -0000
>+ openDialog("chrome://communicator/content/openLocation.xul", "_blank", "chrome,modal,titlebar", params);
>+ var url = getShortcutOrURI(params.url);

getShortcutOrURI doesn't like null, so this needs to bail early if the user cancels the dialog.

Revision history for this message
In , Neil-httl (neil-httl) wrote :

(In reply to comment #27)
>(From update of attachment 234992)
>patch: **** malformed patch at line 146: Index: suite/common/openLocation.js
>@@ -146,17 +129,12 @@ function editPage(url, launchWindow, del
>should be
>@@ -146,12 +129,7 @@ function editPage(url, launchWindow, del
>?
You should have seen the patch before I cut out all my other junk...

>>+++ xpfe/browser/resources/content/navigator.js 20 Aug 2006 20:35:33 -0000
>>+ openDialog("chrome://communicator/content/openLocation.xul", "_blank", "chrome,modal,titlebar", params);
>>+ var url = getShortcutOrURI(params.url);
>getShortcutOrURI doesn't like null, so this needs to bail early if the user
>cancels the dialog.
I'll make it default to "" instead.

Revision history for this message
In , Neil-httl (neil-httl) wrote :

Created attachment 235062
fixed patch

Revision history for this message
In , Neil-httl (neil-httl) wrote :

(In reply to comment #27)
>@@ -146,17 +129,12 @@ function editPage(url, launchWindow, del
>should be
>@@ -146,12 +129,7 @@ function editPage(url, launchWindow, del
Doh, I corrected the 12 to 7 but forgot to correct the 17 to 12 :-[

Revision history for this message
In , Neil-httl (neil-httl) wrote :

Fix checked in.

If anyone wants internet keywords to work anywhere else, please explain your reasoning before reopening this bug, thanks.

Revision history for this message
Jorge Castro (jorge) wrote :

Confirming on 2.15.91-0ubuntu1

Changed in epiphany-browser:
status: Needs Info → Confirmed
Revision history for this message
Daniel Holbach (dholbach) wrote :

The bug is known upstream as http://bugzilla.gnome.org/show_bug.cgi?id=350053 already.

Changed in epiphany-browser:
importance: Untriaged → Low
Revision history for this message
Daniel Holbach (dholbach) wrote :

Seems we'd need to patch firefox with this: https://bugzilla.mozilla.org/attachment.cgi?id=235062&action=view - anybody cares enough to test?

Changed in epiphany:
status: Unknown → Confirmed
Changed in firefox:
status: Unknown → Fix Released
Revision history for this message
In , Neil-httl (neil-httl) wrote :

Fixed on 1.8 branch 2 days ago but I forgot to update the keywords.

Revision history for this message
Nathaniel McCallum (nmccallum) wrote :

Attached is the patch on mozilla.org bug #235062 reworked to apply against the firefox in edgy. Keywords work in firefox, but not in epiphany. I recompiled epiphany with the new firefox-dev and it still didn't change anything.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Um... that was not mozilla bug235062, but attachment 235062 - I hope you picked the right one.

Revision history for this message
Nathaniel McCallum (nmccallum) wrote :

Err... yes attachment 235062... sorry for the confusion

Revision history for this message
Daniel Holbach (dholbach) wrote :

That's most unfortunate the patch doesn't fix the problem completely. :-/

Revision history for this message
Dana Olson (adolson) wrote :

Will this be fixed in Epiphany before Edgy is finalized? I know that some people don't like Epiphany, but there are also people who prefer it, and this feature seems to still be broken in Epiphany.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Dana, if there is a patch available we will use it. According to the current comment on the upstream epiphany bug some epiphany changes would be required

Revision history for this message
lexual (lexhider) wrote :

Appears to be upstream patch now, either applied or pending.

Revision history for this message
lexual (lexhider) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

fixed upstream, we might backport the fix to edgy-updates later

Changed in epiphany-browser:
status: Confirmed → Fix Committed
Revision history for this message
Gabriel Bauman (gabrielbauman) wrote :

The sooner, the better. This annoyance can't be understated. Matt Good did a patch against 2.16.1 here:

https://launchpad.net/distros/ubuntu/+source/epiphany-browser/+bug/60691/comments/5

Works for me.

Revision history for this message
Sebastien Bacher (seb128) wrote :

due to a firefox change but not a firefox bug

Changed in firefox:
status: Unconfirmed → Rejected
assignee: nobody → seb128
importance: Undecided → High
status: Unconfirmed → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

I'll look at backporting the fix to edgy

Revision history for this message
Michael Hofmann (mh21) wrote :

Debified backport for edgy can be found at http://mh21.de/epiphany/.

Revision history for this message
Sebastien Bacher (seb128) wrote :

This upload fixes the issue:

 epiphany-browser (2.17.2-0ubuntu1) feisty; urgency=low
 .
   * New upstream version:
     - fix keyword search (Ubuntu: #56610)
   * debian/control.in:
     - Build-Depends on libenchant-dev
   * debian/patches/02_ac_init.patch:
     - updated
   * debian/patches/04_spell_check_pref.patch:
     - dropped, the new package is built with the spell checker option
   * debian/patches/08_localized_startup_page.patch:
     - updated
   * debian/patches/99_configure.patch:
     - updated
   * debian/rules:
     - use --enable-spell-checker

Changed in epiphany-browser:
status: Fix Committed → Fix Released
Revision history for this message
Jeff Fortin Tam (kiddo) wrote :

Wait! Could you be kind enough to package it as a edgy-updates (like you proposed in an earlier comment)?

This bug really irritates the hell out of me and I was expecting a patch for edgy :| I don't want to update to feisty for such a small bug (pretty much.. the only issue I have with edgy), but that small bug is annoying me (and I think, a lot of other users) daily. I even resorted to using deskbar-applet, but it's a band-aid instead of a solution.

Thanks!

Revision history for this message
Matt Good (launchpad-matt-good) wrote :

I agree that this is an important bug that should be fixed in Edgy. The fix will be included in Epiphany 2.16.2, but it's easy to add the patch to the current package, so I hope Edgy will get the patch sooner rather than later. I've already rebuilt my Epiphany with it, so if others want to do the same:

sudo apt-get build-dep epiphany-browser
apt-get source epiphany-browser
cd epiphany-browser-2.16.1/debian/patches
wget http://librarian.launchpad.net/4938616/09_get_keyword_search_back.patch
cd ../..
dpkg-buildpackage -rfakeroot
sudo dpkg -i ../epiphany-browser*.deb

Changed in epiphany:
status: Confirmed → Fix Released
Revision history for this message
In , Trev-moz (trev-moz) wrote :

Removing delayedOpenTab will probably break lots of extensions. Actually, there is even one occasion where SeaMonkey itself still tries to use this function - gTabOpenObserver.observe() in navigator.js. This should be fixed.

Revision history for this message
diegoe (diegoe-deactivatedaccount-deactivatedaccount) wrote : Diff for packaging epiphany 2.16.2

Since there's a new upstream version from a while now, I produced this .diff.gz so the package can be updated.
It's my first try at doing this kind of contributions so no problem if you reject it or mark as needs work or whatever :).

Greetings!

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for the work on that dieguito. We don't upload new version to a stable usually, rather backport changes to the version already shipped, the diff is not really useful then. Did you work on that update only for that fix?

Revision history for this message
diegoe (diegoe-deactivatedaccount-deactivatedaccount) wrote :

Well yes :).

I can get a diff for .1, let me generate one.

Revision history for this message
diegoe (diegoe-deactivatedaccount-deactivatedaccount) wrote :

There.

Revision history for this message
Sebastien Bacher (seb128) wrote :

dieguito, that patch has some other changes for printing, I've used the version from bugzilla to prepare the update

Revision history for this message
Sebastien Bacher (seb128) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

Corresponding changelog entry:

 epiphany-browser (2.16.1-0ubuntu3) edgy-proposed; urgency=low
 .
   * debian/patches/90_from_upstream_fix_keyword_search_from_location_bar.patch:
     - change from upstream, fix keyword search from the location bar,
       thank to Nathaniel McCallum, Matt Good, dieguito for trying the
       upstream change and sending patches for the package (Ubuntu: #56610)

Revision history for this message
Sebastien Bacher (seb128) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

Note that the change has got some good testing on feisty already

Revision history for this message
Jeff Fortin Tam (kiddo) wrote :

I can't wait for this to hit the backports, as I don't have the skill to fix that for myself, what's the status here?

Revision history for this message
Luis Carlos Cobo (luiscarlos) wrote :

If you do not want to wait for the fix to reach backports, you can grab the package from here: http://diego.aureal.com.pe/archives/2006/11/30/epiphany-patched-packages-edgy/ (download the first deb and install it with dpkg -i package.deb). Guess that deb has been built by the same Diego posting the diff here.

Revision history for this message
diegoe (diegoe-deactivatedaccount-deactivatedaccount) wrote :

Omg I'm being followed!

Yes, those are debs with some patches from the current 2.17 version. I built it not so long ago.

The most noticeable changes are there, so if you use it you will be very close to the actual 2.17.

Some other great changes are available in 2.17 so if you can or want, you are welcome to try it :).

Revision history for this message
Jeff Fortin Tam (kiddo) wrote :

Thanks a lot folks! I am finally able to gallop happily on the net, and that will allow me to keep my sanity in the meantime that this is fully backported ;)

Revision history for this message
Martin Pitt (pitti) wrote :

The patch is realy ugly and unverifyable by eye-balling, but approving on the basis of extensive testing, upstream approval (for 2.16.2) and acceptance in other distros. Please upload.

Revision history for this message
Sebastien Bacher (seb128) wrote :

uploaded to edgy-proposed now

Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into edgy-updates, please go ahead with QA testing.

Changed in epiphany-browser:
status: Confirmed → Fix Committed
Revision history for this message
desrt (desrt) wrote :

superficially, it works.

Revision history for this message
Michael Vogt (mvo) wrote :

I verified this by:

1. installing epiphany-browser from edgy
2. checking that entering some keywords in the adressbar does *not* do a google search
3. install the version from edgy-proposed
4. entering some keyword will result in a google search

I mark this verification-done

Revision history for this message
Sebastien Bacher (seb128) wrote :

upload to edgy-updates now

Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into edgy-updates.

Changed in epiphany-browser:
status: Fix Committed → Fix Released
Revision history for this message
In , Benc-meer (benc-meer) wrote :

V/fixed.
Seamonkey 1.1.2, macosx10.4.

Changed in epiphany:
importance: Unknown → Medium
Changed in firefox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.