epiphany-browser assert failure: epiphany-browser: /build/buildd/nspluginwrapper-1.2.2/src/npw-rpc.c:1225: do_recv_NPObject: Assertion `npobj != ((void *)0)' failed.

Bug #448234 reported by Graham Davies on 2009-10-10
70
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Epiphany Browser
Expired
Critical
adobe-flashplugin (Ubuntu)
Medium
Unassigned
epiphany-browser (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: epiphany-browser

Epiphany crashed while changing toolbar settings

ProblemType: Crash
Architecture: amd64
AssertionMessage: epiphany-browser: /build/buildd/nspluginwrapper-1.2.2/src/npw-rpc.c:1225: do_recv_NPObject: Assertion `npobj != ((void *)0)' failed.
Date: Sat Oct 10 20:54:34 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/epiphany-browser
NonfreeKernelModules: nvidia
Package: epiphany-browser 2.28.0-4ubuntu1
ProcCmdline: epiphany-browser
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.43-generic
Signal: 6
SourcePackage: epiphany-browser
StacktraceTop:
 raise () from /lib/libc.so.6
 abort () from /lib/libc.so.6
 __assert_fail () from /lib/libc.so.6
 ?? ()
 ?? ()
Title: epiphany-browser assert failure: epiphany-browser: /build/buildd/nspluginwrapper-1.2.2/src/npw-rpc.c:1225: do_recv_NPObject: Assertion `npobj != ((void *)0)' failed.
Uname: Linux 2.6.31-13-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Graham Davies (gradavies53) wrote :

StacktraceTop:*__GI_raise (sig=<value optimized out>)
*__GI_abort () at abort.c:92
*__GI___assert_fail (
?? ()
?? ()

Changed in epiphany-browser (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
affects: epiphany-browser (Ubuntu) → adobe-flashplugin (Ubuntu)
visibility: private → public
P. Cobb (pcobb) wrote :

Flash is messed up in Epiphany and Firefox as well. I'm wondering-if I replace flash will it solve the problem--also which flash to use. It would be useful if a workaround was published.

Milan Bouchet-Valat (nalimilan) wrote :

Adding a task for Epiphany, as on my box (bug 617030) the crash doesn't occur in Firefox.

Changed in epiphany-browser (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in adobe-flashplugin (Ubuntu):
status: New → Triaged
Changed in epiphany-browser:
status: Unknown → New
Changed in epiphany-browser:
importance: Unknown → Critical
Robin Roth (robinro) wrote :

Got the same bug on my machine with epiphany (but not firefox). This showed up only recently, but it might be it's because I usually don't use flash websites. See crash log attached.

Using epiphany 2.30.2 on ubuntu maverick

Changed in epiphany-browser:
status: New → Expired
Robin Roth (robinro) wrote :

still not fixed, is it?
Even if it's some kind of annoying flash-issue, there should be at least some kind of more specific error message and epiphany should not crash at all.

Milan Bouchet-Valat (nalimilan) wrote :

I think you should try installing the new 64-bit Flash 11, that will probably solve the issue. Anyway, upstream doesn't support 2.30 now (we're at 3.2), so they're probably not going to fix it now...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.