Ubuntu

new upstream 2.22.2 release

Reported by Alexander Sack on 2008-05-30
12
Affects Status Importance Assigned to Milestone
epiphany-browser (Ubuntu)
Undecided
Alexander Sack
Hardy
Undecided
Unassigned
Intrepid
Undecided
Alexander Sack

Bug Description

Binary package hint: epiphany-browser

New upstream release:

  http://ftp.acc.umu.se/pub/GNOME/sources/epiphany/2.22/epiphany-2.22.2.changes

Alexander Sack (asac) wrote :

uploaded to hardy-proposed

Changed in epiphany-browser:
status: New → In Progress
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Rafał Próchniak (burlap) wrote :

1. Files are not downloaded and open automatically, ignoring appropriate setting in preferences (see also https://bugs.launchpad.net/ubuntu/+source/epiphany-browser/+bug/201192).

2. It's impossible to delete passwords.

I'm sorry if it's a wrong place to report this (I'm using epiphany 2.22.2 from hardy-proposed though), I can submit proper bug reports if necessary.

Sebastien Bacher (seb128) wrote :

are those regression due to this upload? that doesn't seem to be the case, especially than the download bug has been opened a while ago

Rafał Próchniak (burlap) wrote :

#1 Epiphany 2.22.1.1 automatically downloads files but doesn't open any helper apps. In 2.22.2 it ignores the setting and always prompts to save or open.
#2 Deleting passwords works fine in 2.22.1.1, so this looks like a regression.

Alexander Sack (asac) wrote :

Rafal,

I couldn't reproduce your issues.

ad #1. could you please give some example URLs?

ad #2. I can add and remove passwords. Those changes persist after restart.

Do you have any epiphany extensions enabled?

Alexander Sack (asac) wrote :

ok, one fix for password issue (which appears to only happen for HTTP hosts) is to revert upstream changes (2.22.1.1 vs. 2.22.2) for password code. attached the patch that will probably go up.

Alexander Sack (asac) wrote :

after looking a bit closer, i found that upstream introduced some typos. still need to test, but i guess that this fixes the password code too.

Alexander Sack (asac) wrote :

confirmed. the 98b_fix_remove_password_2.22.2.patch above fixes password. i could add/remove HTTP and Form passwords.

Tomorrow Ill look at the download issue. Please give more details, like URLs to test, expected behaviour, actual behaviour. thanks

Alexander Sack (asac) wrote :

This patch should bring back expected behaviour for auto-download:

With auto-download enabled:
1. if helper app is found, automatically open with that one (without prompt)
2. otherwise save to Download dir without prompt

Alexander Sack (asac) wrote :

ok, i uploaded epiphany-browser_2.22.2-0ubuntu0.8.04.2~mt3_source.changes to mozillateam ppa. Please test from there. Ack if this is the expected behaviour for you. Mozillateam ppa is:

   https://edge.launchpad.net/~mozillateam/+archive

Alexander Sack (asac) wrote :

uploaded both fixes as 2.22.2-0ubuntu0.8.04.2 to hardy-proposed

Alexander Sack (asac) wrote :

oh, forgot to remove the initial fix for the password thing. Attached the cleaned up debdiff, which was reuploaded

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Rafał Próchniak (burlap) wrote :

#1 - Now it respects the setting (whether to prompt or to download/open) and it opens files, but if they are open, they don't get downloaded into the directory set in preferences, they go into /tmp instead.

Just some random URLs:
http://www.pdf-tools.com/public/downloads/whitepapers/whitepaper-pdfprimer.pdf
http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.22/epiphany-2.22.0.tar.bz2

I would expect it to work as it did in 2.20.x and before: to automatically "download AND open files": if proper helper app is found, the file is both open and saved in the directory set in the preferences.

All files without helper apps (like Mac OS version here: http://www.mozilla.com/en-US/firefox/all.html) just prompted to save file as, couldn't find any case where file is automatically downloaded without prompt or being open (there was either prompt, file chooser without prompt or warning that files are dangerous).

#2 - Deleting passwords works fine.

I have several extensions enabled (I disabled all of them to test #1, didn't change anything).

Alexander Sack (asac) wrote :

i agree that#1 might be improvable, but imo not in the realm of this SRU update. Please open a new bug where we can track that feature for the future.

Alexander Sack (asac) wrote :

fwiw, the file is downloaded without write permission. so you dont really risk to loose edited content as long as the editor app properly deals with files it cannot write to. The problem about downloading every auto-opened file to a persistent location is that this will clutter that directory with files the users just wanted to look at. Would be somewhat similar to downloading every .html file to that directory (not a fair comparison, I know ... but you get the idea).

asac@tinya:/tmp/mozilla-devscripts.hardy$ ls -l /tmp/whi*.pdf
-r-------- 1 asac asac 171868 Jun 5 11:28 /tmp/whitepaper-pdfprimer.pdf

Sebastien Bacher (seb128) wrote :

confirming that the update fix the autodownloading but use the wrong directory and allow to remove passwords again

Alexander Sack (asac) wrote :

(so epiphany really wants to put files that are only viewed as part of a normal browsing workflow in a persistent directory aka Download? That doesnt sound reasonable for me as it will accumulate a lot of garbage over time.)

Anyway, back on topic: is this good enough to not fail verification? for me it sounds like an overall improvement ...

2.22.1.1:
#1 Epiphany 2.22.1.1 automatically downloads files but doesn't open any helper apps.

in 2.22.2:
1. autodownload works (right directory?)
2. auto open with helper application works (we use a different directory than in 2.20 in gutsy)

let me know if there is work required now or after the SRU?

Rafał Próchniak (burlap) wrote :

I agree this is an improvement over 2.22.1.1, but storing all files with autodownload was default behavior since I've been using epiphany (2.12 I guess) and it was actually a killer feature for me...

For "downloading" all html files - I can have beagle doing something like that, but storing everything else I viewed once is just the only way to have complete history/index of browsing. Storage is not a big issue anymore - my download folder holds 1.6GB of files, although I cleaned it some time ago.

This is not my decision, whether it should be improved before SRU or not. If not, I'm sure I'll file a bug on it.

Sebastien Bacher (seb128) wrote :

the download location specified in the preference dialog was used for download when you have the "automatically download and open" option, the idea seems to avoid users who download things to use them directly to have extra steps to store or open those, users who want to either download or just view what they download usually don't use this option, they get the dialog which ask if you want to download or open the file and select the option they need

anyway we discussed the update on IRC this week and epiphany-browser is far to be perfect in hardy already and we don't think the update is a priority or broken enough to stop the xulrunner transition to hardy-updates, thanks for you work on that Alexander, I think you have other priorities that fix that at the moment, would still be nice to get that fixed in some update later though

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in epiphany-browser:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Hardy and intrepid versions differ, so I can't copy the SRU to intrepid. Please upload to Intrepid ASAP.

Changed in epiphany-browser:
milestone: none → intrepid-alpha-2
Steve Langasek (vorlon) on 2008-07-10
Changed in epiphany-browser:
assignee: nobody → asac
milestone: intrepid-alpha-2 → intrepid-alpha-3
Steve Langasek (vorlon) wrote :

new upstream release present in intrepid.

Changed in epiphany-browser:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers