Epiphany prints blank pages

Bug #217151 reported by krizz on 2008-04-14
16
Affects Status Importance Assigned to Milestone
Epiphany Browser
Fix Released
High
epiphany-browser (Ubuntu)
Medium
Unassigned
Hardy
Low
Unassigned

Bug Description

In Ubuntu Hardy Beta, when trying to print a page I get blank pages. Only epiphany's headers and footers are printed and the other page if blank. Tryed on PDF and Canon printer.epiphany-browser:

  Installed: 2.22.1.1-0ubuntu1
  Candidate: 2.22.1.1-0ubuntu1
  Version table:
 *** 2.22.1.1-0ubuntu1 0
        500 http://gr.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Guido Conaldi (guido-conaldi) wrote :

I can confirm the same behaviour on ubuntu 8.04 64bit

krizz (krizz) wrote :

I think the page content are present on the left upper corner of the page, but are extremely tiny.

Check the attachment.

toobuntu (toobuntu) wrote :

Happens to me, too, on fully up to date Hardy. Many web pages print blank in epiphany browser.

Changed in epiphany-browser:
status: New → Confirmed
krizz (krizz) wrote :

My Hardy, comes from upgrade of Feisty. Tried in fresh Hardy install and seems to work ok.

Maybe it's an upgrade issue?

Bengt Olsson (bengt-blafs) wrote :

Confirming this bug. Similar printout as above with only header and footer printed. Using
"HP LaserJet 4050 Series Postscript (recommended)" driver.

Bengt Olsson (bengt-blafs) wrote :

Was a little bit hasty. Indeed it seems like the printout is there but with very tiny fonts, just like krizz says, see attachment. On my work laptop it happens all the time, om my home desktop it mostly happens, but it may start out with printing alright.

Bengt Olsson (bengt-blafs) wrote :

Yet some more soul-seeking... it seems that the problem for me (and possibly at least krizz) is that my "Scale" option in the "Print..." > "Page Setup" dialog was set to 1.0 % instead of 100%. This made all the difference... Don't know why it is like that, I can't remember ever having changed that, maybe Scale had another scale before... Anyway this problem is solved for me now anyway.

Cheers! :)

Bengt Olsson (bengt-blafs) wrote :

Was to early again... The problem persists but what happens is that the "Scale" parameter changes itself to 1 (%) even though the Epiphany session starts out with 100 (%). Typically when the browser is started and you do the first printout, "scale" is set to 100%. However, at the next print attempt the "scale" parameter has changed itself to 1%.

The obvious workaround is to manually reset the "scale" parameter to 100% every time you print something. This is tedious however.

krizz (krizz) wrote :

Thanks Bengt! That worked pretty well for me. After changing the scale and sending a print, the value was saved and everything works ok now.
Maybe u could try find and change "scale" value in about:config or gconf and change it there. In my case though the value is kept 100% after the first print.

Stephen Irons (stephen-irons) wrote :

The workaround (changing scale to 100%) works for me -- almost permanently.

If I select 'File > Print Preview', the preview looks good. However, selecting 'File > Print' after that, the scale has changed back to 1%.

Changing 'File > Page Setup' does not affect the scale.

It seems as though 'File > Print Preview' changes the scale from 100% to 1%.

The value is stored in .gnome2/epiphany/print-settings.ini

[Print Settings]
scale=100

gets changed to
scale=1

Perhaps print preview writes a value in the range 0..1 where it should be writing the value 0..100%?

Bengt Olsson (bengt-blafs) wrote :

Nice fault correlation Stephen! I also see now that it is after a "Print Preview" the scale is changed 100% -> 1%. This is probable sufficient input for the devs to squash the bug...

Paul Drain (pd) wrote :

I think i've found the fix for this, looking through the Epiphany code, specifically the embed/mozilla/GeckoPrintService.cpp file, there's a line (around 737-739) that reads:

" gtk_print_settings_set_scale (aGtkSettings, 1.0); "

But the GNOME Library Documentation states:

" scale : the scale in percent "

So, the solution turned out to be changing:

    gtk_print_settings_set_scale (aGtkSettings, 1.0);

To:

    gtk_print_settings_set_scale (aGtkSettings, 99.0);

(Or, whatever size you actually want to scale at)

Changed in epiphany-browser:
importance: Undecided → Medium
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

the code change seems to be correct but having a way to trigger the bug on a new installation to try the change would be nice, the scaling is correct on my hardy installation using an existant configuration or not, could be locale dependant or something, could you describe the locale you are using and easy steps to trigger the bug?

Paul Drain (pd) wrote :

Sure, all of the boxes affected were installed off the alternative x86 CD, as fresh installs with updates to June 26th 2008 and en_AU as the locale, having selected Melbourne or Hobart, Australia as the region at install time.

Happens on a variety of printers, including Brother, HP and Lexmarks.

As for steps:

* Install Ubuntu
* Install epiphany-browser and epiphany-extensions
* Setup Printer in System/Administration/Printing
* Attempt to print a webpage, or any other content via Epiphany

We left Firefox installed, but removed the menu items in preference for Epiphany, so there's no $HOME/.mozilla directory on any of the installations, if that makes a difference.

Paul Drain (pd) wrote :

The patch (minus the comment) has been committed to the gnome-2-22 branch of Epiphany too.

Sebastien Bacher (seb128) wrote :
Changed in epiphany-browser:
importance: Undecided → Low
status: New → Confirmed
Changed in epiphany-browser:
status: Unknown → Fix Released
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in epiphany-browser:
status: Confirmed → Fix Committed
Paul Drain (pd) wrote :

With the version from -proposed it works as expected now on a fresh installation of 8.04.1, the scaling is 100% in the CUPS dialogue and in Epiphany and pages print correctly.

Sebastien Bacher (seb128) wrote :

a new rebuild revision has been uploaded now to some libglib issues, would be nice to give testing to this one too

Bengt Olsson (bengt-blafs) wrote :

Run it for two days now, problem resolved, seems to be working fine, and no regressions I'm aware of.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in epiphany-browser:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

there is a newer version in intrepid

Changed in epiphany-browser:
status: Triaged → Fix Released
Changed in epiphany-browser:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.