[SRU] Update epiphany-broswer to 3.28.6 in Bionic

Bug #1845396 reported by Amr Ibrahim
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
epiphany-browser (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

Version 3.28.6 fixes some bugs that are nice to have in Bionic. Some fixes have to do with newer versions of WebkitGTK. So this update is beneficial since WebkitGTK is updated in Bionic.
Summary of the changes on
https://gitlab.gnome.org/GNOME/epiphany/blob/gnome-3-28/NEWS

3.28.6 - September 7, 2019
==========================

- Fix certain page loads not entering history since WebKitGTK 2.24.1
- Fix overview page snapshots sometimes not being updated since WebKitGTK 2.24.1
- Fix floating status bar sometimes displaying wrong loading URL since WebKitGTK 2.24.1
- Fix memory corruption and broken web process extension connection when using WebKit trunk
- Fix crash when loading URLs in new web views (#590)
- Fix crash when syncing bookmarks (#612)
- Fix criticals when deleting pages from history (#691)
- Fix crash when safe browsing database is recreated (#736)
- Fix crash in downloads code
- Fix web apps not being deleted properly
- Fix Firefox Sync web context using global (non-Epiphany) data storage
- Fix bookmarks allowing empty tags (Aral Balkan)
- Fix Google search in Russian localization (Alexandr Sidorenko)

[Test case]

- Run GNOME Web as usual and browse to different websites
- Play videos on YouTube

[Regression potential]

Regression potential is low since this is a bug-fix release as part of GNOME micro-releases, which cherry-pick only fixes to the stable 3.28 branch.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: epiphany-browser 3.28.5-0ubuntu1
ProcVersionSignature: Ubuntu 5.0.0-29.31~18.04.1-generic 5.0.21
Uname: Linux 5.0.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
CurrentDesktop: communitheme:ubuntu:GNOME
Date: Wed Sep 25 23:37:43 2019
InstallationDate: Installed on 2018-11-29 (300 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
SourcePackage: epiphany-browser
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :
Jeremy Bicha (jbicha)
tags: added: upgrade-software-version
removed: third-party-packages
Revision history for this message
Sebastien Bacher (seb128) wrote :

The new version is in new series, marking as fixed for the current one and doing the bionic SRU

Changed in epiphany-browser (Ubuntu):
importance: Undecided → High
status: New → Fix Released
Revision history for this message
Timo Aaltonen (tjaalton) wrote : Please test proposed package

Hello Amr, or anyone else affected,

Accepted epiphany-browser into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/epiphany-browser/3.28.6-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in epiphany-browser (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (epiphany-browser/3.28.6-0ubuntu1)

All autopkgtests for the newly accepted epiphany-browser (3.28.6-0ubuntu1) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

libomxil-bellagio/0.9.3-4 (ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#epiphany-browser

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

I have been testing 3.28.6-0ubuntu1 from bionic-proposed and it's working well. I've tested Launchpad, LinkedIn, Gmail, Google Calendar, Trello, Outlook and others. Firefox Sync works well too.

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Thank you for the verification! Did you by any chance also try playing videos on youtube using the latest -proposed version?

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

Videos on YouTube work to a certain degree, some videos just start and cannot seek, and some don't play at all. However, playing videos (all websites) in Epiphany has not been the greatest experience even before this update. So I don't think this is actually a regression.

Actually the upstream changelog mentions that videos on YouTube are not 100% reliable:
3.28.5 - September 21, 2018
===========================

This release is intended to fix video playback on YouTube. We believe that
YouTube began requiring media source extensions to play WebM videos on Tuesday
of this week, so we have enabled it.

You are strongly encouraged to update to WebKitGTK+ 2.22.2 and the forthcoming
GStreamer 1.14.4 to minimize video playback disruptions. It's not really
reliable enough to be enabled yet, but it's a whole lot better than no YouTube.

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

And I have also tested videos on YouTube and Dailymotion using the WebKitGTK MiniBrowser just to make sure that Epiphany is not regressing.

The experience of playing videos is equally broken. Here is how to start the MiniBrowser from the terminal:
$ /usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/MiniBrowser

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package epiphany-browser - 3.28.6-0ubuntu1

---------------
epiphany-browser (3.28.6-0ubuntu1) bionic; urgency=medium

  * New bugfix version (lp: #1845396)

 -- Sebastien Bacher <email address hidden> Tue, 05 Nov 2019 17:00:03 +0100

Changed in epiphany-browser (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for epiphany-browser has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers