Personal data manager doesn't display any password information

Bug #180205 reported by Senor Hubris on 2008-01-03
14
Affects Status Importance Assigned to Milestone
Epiphany
Won't Fix
High
epiphany-browser (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Hardy by Michael Gratton

Bug Description

Binary package hint: epiphany-browser

Epiphany's personal data manager does not display any information about stored passwords (when you click on the 'Passwords' tab you get an empty window). The files signon.txt and signon2.txt exist in the $HOME/.gnome2/epiphany/mozilla/epiphany directory. I believe these are the files that xulrunner and/or firefox use for storing this personal information. An 'strace -e trace=open' suggests that these files aren't being looked for by epiphany. Also epiphany no longer asks if you want to 'remember' passwords.

epiphany-gecko: 2.21.4-0ubuntu3
epiphany-browser: 2.21.4-0ubuntu3

Changed in epiphany-browser:
status: New → Confirmed
Lee Maguire (leemaguire) wrote :

In addition to this, sometimes (for sites I have stored passwords) the entry boxes will not autofill. This is inconsistent and restarting the browser may result in the password being autofilled.

With Epiphany 2.21.90, No password data is stored and I have to log in to things each time I start Epiphany.

This has nothing to do with epiphany-extensions.

mithro (mithro) wrote :

I too have this problem - nothing in the personal data page, no logins being auto-filled and it is not asking to store passwords anymore.

My ~/.gnome2/epiphany/mozilla/epiphany/signons2.txt is fine and Privacy->Passwords->Remeber Passwords is checked.

Just a "me too" post to be notified about this. Sorry.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package epiphany-browser - 2.21.92-0ubuntu1

---------------
epiphany-browser (2.21.92-0ubuntu1) hardy; urgency=low

  * new upstream tarball 2.21.92
  * with 98_xulrunner1.9.configure.patch preapplied and autoreconf2.50 in
    diff.gz
    - add (not applied) 98_xulrunner1.9.configure.patch
  * drop gcc 43 patch (applied upstream)
    - delete debian/patches/12_gxx43.patch
    - update debian/patches/series
  * update 98_xulrunner1.9.patch to match new epiphany upstream version
    - update debian/patches/98_xulrunner1.9.patch
  * fix personal data manager (LP: #180205) and login auto form-fill
    - update debian/patches/98_xulrunner1.9.patch

 -- Alexander Sack <email address hidden> Mon, 03 Mar 2008 13:32:10 +0000

Changed in epiphany-browser:
status: Confirmed → Fix Released
Michael Gratton (mjog) wrote :

I've just upgraded to 2.22.0-0ubuntu5 in hardy (from gutsy) and have encountered this problem.

Changed in epiphany-browser:
status: Fix Released → Confirmed
mithro (mithro) wrote :

I have the following versions and the bug is fixed,
ii epiphany-browser 2.22.0-0ubuntu2 Intuitive web browser - dummy package
ii epiphany-browser-data 2.22.0-0ubuntu2 Data files for the GNOME web browser
ii epiphany-extensions 2.22.0-0ubuntu1 Extensions for Epiphany web browser
ii epiphany-gecko 2.22.0-0ubuntu2 Intuitive GNOME web browser - Gecko version

Michael Gratton (mjog) wrote :

It's definitely still occuring for me with:

ii epiphany-browser 2.22.0-0ubuntu5
ii epiphany-browser-data 2.22.0-0ubuntu5
ii epiphany-extensions 2.22.0-0ubuntu1
ii epiphany-gecko 2.22.0-0ubuntu5
ii xulrunner-1.9 1.9~b4+nobinonly-0ubuntu1
ii xulrunner-1.9-dom-inspector 1.9~b4+nobinonly-0ubuntu1
ii xulrunner-1.9-gnome-support 1.9~b4+nobinonly-0ubuntu1

All of my old cookies are gone, too, even though they still exist in ~/.gnome2/epiphany/mozilla/epiphany/cookies.txt

Michael Gratton (mjog) wrote :

It looks like the issue I was seeing was the same, but different: I had an old lock file hanging around in my profile directory that stopped the profile being loaded, hence not seeing any passwords in the manager.

Bug filed upstream if you want the full details (and the simple workaround): http://bugzilla.gnome.org/show_bug.cgi?id=524477

Apologies for the spam, resetting this bug to it's previous state.

Changed in xulrunner-1.9:
status: Confirmed → Fix Released
Changed in epiphany:
status: Unknown → New

I have the following versions and the bug is NOT fixed:

epiphany-browser 2.22.0-0ubuntu5
epiphany-browser-data 2.22.0-0ubuntu5
epiphany-extensions 2.22.0-0ubuntu1
epiphany-gecko 2.22.0-0ubuntu5

Changed in epiphany:
status: Fix Released → Confirmed

Please see the comment immediately above yours.

I did look at the previous post but it didn't help.

The problem I'm having is exactly as described in bug #189528 which has been marked as a duplicate of this one. That's why I added my comment here in the first place.

Now I realize that those two bugs are NOT the same so I will add my comments to the appropriate place.

Sorry for the confusion.

Changed in epiphany-browser:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Triaged
Changed in epiphany:
status: New → Won't Fix

Resetting this bug to "Fix Released".

I was the one who mistakenly set it to "Confirmed" (more then a year ago!). I have admitted my mistake but now I realised that I didn't set the status back to "Fix Released" as I should have done.

Sorry for the (long) delay.

Changed in epiphany-browser (Ubuntu):
status: Triaged → Fix Released
Changed in epiphany:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.