Epiphany does not start

Bug #1737083 reported by Randy Tang on 2017-12-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
epiphany-browser (Ubuntu)
Undecided
Unassigned

Bug Description

OS: Ubuntu 16.04 LTS
Epiphany:3.18.11-0ubuntu1

Epiphany does not start!

Using CLI to start it, the following error message showed up:

(epiphany:3361): GLib-GIO-ERROR **: Settings schema 'org.gnome.Epiphany.lockdown' is not installed
---
ApportVersion: 2.20.1-0ubuntu2.14
Architecture: amd64
CurrentDesktop: Unity
DistroRelease: Ubuntu 16.04
InstallationDate: Installed on 2017-08-30 (99 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
Package: epiphany-browser 3.18.11-0ubuntu1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.4.0-103.126-generic 4.4.98
Tags: xenial
Uname: Linux 4.4.0-103-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

Jeremy Bicha (jbicha) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:
apport-collect 1737083

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

apport information

tags: added: apport-collected xenial
description: updated

apport information

apport information

apport information

Jeremy Bicha (jbicha) wrote :

I don't understand what could be wrong here. epiphany-browser depends on epiphany-browser-data which includes the org.gnome.Epiphany.lockdown gsettings schemas.

Sebastien Bacher (seb128) wrote :

could you add the output of
"$ cat /proc/`pidof epiphany-browser`/maps"
to the bug

there might be an outdated schemas in /usr/local or something

Sebastien Bacher (seb128) wrote :

in fact since the binary doesn't start that's not going to work, could you start gedit and does that on it for example?

Randy Tang (yltang52) wrote :

Sorry to respond so late. What file do want me to open and get its content?

Randy Tang (yltang52) wrote :

FYI, the attached is `/var/crash/_usr_bin_epiphany.1000.crash`.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in epiphany-browser (Ubuntu):
status: New → Confirmed
Mélodie (meets) wrote :

Hi,

I am using Ubuntu 16.04 perfectly up to date, with an Openbox environment which makes use of openbox-menu. (https://packages.ubuntu.com/xenial/openbox-menu )

I also have lxpanel, with a classic menu. My version of lxpanel is 0.8.2-1ubuntu2 (There is a version of it being 9.3 upstream). My version openbox-menu is 0.8.0-1.

Openbox-menu makes use of the menu-cache lib from the lxde project…

Strangely, when invoked using the Applications menu in the Openbox menu, Web (epiphany-browser) starts fine!

When I add a quick start button in the quick start applications bar in lxpanel, a simple click does not start it, a double click starts 2 instances of it.

I does not start at all when using the Lxpanel menu "Internet > Web".

I have tried to remove all ~/.cache/menu/* files, and restart the session. I think "Web" could be started once from the menus, then no more. I have tried to start "epiphany" from the console, it worked every time.

I will also add my "_usr_bin_epiphany.1000.crash" file as a zip attachment.

Mélodie (meets) wrote :

PS: something is strange here, I just removed the _usr_bin_epiphany.1000.crash from the /var/crash directory, and now the "Web" launcher from the lxpanel menu works.

Could it be possible that this older version of lxpanel comes with some old version of libmenu cache and does not refresh fast enough to work right away after installing the package?

When I start it from console, I only get these warnings:

***********
$ epiphany

(epiphany:9764): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(epiphany:9764): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(epiphany:9764): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(epiphany:9764): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(epiphany:9764): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(epiphany:9764): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(epiphany:9764): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(epiphany:9764): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(epiphany:9764): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(epiphany:9764): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

***********

I would like to know how to get epiphany to work right away after starting it the first time, if possible to get it to work right away?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers